iPod has no music on it

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

Posts: 20
Joined: Sat May 18, 2019 5:29 am

iPod has no music on it

Post by Ravingoofy » Sat May 18, 2019 5:44 am

I synchronize my iPod with MediaMonkey today. After it finish I went to play the music on my iPod and my iPod stated there was no music on it; however, all the data is saved. My files are all mp3 and worked until this happen. I was hoping to evict iTune from my life. Please can anyone assist with helping me figure out why my iPod said there is no music on it, but has over 100G of music saved on it. Also, the music all worked till now. Please don't make me utilize iTune anymore.

Posts: 47547
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: iPod has no music on it

Post by Lowlander » Sat May 18, 2019 12:15 pm

Which version of MediaMonkey, what model iPod (and iOS if applicable) and version of iTunes (if iOS iPod) are you using?
Lowlander (MediaMonkey user since 2003)

Posts: 20
Joined: Sat May 18, 2019 5:29 am

Re: iPod has no music on it

Post by Ravingoofy » Sat May 18, 2019 7:19 pm

I'm running version

My iPod is an iPod Classic 6th Gen. 160G

Serial Number: 3141-5926

Posts: 20
Joined: Sat May 18, 2019 5:29 am

Re: iPod has no music on it

Post by Ravingoofy » Sun May 19, 2019 1:14 pm

Wrong serial number, but if you need the right on I can get it. I posted that half asleep. lol

Posts: 13286
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia

Re: iPod has no music on it

Post by Peke » Mon May 20, 2019 6:21 pm

iPod Classic along with iPod Nano are only two Apple devices that still do not use iOS and are bit harder to debug.

Can I ask you please to confirm that:
1. MMW sync worked in previous versions and estimate when this behavior started?
2. Whenever syncing a smaller group of tracks works?
3. if 2 worked, then try to sync all tracks again?
Best regards,
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
How to add SCREENSHOTS to forum


Classic iPod no longer syncing at all

Post by SadHouseDaddy » Tue Jul 02, 2019 5:31 pm

I've been using MediaMonkey for over a year with my 120GB Classic iPod and was finding it a dream compared to the nightmare of iTunes. I've installed the latest versions of MediaMonkey each time there has been an update and a few weeks ago I began to experience sync issues for the first time. Sometimes when adding just a few songs and the sync had finished the iPod revealed "No Music" whatsoever, though further attempts would often redress this and within moments the entire iPod's library would reappear including the new songs. Sometimes though the new songs would be listed on the iPod but wouldn't actually play. Now in the last 2 weeks I have been unable to sync the iPod at all, both MediaMonkey and the iPod appearing to be doing the necessary but upon completion and ejecting the iPod: "No Music". Sometimes the syncing process would be very slow and would stall for minutes at a time on a particular track, then speed up for a few minutes before stalling on another one. Sometimes the process takes hours and hours, but each time at the end I expectantly eject the iPod only to see once again: "No Music".

I am using a home computer with Windows 10. I have tried reinstalling MediaMonkey numerous times. I have tried MediaMonkey's "Rebuild Device database", but the operation repeatedly freezes after two or three seconds and MediaMonkey is no longer responsive. I have reset the iPod to factory settings using iTunes several times, both by downloading the latest version and also with an older version ( I have on a laptop (with Windows 7) I initially used with the iPod. I have an older version of MediaMonkey (version on the laptop that also will no longer sync any tracks to the iPod now.

Absolutely mystified as to what is going on and would greatly appreciate some advice!

Post Reply