Page 2 of 5

Posted: Sat Mar 31, 2007 6:37 pm
by Blake
1. Did you copy BOTH files Steegy provided links to.
2. Are they in the %Mediamonkey dir%\scripts\auto folder?
3. Are you running the MilkDrop visualization or something else?

Posted: Sun Apr 01, 2007 9:08 am
by kriscs1
blakeloth1 wrote:1. Did you copy BOTH files Steegy provided links to.
2. Are they in the %Mediamonkey dir%\scripts\auto folder?
3. Are you running the MilkDrop visualization or something else?

1. Yes
2. Yes
3. Yes, Milkdrop

Hmm, I just found that I called the file 'VisualisationEmbedder.vbs' instead of 'Visualisation Embedder.vbs' but after recopying the correct files, it still didn't work.

Posted: Sun Apr 01, 2007 6:11 pm
by Blake

It could be something not MM related. Can you run the visualization without the embedder there?

Posted: Mon Apr 02, 2007 3:33 am
by Steegy
Did you already start the visualisation yourself?, because the script can't do that for you. Once you have started the visualisation, it'll automatically get embedded in the "Embedded Visualisation" pane.

Posted: Mon Apr 02, 2007 4:42 am
by Guest
Yep. it works fine without the embedder and even once I've started the visualisation it still doesn't work. :(

Posted: Mon Apr 02, 2007 6:38 am
by kriscs1
Ah sorry. I misunderstood. You have to start the visualisation then open the panel. It works now. Oops

However, is there any way to automate this on start-up of mediamonkey? If not, I think I'll just get rid of it.

Thanks for the help guys and sorry for being a bit dumb :oops:

Posted: Mon Apr 02, 2007 8:54 am
by Steegy
No sorry. There's no way to automatically start the visualisation on startup. I have been working on a better solution, but I have a programming question here on the forums that hasn't been answered on yet, so it isn't finished yet.

Posted: Mon Dec 10, 2007 9:56 pm
by Big_Berny
Waiting for G-Force-support! Pleeeeeaaaaaasssseeeee! :)

Posted: Wed Dec 12, 2007 8:23 am
by Fraxav
Just installed the script and tried it.
It's really good and i agree that the embeddable visualizaition should be natively present in the new MM3 (or at least an option should be present which let you choose if you want the visualization embeddable or not).
As well, the "start visualization first and than launch the embedder script" thing is quite annoying, and it should be fixed :P
Thanks for this script :)

Posted: Wed Dec 12, 2007 9:03 am
by Big_Berny
@steegy: Or is there easy way to create that exe by ourself?

Posted: Thu Dec 13, 2007 3:51 pm
by Steegy
This should be something for MM natively. Point.

Some visualisations don't allow to be "embedded". I think G-Force did embed but immediately crashed after that, last time I tried.
Afaik, MilkDrop is the only stable-to-embed popular MM visualisation.

Posted: Fri Dec 14, 2007 11:58 pm
by scrapqueen
So far this script has worked flawlessly with me on each of the mm3 releases until RC4. Well, it works on RC4 until I uncomment line 25. When I do I get this error message: Image

When I go back and put the comment mark on line 25 the error goes away and the visualization works as it should and can be moved around but doesn't resize itself. Any ideas? My system is XP Home SP2

Posted: Sat Dec 15, 2007 8:40 am
by Steegy
What you did is uncomment the comment portion of line 23. This is confirmed by the error message.

You should leave line 23 as it is, but uncomment lines 4, 25, 33, 34, 52, 53 (i.e. for lines starting with the ' character, remove that character).


Posted: Sat Dec 15, 2007 10:55 am
by scrapqueen
Ah I see. Thanks so much. Works fine now.

Thank you

Posted: Wed Dec 19, 2007 8:20 am
by MM3 monkey
I just came to find out how to change the shortcut from Ctrl+Shift+V because deleting the inbuilt one for volume levelling didn't enable your one. [Line 11 of the embedded visualisation vbs file in your auto scripts folder, in case anyone doesn't know.]

I'm always opening and closing MM, it seems, so shortcuts are vital to ... close embedded panel -> open viz -> open embedded panel. Have you got any tricks you use, Steegy?

Anyway, I just want to say a very belated thank you. Should have said it ages ago.