WebSearch Panels (updated March 14, 2007) now with installer

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

MonkeyBone
Posts: 66
Joined: Sun Nov 19, 2006 9:39 am
Contact:

Post by MonkeyBone »

Hate to be an negative ass..

But, for me, it's "impossible" to use the WebSearch -panels without support for Firefox (and the add-on which support the removal of banners and such). It's really sad, because the possibilities with this feature is just marvelous! But; kudos to the guys here that makes it possible!! You're doing a great job!!

:)
[AMD Athlon 64 FX-60] . [Hiper Type-R 580W] . [Western Digital Raptor X] . [Lian Li PC777B]
[Hightech Excalibur Radeon x1900xtx 512 MB] . [OCZ EB DDR PC-4000 2 GB Pl.Ed. Dual Channel]
[DFI Lanparty UT RDX200 CF-DR] . [Creative SB X-Fi Fatal1ty FPS] . [DELL UltrasSharp 2405 FPW 24"]
3DMark05 : 11043 . 3DMark06 : 5856 . (a non-clocked system) . AudioScrobbler . Xfire . YMDb
baker

Post by baker »

aidan_cage wrote:I seem to be laggin whenever a song switches
I am curious to now, based on how the YouTube window will continue to play a video even when the WebSearch Panel is closed, whether or not the panel continues to refresh for content even when no window is open within the layout
is this happening for anyone?
I have same prob. Can script be turned off when all panels are closed?
asdf

Post by asdf »

If the panels aren't visible, they still load the web page... I found it out in Google Web History.
xvsteep
Posts: 6
Joined: Fri Oct 05, 2007 10:21 am
Location: Belgium
Contact:

Post by xvsteep »

Great apps.
Is there a possibility to add the Album Art through clicking a button (similar as to the lyrics or comment button) ?
MeMeMe
Posts: 263
Joined: Fri Dec 23, 2005 11:42 am
Location: In front of my computer
Contact:

Post by MeMeMe »

Sn3ipen wrote:I dont get this script to work.

When i am starting MM3 i get a error message that is saying something like this:

Error #457 - Microsoft VBScript-error
This key is allready conected to a element.
File: "MM3\scripts\Auto\WebSearch.vbs", Line: 504, column: 16

Does it have anything to say that i am running MM3 Beta?

Thanks for any help.
Did you find a solution? I had this error, and found the cause was a duplicate entry in my websearch.xml file.
drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA
Contact:

Post by drjboulder »

So, I have always loved this script.
However, I have just blissfully used it as it comes with the down loader. It was not until last night when I was wondering how I could modify it to include lyricwiki.org that I discovered, through this thread what a power house was lurking under my little "search the web" button!!!
:o
I was wondering if anyone could help me out with the parameters I need for the url to search on wiki lyrics?
This is what I have so far:

Code: Select all

<site>
      <name>LyricWiki</name>
      <caption>LyricWiki</caption>
      <description>Lyrics Search</description>
      <start>http://lyricwiki.org/Main_Page</start>
      <url>http://lyricwiki.org/search/%title%&artist=%artist%</url>
  </site>
I just totally guessed at the URL. How do I figure out what it should be?

Any help would be greatly appreciated!
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...
drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA
Contact:

Post by drjboulder »

As long as I have bumped this thread....

Anyone have any URLs for LRCs, for when mini lyrics does not return any results for synchronized lyrics?
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...
gege
Posts: 864
Joined: Tue Sep 05, 2006 2:10 pm
Location: Brazil
Contact:

Post by gege »

Code: Select all

<site>
    <name>lyricwiki</name>
    <caption>LyricWiki.org</caption>
    <description>Search for lyrics on LyricWiki.org</description>
    <start>http://lyricwiki.org</start>
    <url>http://lyricwiki.org/api.php?artist=%artist%&song=%title%&fmt=html</url>
</site>
Enjoy!
drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA
Contact:

Post by drjboulder »

Thanks for that, Gege!
Should have guessed it would be you who responded.

Having a problem, tho.
When I inserted the parameters that you suggested in the XML, I received these error messages when I open the Monkey:
http://picasaweb.google.com/djboulder/M ... 9519858962
&

http://picasaweb.google.com/djboulder/M ... 2534303010

Any ideas?

Thanks again!
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...
drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA
Contact:

Post by drjboulder »

gege wrote:

Code: Select all

<site>
    <name>lyricwiki</name>
    <caption>LyricWiki.org</caption>
    <description>Search for lyrics on LyricWiki.org</description>
    <start>http://lyricwiki.org</start>
    <url>http://lyricwiki.org/api.php?artist=%artist%&song=%title%&fmt=html</url>
</site>
Enjoy!
Gave up on getting this to work for a little while...

Now have it working. Think, maybe (:shrugs:), the reason for the code Gege offered was not working for me was the <caption>LyricWiki.org</caption>.

This is what I got to work:

Code: Select all

<site>
        <name>LyricWiki</name>
        <caption>LyricWiki</caption>
        <description>LyricsWiki Search</description>
        <start>http://lyricwiki.org</start>
        <url>http://lyricwiki.org/api.php?artist=%artist%&song=%title%&fmt=html</url>
  </site>
Works beautifully!
Highly recommend this for lyrics search - very clean.
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...
pitoresco
Posts: 13
Joined: Sat Jun 30, 2007 1:52 pm
Contact:

Post by pitoresco »

Can someone help me with www.plyrics.com?

An url example:

http://www.plyrics.com/lyrics/generatio ... yself.html

The problem is in the url, i think. The script does the search, but the page isn´t found. What i putt:

My code:

Code: Select all

<site>
    <name>PLyrics</name>
    <caption>PLyrics</caption>
    <description>Search PLyrics</description>
    <start>http://www.plyrics.com/</start>
    <url>http://www.plyrics.com/lyrics/%artist%/%title%.html</url>
  </site>
m_bojangles
Posts: 99
Joined: Fri Jun 11, 2004 8:22 pm
Contact:

Post by m_bojangles »

That's only going to work if you name all of your artists and song titles exactly the way the site uses them in their URLs. So the song would need to be titled "dancingwithmyself" in your MediaMonkey. It's probably called "Dancing With Myself". So there's no match.

For that particular site, the closest I can get is to use the search URL with the artist and song name. From there, you'd have to click on the correct entry.

The URL for Generation X's "Dancing With Myself" is: http://search.plyrics.com/cgi-bin/pseek ... ith+myself

So in your XML file, you can try:
http://search.plyrics.com/cgi-bin/pseek ... st%+%title%
pitoresco
Posts: 13
Joined: Sat Jun 30, 2007 1:52 pm
Contact:

Post by pitoresco »

m_bojangles wrote:That's only going to work if you name all of your artists and song titles exactly the way the site uses them in their URLs. So the song would need to be titled "dancingwithmyself" in your MediaMonkey. It's probably called "Dancing With Myself". So there's no match.

For that particular site, the closest I can get is to use the search URL with the artist and song name. From there, you'd have to click on the correct entry.

The URL for Generation X's "Dancing With Myself" is: http://search.plyrics.com/cgi-bin/pseek ... ith+myself

So in your XML file, you can try:
http://search.plyrics.com/cgi-bin/pseek ... st%+%title%
I've already tried the search url, but didnt get any results. Now worked. Many thanks. ;)
fuzzynavel

Saving Images to tag

Post by fuzzynavel »

Now I can load up a page in the websearch panel with a cover art image for the currently playing song! Great!

Problem: I can't drag the image from the websearch panel to the Album art panel to tag the file. I have to manually save the image to my HD, then go into the edit file dialog, find the file on the HD, and then save.

Why can't I drag from within Mediamonkey? It's frustrating to have the image displaying right there and not be able to save it to the file.

Any help would be great, thanks.
fuzzynavel

Oh, I See

Post by fuzzynavel »

Ah, I worked it out. It doesn't work when the image is embedded in the HTML page, but it seems to work when you actually find the direct link to the image on the web.
Post Reply