Page 3 of 4

Synology Cubestation CS407e

Posted: Fri Apr 11, 2008 2:39 pm
by theshawn
I am able to see my Synology Cubestation CS407e NAS, browse music by various ways...and play music too. Nice script!

Posted: Sun Apr 13, 2008 2:07 pm
by botijo
Hi, theshawn, GuHu,
thanks for testing and reporting it is working. Unfortunately, there has been no progress on the script. The video card in the laptop died, so I moved to a whole new computer. I am running Vista Home Premium right now instead of old XP, something I installed this weekend. And I can confirm that the script works with WMP11 in vista too.
Anyhow, the only thing left in my "things I want to do" is Album Art, and I am not sure it can be done. I am not following any more to fix any client/server communication - nobody can assure me that the servers are following the UPNP spec, or even explain why Windows rules out some of the servers out.
Believe it or not, I am not using the script I wrote, so I do not see any improvements that could be made: the script does what it is suppose to be doing. Maybe you can tell me anything you miss? Or even you could try to edit the script yourself. Comments inside the file were given for that purpouse.
By the way, thanks for testing the script!

Re: UPNP client script 0.5 [MM3]

Posted: Wed Aug 20, 2008 4:06 am
by macrbest
great script!

I'm just discovering Upnp Servers... but I'm wondering why:
- the search box of MM do nothing in the list of the script (except re-scanning everything) after click in the tree
- album art in ID3 tags are not shown

Re: UPNP client script 0.5 [MM3]

Posted: Wed Aug 20, 2008 3:10 pm
by botijo
Hi, Macbrst,
The way the script works makes it impossible for MM to know how to search the server. I will be out for some weeks, so I cannot look at this. As for AlbumArt, I wish I found a way to do that. Unfortunately, the way it is done at this moment, you cannot assign an URL as an AlbumArt. And I am not sure I can download AlbumArt and assign it to non-library songs. The script is yours to make any modifications.

Re: Dead Links

Posted: Sat Dec 20, 2008 11:48 pm
by JBDive
Can the author get an active host for the script location? Link to .5 is dead, .4 doesn't work correctly at least for me.
GuHu wrote:..
just tested it with Fritz!Box 7270, worked up to now perfectly!

Is there any progress on this script?

With regards and thanks,


Re: UPNP client script 0.5 [MM3]

Posted: Sun Dec 21, 2008 7:43 pm
by botijo
Thanks for trying to download the script. Somehow, the link does not work on Opera, but it does on Internet Explorer? WTF! I do not know how to resolve this except for moving the website to another place.
If you really want to get the UPNP client script, please download it via Internet Explorer. I will fix it whenever I am back at home in two weeks time.
And thanks for reporting the problem!

Re: UPNP client script 0.5 [MM3]

Posted: Sat Jan 03, 2009 1:11 pm
by M1ke
Hey, I posted some thanks in the Server thread and echo them here. I have two errors with this script, other than that it works perfectly.

Firstly on the same machine that is running the servers (XP running WMP 11 and MM3 UPnP) I get an "Error Executing Script" when I try to browse "Albums" on the MM3 UPnP server.

I also get this error on my XP laptop, and on that I also get an error when trying to access the "Music" node on the WMP share. I can play music fine if I view it in playlists, but I am told there is an error on line 171 if I try and view the "Music" node.

Re: UPNP client script 0.5 [MM3]

Posted: Sun Jan 04, 2009 1:42 pm
by M1ke
As an addendum to my previous problem - looking through the playlists there is one which produces the same error as attempting to view the "Music" node on the WMP server. Could there be something about a file in this playlist that is causing the problem? What errors could there be with the file and why do they only show when it is viewed from a different computer to the one running the server? Anyone got any ideas?

Re: UPNP client script 0.5 [MM3]

Posted: Mon Jan 05, 2009 4:00 pm
by M1ke
I've been reading up on MM scripting and have been trying to debug the code myself. The error that occurs only occurs on the Music node of a WMP11 server, giving error code 2147220975. However this code does not have any articles relating it to UPnP on MSDN. The error can occur occasionally when browsing playlists. Reading other forums suggests that this is a problem with the timeout of the Browse method (though I've been unable to find any list of InvokeAction methods for the UPnP API). As far as I can see there is no way to change this, but I will test it by clearing the library I am viewing and seeing if it will work then. It is worth mentioning that the function did work when I first started the server and installed the script, and I can't remember changing anything between then and a few hours later when it began failing.

A new error has become apparent today - that even when I can get at the Playlists on either the WMP11 server or the MM3 UPnP server I can't actually play anything. MediaMonkey adds the song to the Now Playing list, and can access the metadata. If I view properties the file name is in the form of the IP of the server, a port number (10284 for WMP11, 5050 for MM3 UPnP server) but the song won't play, and if another song is after it in the playlist it skips on after a few seconds. Opening the address in a browser has no result when using the WMP11 address, but prompts me to download the mp3 file when using the MM3 UPnP server.

If anyone has any experiene here or can use what I've said to work out the problems I'd like to hear it.

Re: UPNP client script 0.5 [MM3]

Posted: Sat Jun 06, 2009 11:17 am
by orkaowen

Sorry if this is a stupid question.

I've downloaded and installed 0.5, and their is a uPnP node showing up in MM. However, I don't see my device listed there.

I have a Streamium WAC75000 and was hoping that I could connect to it with MM.

Am I doing something wrong?


Re: UPNP client script 0.5 [MM3]

Posted: Sun Jun 07, 2009 5:06 am
by Maaspuck

i have the same problem like orkaowen.

I installed version 0.5 but don't get any Server listed. I have a router (DGL 4300) and a NAS (Buffalo Linkstation Pro Duo including Twonky Media Server).

Any suggestions what could be wrong. I had a short look at the script itself but am not sure whether i have to change it for my purposes. I didn't get any error messages and also found upnp.dll in the system32 directory of the system.



Re: UPNP client script 0.5 [MM3]

Posted: Tue Sep 22, 2009 1:02 pm
by wolle

all worked fine until I updated to iTunes 9.0 and MM beta. I'm able to browse my TwonkeyServer on my Qnap SS-439 but I'm not able to play any song. This worked fine before.

Cheers Wolle

Re: UPNP client script 0.5 [MM3]

Posted: Fri Sep 25, 2009 5:39 pm
by botijo
Well, as if you do not know already, I stopped development on this script some time ago. I might help you debug your problems, but first, you need to do something first: ... _DebugView
With DebugView (and probably a debug version of MM) you can view extra information coming from MediaMonkey. In the case of my script, if I remember correctly, it reports some extra info.
About the problem wolle has explained, I can reproduce the same issue with WMP11. The thing is, my script is not getting the proper URL for the songs for some strange reason. Wolle, can you double check this for me? Just browse a song, go to properties, and copy and paste the URL (http://) into a webbrowser. If this does not work, then the script is not interpreting the paths correctly.

Re: UPNP client script 0.5 [MM3]

Posted: Tue Sep 29, 2009 3:04 pm
by botijo
I have been looking at the script. Somehow, following method stopped working:

Code: Select all

NewSong.Path = ""
I am not sure why it stopped working. Using the same URI in the Add File or URL in MM makes this work. I will probably report a bug. Until then, I do not know how to fix this client script.

Re: UPNP client script 0.5 [MM3]

Posted: Fri Oct 02, 2009 6:55 pm
by botijo
Good news,
with the new MM beta build (1270), the issues with this script have been resolved. That does not mean there might be other problems, though.
Thanks for the developers for looking into this issue into such brief period of time. Special thanks go to Ludek.