AutoRateAccurate 2.4.3 (22/10/2009) - for MM3

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

kalowski
Posts: 64
Joined: Thu Aug 10, 2006 2:36 am

Post by kalowski » Sun Mar 23, 2008 6:35 am

Yep. Similar problem. When activated the Auto Rate seems to affect playback. It freezes on every previously unplayedtrack. I've just had to restart MM 5 time to play 5 tracks!
I've just disabled Auto Rate and they now play fine. :(

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Sun Mar 23, 2008 10:03 am

Hi guys,
just to let you know: I couldn't work on the script these days but I'll try to fix the bugs the next days. Unfortunately I can't reproduce any of the problems so it's difficult to get them... But I'll do my best! :)
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

spacefish
Posts: 1427
Joined: Mon Jan 14, 2008 7:21 am
Location: Denmark

Post by spacefish » Sun Mar 23, 2008 10:09 am

Berny, just to let you know: I almost always use Album Art with Details view and that may contribute to the problem. According to Petr, all the bugs I've reported since I installed 1147 yesterday may be related to Album Art views.
Image
MM Gold 3.0.3.1183 : Vista HP SP1 (x86) : Zen Stone (2GB)
Zekton: An original MM3 skin by Eyal.
Scripts in Use: Add/Remove PlayStat | Auto Album DJ | AutoRateAccurate | Backup
Case & Leading Zero Fixer | Classification & Genre Changer | Clean Scripts.ini | Clear
Field | Custom Report | Discogs Auto-Tag Web Search | Forget Crossfade | Invert
Selection/Select None | Last 100... | Lyricator | Lyrics to Instrumental | MonkeyRok
MusicBrainz Tagger | My Custom Nodes | Now Playing Art Node | Play History & Stats
Right Click for Reports | Right Click for Scripts | Right Click for Web | Stop After Current
WebNodes

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Sun Mar 23, 2008 10:11 am

Yeah, saw that too. But I think that people also had some problems with the older MM-beta.

Who had problems with MM 3.0.3 Beta 1?
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

PhilDG
Posts: 146
Joined: Sun Dec 30, 2007 6:14 am
Contact:

Post by PhilDG » Sun Mar 23, 2008 1:05 pm

I had plenty of problems with build 1147 but rolling back to the previous solved them. Seems that build had plenty of bugs.
I nearly always use the album art view and have only really had problems with 1147.

spacefish
Posts: 1427
Joined: Mon Jan 14, 2008 7:21 am
Location: Denmark

Post by spacefish » Sun Mar 23, 2008 1:12 pm

PhilDG wrote:I had plenty of problems with build 1147 but rolling back to the previous solved them. Seems that build had plenty of bugs.
I nearly always use the album art view and have only really had problems with 1147.
Same here although I haven't rolled back (yet) because 1147 fixes the invalid track ID bug. I will likely roll back though and remove the trigger scripts if they can't get all these 1147 errors handled soon. 1140 gave me no issues beyond that.
Image
MM Gold 3.0.3.1183 : Vista HP SP1 (x86) : Zen Stone (2GB)
Zekton: An original MM3 skin by Eyal.
Scripts in Use: Add/Remove PlayStat | Auto Album DJ | AutoRateAccurate | Backup
Case & Leading Zero Fixer | Classification & Genre Changer | Clean Scripts.ini | Clear
Field | Custom Report | Discogs Auto-Tag Web Search | Forget Crossfade | Invert
Selection/Select None | Last 100... | Lyricator | Lyrics to Instrumental | MonkeyRok
MusicBrainz Tagger | My Custom Nodes | Now Playing Art Node | Play History & Stats
Right Click for Reports | Right Click for Scripts | Right Click for Web | Stop After Current
WebNodes

LordHades
Posts: 53
Joined: Sat Sep 29, 2007 4:45 am
Location: The Netherlands
Contact:

Post by LordHades » Sun Mar 23, 2008 1:35 pm

I'm using 1140 on the moment, and it gives me problems with the beta script,I have installed 2.1 on the moment and that works fine.

Johonn
Posts: 7
Joined: Thu Jun 15, 2006 8:17 pm

Post by Johonn » Sun Mar 23, 2008 7:17 pm

Well first off i just started using ARA and so far so good. There are just some tweaks i would like to suggest.

While the percentage for each star rating is nice it seems to be off balance without another calculation taking place. What i mean is: i rarely reboot and i am lucky to even restart MM. This causes the AutoCalc to run less then it should. Which causes either high or low ratings. High was if a new song played for the first time and played all the way through the song and low if i skipped it. Since i just started using ARA my auto ratings were either 1 or 5 stars, nothing else. I restarted MM and now i get 4.5 stars or 2.5 stars.

I know this is because it has reran the AutoCalc and balancing my auto ratings for the percentage of each star i set. That got me thinking of how it could be tweaked a little more. The only option i can think of (right now) is how long the song is played for in percentages before being skipped.

ex. The current calc is "(Played-Skip^1.7)". What if we could change it to say (Played-Skip^Percent-Played). Where percent played was able to be user-configed in 5 levels. Configured in the way of percentage of the song played

ex.
Song played (%)
0-10% = 1.7
11-30% = 1.5
31-50% = 1.3
50-75% = 1
76-100% = .75

What i am saying is if i skipped a song right away then it should get a rating lower then if i skipped a song at say 60% done.

Thoughts?????

spacefish
Posts: 1427
Joined: Mon Jan 14, 2008 7:21 am
Location: Denmark

Post by spacefish » Mon Mar 24, 2008 12:48 am

Can't you just calibrate/autorate manually? Hit the star button everyday when you wake up. :wink:
Image
MM Gold 3.0.3.1183 : Vista HP SP1 (x86) : Zen Stone (2GB)
Zekton: An original MM3 skin by Eyal.
Scripts in Use: Add/Remove PlayStat | Auto Album DJ | AutoRateAccurate | Backup
Case & Leading Zero Fixer | Classification & Genre Changer | Clean Scripts.ini | Clear
Field | Custom Report | Discogs Auto-Tag Web Search | Forget Crossfade | Invert
Selection/Select None | Last 100... | Lyricator | Lyrics to Instrumental | MonkeyRok
MusicBrainz Tagger | My Custom Nodes | Now Playing Art Node | Play History & Stats
Right Click for Reports | Right Click for Scripts | Right Click for Web | Stop After Current
WebNodes

Johonn
Posts: 7
Joined: Thu Jun 15, 2006 8:17 pm

Post by Johonn » Mon Mar 24, 2008 8:29 pm

yes, i could hit the star to autorate but it does takes some time to go through my entire collection since i am counting skipped songs. I am lazy i don't want to have to do that everyday. I am guessing since i have not had to much time to dig through the code that it will only take longer and longer as i play more and more songs and skip more and more songs.

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Mon Mar 24, 2008 10:16 pm

Hi Johonn,
what you experience here only happens atr the very beginning with a fresh database! After some days/weeks the script gets stabler and you don't have to run the AutoCalibration as often anymore and you won't notice such rating jumps anymore. And as spacefish said you also just can click on the star to AutoCalibrate and re-calculate all ratings again. I recommend to do that anyway from time to time because it also optimizes the ratings of older songs. And it won't get much slower by the way - also when you skip/play more and more songs!

But I already have a feature on my todo-list which would be useful in your case (specially with fresh database). Don't know when I can implement that though as my time is limited and I first want to improve the stability of the script by fixing all bugs the others experienced.

Regards
Big_Berny :)
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

theshawn
Posts: 14
Joined: Thu Feb 28, 2008 12:41 pm

Sync ratings from iPod back to MM?

Post by theshawn » Wed Mar 26, 2008 4:33 pm

I read in another thread how ARA was good with portable players and ratings, but I can't seem to find the details of how or what. So, I'll just say what I want and see if there are ideas... When listening to songs on the iPod, when I run across one I don't care to hear again, I mark it with 1-star. Is there any way that ARA would pull those ratings back into MM?

drjboulder
Posts: 1119
Joined: Mon Apr 09, 2007 12:03 am
Location: Boulder, Colorado, USA

Re: Sync ratings from iPod back to MM?

Post by drjboulder » Thu Mar 27, 2008 1:50 am

theshawn wrote:I read in another thread how ARA was good with portable players and ratings, but I can't seem to find the details of how or what. So, I'll just say what I want and see if there are ideas... When listening to songs on the iPod, when I run across one I don't care to hear again, I mark it with 1-star. Is there any way that ARA would pull those ratings back into MM?
The rating should change in the monkeys Database (and tag) during auto-synch. ARA would then see it as manually rated and ignore it in its formula if that option is checked in the options dialog.
D Rock
Image
MediaMonkeyGoldv3.0.3.1183
Vista Home Basic|4thGen 20GPod
Zune Small Player Skin w/ Aqua 4 Player Mod
Backup | Last FM Node | Scrobbler DJ | TopTracks | StayInSameStyleDJ
RadioDJ | RadioFreeMonkey | PrettyPictures | MiniLyricsEmbedder
LyricsViewer | Lyricator | LyricsPlugin | VisualizationEmbedder | MonkeyRok
RightClickForWeb | WebSearchPanels | WebNodes | MagicNodes | FavoritesNodes
NowPlayingArtNode |AutoRateAccurate | TaggingInconsistencies
AdvancedDuplicateFind&Fix | CaseModify | PlayHistory&Stats | Etc...

LordHades
Posts: 53
Joined: Sat Sep 29, 2007 4:45 am
Location: The Netherlands
Contact:

Post by LordHades » Thu Mar 27, 2008 8:22 am

OK,

well i'm pretty sure it's the 2.2 version of the ara script that causes my problem the 2.1 version works fine :) I am using the 1140 build still but i can upgrade tonight and try it again. Btw is it possible you upload the beta 4 of the script so i can check if it has the same problem as the beta 4.

Big_Berny
Posts: 1784
Joined: Mon Nov 28, 2005 11:55 am
Location: Switzerland
Contact:

Post by Big_Berny » Fri Mar 28, 2008 7:20 pm

Hi theshawn,
the sript is good to use with portable players like ipod because it uses the playcounter in stead of the played-table. This has the advantage that also the plays from the ipod are used to calculate the ratings. The played-table which is used in another autorating-script has the advantage that you have more details about the different plays. So for example you can look how much a song has been played the last X days.

About your other question: MediaMonkey should automatically sync the the ratings from your ipod back to the pc. And in my script you can set in the options that only songs without a manual rating (also when rated on a ipod) will get an AutoRating.

Hope that helps.

@all: By the way I hope that I can release the next beta soon which will store a log-file which should help to get all your problems.

Big_Berny
Image
Scripts in use: Genre Finder / Last.fm DJ / Magic Nodes / AutoRateAccurate / Last.FM Node
Skins in use: ZuneSkin SP / Eclipse SP
AutoRateAccurate 3.0.0 (New) - Rates all your songs in less than 5 seconds!
About me: icoaching - internet | marketing | design

Post Reply