Page 23 of 64

Posted: Sat Mar 29, 2008 11:31 am
by Johonn
Big_Berny,

Thanks for the update. It will be interesting to see what you have on your list of updates to the script.

Posted: Sun Mar 30, 2008 8:13 am
by Big_Berny
For now I'll fix all problems first. After that I'll introduce a new feature but this is probably in version 2.3.

Btw I still can't reproduce any of the problems...

Posted: Fri Apr 04, 2008 11:02 am
by Big_Berny
A question: Noes anyone else except LorhHades has problems with the last beta of this script and MM 3.0.3 Beta 3?

Posted: Fri Apr 04, 2008 11:23 am
by LordHades
ok updated to 1147, removed the 2.1 script restarted MM to see if it was really gone, shutdown MM and installed the beta5 manually. Started listing first song which was 1 minute as soon as it skipped to second song it froze and i had to restart MM

Posted: Fri Apr 04, 2008 7:06 pm
by Big_Berny
Ok, I created a debug version of Beta5. It creates a log-file with the name "AutoRateAccStarter.vbs.log" in the Script/Auto-folder. When you had a crash please send it to me immediately. This is important because after restarting MediaMonkey the log will be cleaned. So just send it or post it her in a code-box. Then I can have a look and find the problem.

At the moment the logs are very basic. So maybe I'll have to make it more detailed as soon as I know where the problem is.

Download: AutoRateAccurate 2.2 Beta 5 Debug (Only manual setup for now! So just extract the files into the Scripts/Auto-folder)

Thanks for your help! :)

Posted: Fri Apr 04, 2008 7:55 pm
by LordHades
Ok thanks

Installed it and playing some songs on the moment also the cd which made MM hang last time but so far it's working ok. I'll keep using the beta5 and when it hangs i'll make a post with the error in it. But i hope it works ok now :D

update: It didnt crash sofar :) so it's going ok for the meanwhile i'll keep using the debug version then.

update2: well many songs later still no crashes restarted MM a few times for scripts and stuff like that and still going strong also on the album that hanged the most. Perhaps the change to ntfs changed something that's the only thing I changed before installing the script again.

Posted: Sat Apr 05, 2008 12:08 pm
by LordHades
Ok it crashed

PC was repairing a movie i downloaded with newsleecher and this is the log:

Code: Select all

**Start AutoRateAccurate**
**Start OnStartUp**
**Start Initialize**
Enabled = True
CustomField = Custom5
WritePoints = False
AutoRecalibrate = True
ManualRatings = 2
BaseRatingEnabled = True
BaseRating = 2
RateNonPlayed = True
SkipDetection = False
MinSkip = 10
MaxSkip = 80
SaveToTag = True
FormulaSelect = Big_Berny_1
Formula = (10000000 * (7+Played-Skip^1.7)^3 / (10+DaysSinceFirstPlayed)^0.5) - DaysSinceLastPlayed
SpreadFive = 1
SpreadFourToFive = 2
SpreadFour = 3
SpreadThreeToFour = 20
SpreadThree = 37
SpreadTwoToThree = 27
SpreadTwo = 10
SpreadOneToTwo = 0
SpreadOne = 0
SpreadHalf = 0
PointsFive = 000002198017700
PointsFourToFive = 000002104441730
PointsFour = 000001543738083
PointsThreeToFour = 000001478016688
PointsThree = 000000000000000
PointsTwoToThree = 000000000000000
PointsTwo = 000000000000000
PointsOneToTwo = 000000000000000
PointsOne = 000000000000000
PointsHalf = 000000000000000
AutoRecalibrateNow = True
OldestDateAdded = 2008-04-04
**End Initialize**
Load menuitem
**Register event**
**End OnStartUp**
**Start SkipDetection**
**Start AutoCalibration**
Set SongIter
Analyse songs
Sort Pointlist
Calculate Points and write to ini
**End AutoCalibrate**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**
**Start SkipDetection**
**End SkipDetection**
**Start AutoRateLive**
Real start
Process changed songs
Save tag
**Start AutoRateLive**
**End AutoRateLive**
**Start AutoRateLive**
**End AutoRateLive**
**End AutoRateLive**

Posted: Sat Apr 05, 2008 1:11 pm
by Big_Berny
That's strange because wasn't running when crashing... So the problem is somewhere else. Probably it's a MM bug. Because I don't have this problem on both of my systems: XP and Vista. Can you send a report to the MM-devs when it crashs?

Big_Berny

Posted: Sat Apr 05, 2008 1:16 pm
by LordHades
Yeah will do, strange thing is I dont get a send a bug report msg when it crashes it just freezes. But i'm starting to get a feeling it has something to do with reparing files with par parhaps memory related or something. Anywayz it's working fine now again when i restarted MM again.

Posted: Sat Apr 05, 2008 1:22 pm
by Big_Berny
OK, so just keep an eye on it.

Does anybody has other problems with this beta?

Posted: Sat Apr 05, 2008 1:31 pm
by nynaevelan
Berny:

I had ARA disabled for a little while because I was doing some mass-editing, anyway I've just installed 1155 so I am not sure if this is affecting the script but now that I have enabled ARA, it starts to autorate but it just stops (or it is moving so slow the progress bar isn't moving), I am using the original B5 version. Any ideas what the problem is?

Nyn

EDIT: Berny, don't know what was causing the lockup but it has stopped now so I'm back on track. 8)
I think it might have something to do with running two MM's with two different databases at the same time.

Nyn

Posted: Sat Apr 05, 2008 3:00 pm
by Big_Berny
I'll post a modifed script version which gives a more detailed log-file so that I can get the problem.

EDIT: Just posted before you have edited your posting. So I'll wait untill tomorrow and when there's no new problem then I'll release it as final. There's a little improvement since beta 5 but anything else stay the same.

bad crash :-(

Posted: Mon Apr 07, 2008 8:13 pm
by kazadharri
BB,
I had to remove ARA from my MM as it was crashing before the application would even start.

I am running 3.0.3.1155

I think I might be able to send you a log file, but I don't know what it will tell you. As it is befor the program even finishes opening.

/Jeff

Posted: Mon Apr 07, 2008 10:59 pm
by Guest
No problems here just wondering how ARA handles files played on a portable device... I have quite a bit of music that has only been played on a mp3 player so when MM transfers the counts back to the files ARA actually rates them lower comparitively to songs that I play on the computer!?! It looks to me that its treating those one as skipped or something. If I play a song once on the computer it will get a rating of 3 stars. If I play it on the mp3 player it gets 1.5 stars on sync. Also I noticed a weird date or time code in the custom field:

1/3/1954 or
12:00:00

Lastly I also noticed why perusing the custom fields i have about 1 in 5 that say MR i figured this stood for manual rating? I have never manual rated any song. Does this mean that ARA has quit rating anything that says MR? Some of those files i would select unknown rating and the custom field would change to AR but the rating stayed the same amount of stars. Just wondering of any changes that I can make to make songs rate better that are actually being played. Thanks!

Posted: Tue Apr 08, 2008 1:44 am
by Spazz
What player? does it sync last played date/time along with the playcount? If not that is why.