Page 78 of 100

Re: Backup 5.8 - Updated 27/10/2010

Posted: Thu Nov 21, 2013 10:54 am
by dtsig
Lowlander wrote:This Addon can't create large ZIP archives (limitation of zip library used) something that has been discussed a long time ago (I ran into that issue some years ago). I don't remember the max size supported, but it isn't more than a few 100MB.
Then wouldn't it be nice if there was a big banner on the front page saying CANT DO IT ON LARGE (who knows how big ... it is a surprise) DATABASES. Is it really expected that someone looking for something to work would read all 3 years worth of posts to gleam this information.

Or if not warn the user of the limits of the mini backup system before they put their trust in it .. at least enhance the message box to play a happy irish jig and have little fireworks with the message "You have reached the magical limit where this tool no longer works ... YEAH for you!!!"

Or maybe best ... ad the ability for the user to select an alternate zipping program (one that works for large files) that they may have .. say winzip, winrar etc .. and have the program use that.

Oh well .. thanks for the info. Now I know why i lost nearly a month of work.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Thu Nov 21, 2013 10:56 am
by dtsig
gpzbc wrote:Trixmoto has tested it up to 660 mb. ... ze#p266977

Lowlander has confirmed that 800 mb is too big. ... ze#p263377
Thanks gpzbc ... I hope someone finds it important enough to add this info to the very beginning of the info for Backup. Or it is probably right there and I missed it

Re: Backup 5.8 - Updated 27/10/2010

Posted: Fri Nov 22, 2013 4:24 am
by trixmoto
There's no warning because the script is supposed to handle this situation, by copying the database file into the same folder as the zip file, instead of trying to include it in the archive, which from your screenshots, is exactly what has happened. So what's been lost?

Re: Backup 5.8 - Updated 27/10/2010

Posted: Fri Nov 22, 2013 3:44 pm
by dtsig
Trixmoto .. you are right in the long run. When trying to use the DB file I continued to get the 'cant open blah blah'. It did turn out that the service in fact was starting and locking the file while MMW was trying to start. So once I got that all worked out (reboots, kill service, reboots etc) the previous file copied by BACKUP worked.

1) I am sorry that i might have impugned the voracity of BACKUP. It almost does what it seems to state with the addition of the copying of files. I was unsure when I saw the db files why they were there for some and not others. Maybe this would be a good add to the first page (see #2). I think the real problem came when trying to unzip the zip as I normally would it came back with the image below.

2) I think it would be very nice to add a big note to the beginning of the Backup thread explaining that the ZIP is incapable of handling large databases (and give a best guess as to the size) and that at that time it will simply copy the mm.db file to the directory. This is really important.

3) When this 'size' is reached please give another message than simply the one with the success lines at the beginning. If something goes wrong give a big HEY BUDDY ...

4) How about adding an option to call say 1 of a couple other zip tools. Say winrar and winzip .. maybe with the ability to add another command string if the user figures out how to call the product they want.

Image of bad unzip:

I do really like BACKUP and have happily pointed others to it. A couple have fairly large dbs and I will be warning them of this possiblity.


Re: Backup 5.8 - Updated 27/10/2010

Posted: Sat Nov 23, 2013 12:50 pm
by trixmoto
Ok, I'll definitely take a look at the zip file being corrupted, because that definitely shouldn't happen. I'll do some testing to work out the maximum size, although from what I recall, it's actually system dependent. I'll work on trying to get the script to handle this situation better, given your suggestions. I'm not sure about interfacing with other products with the command line, I use the included one because I can access it via COM methods, which makes it much easier to communicate with, but I can play about and see how much success I have.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sat Nov 23, 2013 9:23 pm
by dtsig
Thanks man .. that is great. I really loved the product (and something else you did but can't remember right off). I think it was the combination of the service messing up and then trying to unzip and getting the corrupt error AND probably a little short because of the pain meds i have been on. If there is anything I can to do to help including sending (or making available my db and *bad* zip files) let me know.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Tue Nov 26, 2013 4:23 am
by trixmoto
No worries, I'll take a look when I get a chance.

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sat Dec 07, 2013 2:39 am
by sperk
Why do I get "backup cancelled because output folder already exists"?

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sat Dec 07, 2013 10:43 am
by dtsig
There is an option to overwrite the existing folder. And do you have full rights to the directory?

Re: Backup 5.8 - Updated 27/10/2010

Posted: Sat Dec 07, 2013 4:08 pm
by gpzbc
sperk wrote:Why do I get "backup cancelled because output folder already exists"?
In addition to what dtsig wrote, check out these few posts. I think they will answer your questions. ... 05#p338056

Good luck! And let us know if you have more questions.

Restore, DB malformed

Posted: Wed Jan 01, 2014 6:24 am
by lizat
Dear Monkeys,

I have been trying to restore my library from a backup using Trixmoto's Backup&Restore utility. Since something seems to have changed on my machine - although I can't for the life of me workout what or why - I wanted to use the files manually. I assumed that the copy of the database in the backup folders is simply a copy. However on doing a fresh install they copying the db to the right folder I get a number of errors suggesting the file can't be read. They all follow this pattern:
There was a problem querying the database:
Could not retrieve data "SELECT Songs.*FROM Songs WHERE Songs.IDMedia=? AND Songs.SongPath=?": database disl image is malformed (11,11)
And this is true for all the backups I have.

1. Is the file in the backup folder a simple copy?
2. does trixmoto's restore routine do something additional that I need to do to make it valid?
3. If it is a simple copy what would cause this error?
4. why would all my copies show this error - I have at least 12 backups

I can reconstruct the library relatively easily but what is a nuisance is losing the playlists

Many Thanks......................liz

Re: Restore, DB malformed

Posted: Wed Jan 01, 2014 11:24 am
by trixmoto
It just does a straight cope of the database file, it doesn't do anything else, so I have no idea why it would be malformed, sorry.

Re: Restore, DB malformed

Posted: Wed Jan 01, 2014 1:40 pm
by lizat
Ok. Fortunately I found a not too old copy that I had on another machine so OK now. I will monitor Backup and see what is going on.

Thank you Trixmoto, I love your add-ons!


Backup 5.8 Activex error (Windows 7 )

Posted: Wed Jan 01, 2014 2:07 pm
by lizat
Dear Monkeys,

I have a new install of MM to replace one that got corrupted. I have now added all the add=ons that I want including Trixmoto's Backup 5.8. To test that I had set it up correctly I ran but got this error:

Script: [path]
Line : 12
Char: 11
Error ActiveX component can't create object:
Code: 800A01AD
Microsoft VBSscript runtime error

The path was my Roaming directory. I am running Windows 7. Backup used to work fine on the previous installation on this machine, although the reason for needing to reinstall was because MM suddenly thought it was a new installation and didn't recognise anything so I cut my losses, removed everything and made a clean installation, then copied the original db.

There are a couple of posts similar to this but they aren't quite the same situation. Although I wonder if it's to do with permissions?

What should I check, and how do I fix it?

Thank you...........................liz

Re: Backup 5.8 Activex error (Windows 7 )

Posted: Wed Jan 01, 2014 2:52 pm
by lizat
Without having changed anything, other than I was allowing the backup on exit to run rather than an ad-hoc, everything is now working.... don't you hate that when it's fixed and you don't know why!!!

Thank you