Page 88 of 99

Re: Backup 6.0 - Updated 01/07/2014

Posted: Mon Mar 23, 2015 8:26 am
by dtsig
In your backup directory there should be a 'restore.vbs'. You should be able to d-click this file and it in turn should install.
Is this not happening for you?

Re: Backup 6.0 - Updated 01/07/2014

Posted: Mon Mar 23, 2015 6:46 pm
by Hdhntr23
I didnt even know where to begin!

I'll try it and report back.

Thanks a ton!

Re: Backup 6.0 - Updated 01/07/2014

Posted: Tue Mar 24, 2015 6:01 pm
by DakuTree
A bit of warning to those using the "delete old backups" portion of this script.
If you ever run this script somewhere other than your main backup folder (even by accident), you may want remove the row containing that location from the DB.
The script deletes "everything" from the old backup locations, regardless if it's an MM backup or not.
So for example, if you ran it on the root of an HD at some point...well, you're in for a bad time. Learned that the hard way :|

Re: Backup 6.0 - Updated 01/07/2014

Posted: Tue Mar 24, 2015 7:25 pm
by gpzbc
Thanks for the tip!

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed Mar 25, 2015 9:58 am
by dtsig
Wow ... That should be corrected

Re: Backup 6.0 - Updated 01/07/2014

Posted: Fri Mar 27, 2015 1:28 am
by dypsis
DakuTree wrote:A bit of warning to those using the "delete old backups" portion of this script.
If you ever run this script somewhere other than your main backup folder (even by accident), you may want remove the row containing that location from the DB.
The script deletes "everything" from the old backup locations, regardless if it's an MM backup or not.
So for example, if you ran it on the root of an HD at some point...well, you're in for a bad time. Learned that the hard way :|
I have never had that happen to me.
Or do you mean that you didn't put your backup in a folder?

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed Apr 29, 2015 1:41 pm
by trixmoto
That's exactly what it does, and that's exactly why it outputs a confirmation message asking you if you're sure, which a count of how much would be deleted! It has to do a clean up, otherwise when you delete scripts and stuff, they wouldn't be deleted from the backup.

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed May 20, 2015 12:59 pm
by terrypin
I've just installed Backup 6.0. When I close MM I consistently get an error message. I've shown it below, together with the contents of my four Scripts folders.

https://dl.dropboxusercontent.com/u/401 ... -BU6-3.jpg

Presumably I should get a pop-up telling me the backup was successful?

I assume that no backup has been made, but where should I look for it?

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed May 20, 2015 1:10 pm
by terrypin
DakuTree wrote:A bit of warning to those using the "delete old backups" portion of this script.
If you ever run this script somewhere other than your main backup folder (even by accident), you may want remove the row containing that location from the DB.
The script deletes "everything" from the old backup locations, regardless if it's an MM backup or not.
So for example, if you ran it on the root of an HD at some point...well, you're in for a bad time. Learned that the hard way :|
Ah, I reckon that must be what happened to cause my catastrophe! Although in my case, it was at least partly my own fault as I was apparently using an old backup, 3.8, from MM v3. Took me two days before I realised it was MM's backup that was losing my 300 GB. See this thread if you want more details:
http://www.mediamonkey.com/forum/viewto ... 35#p408435

I've got past that but have just posted about the remaining error message, which is how I came to read your warning.

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed May 20, 2015 1:52 pm
by dtsig
terrypin wrote:I've just installed Backup 6.0. When I close MM I consistently get an error message. I've shown it below, together with the contents of my four Scripts folders.

https://dl.dropboxusercontent.com/u/401 ... -BU6-3.jpg

Presumably I should get a pop-up telling me the backup was successful?

I assume that no backup has been made, but where should I look for it?
Did you look in the folder you specified in the options?

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed May 20, 2015 2:06 pm
by MMFrLife
Check out my last post in the other thread.

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed May 20, 2015 3:45 pm
by terrypin
dtsig wrote:
terrypin wrote:I've just installed Backup 6.0. When I close MM I consistently get an error message. I've shown it below, together with the contents of my four Scripts folders.

https://dl.dropboxusercontent.com/u/401 ... -BU6-3.jpg

Presumably I should get a pop-up telling me the backup was successful?

I assume that no backup has been made, but where should I look for it?
Did you look in the folder you specified in the options?
I didn't see any options during installation and couldn't find them in MM.

Any ideas about the error message?

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed May 20, 2015 3:49 pm
by terrypin
MMFrLife wrote:Check out my last post in the other thread.
Not sure I follow. Both references to the MM backup script were meant to be identical. It was v 3.8.

What little folder do you mean?

Re: Backup 6.0 - Updated 01/07/2014

Posted: Wed May 20, 2015 4:59 pm
by MMFrLife
terrypin wrote:Not sure I follow. Both references to the MM backup script were meant to be identical. It was v 3.8.
When you first mentioned the script and then said MM's script it threw me. I got it now, as that's what I figured you meant. I just wanted to make
sure I was on the same page.
terrypin wrote:What little folder do you mean?
Forget the term "little" folder, I was thinking of something else (a little distracted) when I first wrote that (sorry :-? ). This is what I meant to say:
From what DakuTree was warning against, that you referenced above, did you ever run the script from an old backup folder, no right? It just seemed to back stuff up on it's own, not use the delete old backups feature. Nothing went missing in any MM script or backup folders, right? The things that kept disappearing were mostly in other locations, (like documents, etc.), right? So, in conclusion, I just figured that the script (old version) had something to do with the original problem, but not the specific thing that DakuTree is talking about.

Anyway, the question is what to do now? I'll let you know if I think of something else.

Re: Backup 6.0 - Updated 01/07/2014

Posted: Thu May 21, 2015 3:20 am
by terrypin
MMFrLife: Understood, no problems. I'm pretty relaxed now that I don't have another day of massive data recovery ahead!

I'm hoping the script's author, trixmoto, will come along and help me to isolate the cause, with future prevention in mind. Despite the fact that it was almost certainly because I'd placed one or more MM scripts in the wrong location (probably one of those three for Backup 3.8 or earlier), IMO no MM script should allow indiscriminate deletions, and certainly not on the root of the OS drive. As you'll recall from my earlier posts, I had no warnings and it was many hours later that I discovered the loss in C: and C:\Docs (alias for My Documents).

trixmoto: I'm no programmer or scripter but I'll happily help any forensic work under your direction.

I've stared at Backup.vbs, ABackup.vbs and ABackup2.vbs in my text editor looking for clues in vain. Note that all my old version scripts have now been deleted or copied to a folder I used while trying to sort out all the old and new VBS files (all with same names), K:\Copy of all MM Scripts.

Anyone: Where do I find the options dialog for Backup 6 please? I see nothing under Options or Extensions. I still don't know what output folder it's using, so that I can check if I have any backups. Also, how long should a backup of 7800 tracks take? I've just closed MM (to check that the error message still appears), but after 5 mins the HD activity (but low CPU resource) has still not finished.

10 mins now!What can it be doing? I'm nervous now, so I've used Task Mgr to end the WSC process. Files still intact.