So tired of deteriorating UPnP support

Get answers about how to share with different devices.

Moderator: Gurus

Posts: 827
Joined: Sun Sep 21, 2008 9:35 pm
Location: Cupertino, California

So tired of deteriorating UPnP support

Post by mcow »

MMA 1.3.3, running on LegacyOS (Marshmallow) on my old Samsung tablet.
MMW 4.1.20, running Windows 10 Home.

I added a new UPnP server to MMW with "update play counter" enabled so that the server will scrobble; this is for the case where I'm playing through a ChromeCast Audio. This server copied over all the existing UPnP/DLNA client devices, and disabled them all. So when I tried to connect, I got "access denied." Rather than blanket-enable everything, I removed all the old devices and tried to reconnect; MMW put up the dialog requesting permission, which I granted, and got an entry for MediaMonkeyAndroid/1.0 Cling/2.0. All good: browed to the library, picked an album to play.

No sound. Tried and retried, wouldn't play; returned to the computer and discovered another request for access permission, which I granted, and now there's a second entry: Mozilla/5.0 (X11; Linux armv7) [... etc ...]

Is this really necessary? You have to use two different modes of access for browsing vs. playing? And you can't inform the server that these are the same device? Why keep making it more difficult? This wasn't required in the past when I accessed the original, non-scrobbling UPnP server in MMW from this same device. And it wasn't required when I accessed this same server via my Moto X4 phone five minutes later: a single device entry works for that.