Wifi Sync Fail frustration

Get answers about the current release of MediaMonkey for Android

Moderator: Gurus

Posts: 2
Joined: Wed Sep 04, 2019 5:09 am

Wifi Sync Fail frustration

Post by Kamikaze62 »

Hi guys, if there if more appropriate forum to post this in please let me know. I've been pulling my hair out trying to get wifi sync to MMA to work again for so long now, I'm hoping someone here can help. I've wiped data, formatted SD card, uninstalled and wiped system files and transferred files over both via usb to my phone and with micro sd inserted directly into my laptop so many times and I'm out of ideas. I've looked at and followed advice on many similar threads but still failing. Anyway, enough preamble!

I have a fairly large database (around 20,000 songs) and so have found the best way to do it previously was to transfer the selected database with the SD inserted in the laptop, analyazze then wifi sync. Previously I have had issues but eventually got wifi sync working but this time I just can't. My issue is that all my selected music files have been transferred to my micro SD (256GB Transend card), directly through MMW (this time, previously via USB in my phone Moto G6). MMA has finished processing the files and recognizes them all in the database. To start with my playlists are there though not organised in the correct folder structure. After a day or two the playlists disappear in MMA. I am also unable to sync via wifi at any timee to bring the playlists back or update my ratings. I am pretty sure that all my settings in device profile are the same as when I have had wifi sync working previously. Sync always seems to fail at the same time (or earlier). The Screen displays:

Initializing: Synchronization is starting...
Matching new files: Checking for new files...
Sync incomplete / Sync failed

I have have the latest beta releases of both MMW and MMA (though have also tried with several other stable and beta releases)
MMW Version:
Windows 10
MMA Version:
Android version 9

I have a debug log of the last attempts here:
and here

I've also tried on various wifi networks but no joy. Sorry for the essay! Any advice or tips anyone has are very appreciated.
Posts: 4
Joined: Mon Oct 06, 2014 10:52 am

Re: Wifi Sync Fail frustration

Post by AnsgarGorgor »

I'm also experiencing very often the case that my Android (Galaxy S9) do not see my PC as sync server, even though that it worked the last time and I haven't changed anything in my MM config nor in WiFi network. So also today, my Android just didn't see my PC with Mediamonkey running (MMW on Win10, MMA, both devices in the same sub-net and in same 5Ghz band).

What helped in my case:
- Disconnect first Android from WiFi by going into airplane mode
- Close MMW and disconnect PC from WiFi by going to airplane mode
- Re-connect PC to WiFi by enabling WiFi
- Re-connect Android device to WiFi by enabling WiFi (same band)
- Go to MMA options - Select sync server
- Now restart MMW on your PC, move your mouse onto the MMW gui so that the app is in front and active. At exact that moment your PC library and ip address should appear in the MMA select sync server list

At least these steps in this order helped in my case.

What also might help to identify the root cause of the issue is to do the "UPnP/DLNA Server Connection Test" http://www.mediamonkey.com/support/inde ... lna-server
Windows 10 Home 20H2
MMW = (lifetime license since .... can't remember :wink: )
MMA = with 240GB external microSD
Galaxy S20 5G with latest Samsung Android update SM-G981B
Posts: 13968
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia

Re: Wifi Sync Fail frustration

Post by Peke »

Once you get PC in Sync List try to long tap on Name and select Save, as that way MAM ill first try to connect to saved servers and then query for sync servers if needed.
Best regards,
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
How to add SCREENSHOTS to forum
Posts: 2
Joined: Wed Sep 04, 2019 5:09 am

Re: Wifi Sync Fail frustration

Post by Kamikaze62 »

Thanks for your suggestions guys, but the same thing is still happening. I don't think it's a problem with it initially connecting to the server, as it seems to connect and start the process before crashing out. Is there a way that I can access the error log I posted, just on the off chance I can make heads or tails of it?
Post Reply