Bugs in Web node [5.0.1.2412] [#18025]

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

monkeyfan1970
Posts: 97
Joined: Wed Sep 07, 2011 11:08 pm

Bugs in Web node [5.0.1.2412] [#18025]

Post by monkeyfan1970 »

Hello,

I notice a couple of bug in MM5 version 5.0.1.2412.

01.
Image

When I create a new tab for Web Node and when I return back to my first tab Artist Tab, the right panel does not refresh to return back to the artist list.

02.
Image

I keep deleting the Amazon.com links and iHeart Links, but each time I restart MM5, the links reappear again. MM4 did not have this issue.
Last edited by monkeyfan1970 on Fri Jun 11, 2021 9:20 pm, edited 1 time in total.
Lowlander
Posts: 50226
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Bugs in Web node [5.0.1.2412]

Post by Lowlander »

1) I don't really follow what the exact problem is.

2) Unable to reproduce on build 2415, the removed web shortcut stays removed on restart.
Lowlander (MediaMonkey user since 2003)
monkeyfan1970
Posts: 97
Joined: Wed Sep 07, 2011 11:08 pm

Re: Bugs in Web node [5.0.1.2412]

Post by monkeyfan1970 »

Lowlander wrote: Fri Jun 11, 2021 9:09 pm 1) I don't really follow what the exact problem is.

2) Unable to reproduce on build 2415, the removed web shortcut stays removed on restart.
01.

Image
As you can see that the right panel is not go back to the artist list.

02.
Image

Nope. It does not. Each restart the links comes back.
Lowlander
Posts: 50226
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Bugs in Web node [5.0.1.2412]

Post by Lowlander »

Neither are a problem I can reproduce on 2415.
Lowlander (MediaMonkey user since 2003)
monkeyfan1970
Posts: 97
Joined: Wed Sep 07, 2011 11:08 pm

Re: Bugs in Web node [5.0.1.2412]

Post by monkeyfan1970 »

Lowlander wrote: Fri Jun 11, 2021 10:26 pm Neither are a problem I can reproduce on 2415.
The bugs and issue can be clearly seen in my both of screen recordings.
Lowlander
Posts: 50226
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Bugs in Web node [5.0.1.2412]

Post by Lowlander »

Yes, but neither are reproducible for me on build 2415, you're reporting them for build 2412.

If you can reproduce on build 2415, please capture each in their own debug log (step 4b) and attach the logs to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... 30&t=86643
Lowlander (MediaMonkey user since 2003)
Snofru
Posts: 185
Joined: Tue Dec 27, 2016 8:12 am

Re: Bugs in Web node [5.0.1.2412]

Post by Snofru »

I can confirm 1. with 2415. The tab that represents the Web remains open and in front even when I click on a tab with music. I can only see the music tab when I close the Web tab, but not by switching from one tab to the other.

I cannot confirm 2. Removing Amazon from Web means that it is permanently removed, even after a restart of MMW5 (on my system with 2415).
MMW Version 4.1.31.1919 Portable
MMW Version 5.0.0.2415 Portable
Samsung Galaxy S9 and Sony NW-A105 with MMA Beta 1.4.2.0952
Lowlander
Posts: 50226
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Bugs in Web node [5.0.1.2412]

Post by Lowlander »

Please capture it in a debug log (step 4b) and attach the log to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... 30&t=86643

It may require a very specific set of steps, which a debug log would help to identify.
Lowlander (MediaMonkey user since 2003)
Snofru
Posts: 185
Joined: Tue Dec 27, 2016 8:12 am

Re: Bugs in Web node [5.0.1.2412]

Post by Snofru »

Here is the link to the debug log: https://www.magentacloud.de/lnk/yVBJJYqL

To see the bug is very straightforward here:

Open a 2nd tab at the top of the MM5 window (by pressing "+"). Have one tab showing a web page, the other a playlist. When you now click on the web tab and then on the playlist tab the web tab remains in view.
MMW Version 4.1.31.1919 Portable
MMW Version 5.0.0.2415 Portable
Samsung Galaxy S9 and Sony NW-A105 with MMA Beta 1.4.2.0952
Lowlander
Posts: 50226
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Bugs in Web node [5.0.1.2412]

Post by Lowlander »

Lowlander (MediaMonkey user since 2003)
monkeyfan1970
Posts: 97
Joined: Wed Sep 07, 2011 11:08 pm

Re: Bugs in Web node [5.0.1.2412]

Post by monkeyfan1970 »

Lowlander wrote: Sat Jun 12, 2021 12:06 am Yes, but neither are reproducible for me on build 2415, you're reporting them for build 2412.

If you can reproduce on build 2415, please capture each in their own debug log (step 4b) and attach the logs to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... 30&t=86643
I have installed build 2415. It is still the same.

I also notice another bug. Each time when I open the Web Node Tab and if the Web node is the active tab or I have at least clicked it once, and when I close MM5. MM5 takes a much a longer time to close or remains stuck in the system tray.

This does not happen when I disable web node or I do not open it in tab.
Post Reply