CD Ripping - Entering Properties - Playing Bug [#15735]

Report bugs & feature requests for MediaMonkey 5 and learn about the newest builds.

Moderator: Gurus

Asect
Posts: 45
Joined: Fri Oct 21, 2016 6:25 pm

CD Ripping - Entering Properties - Playing Bug [#15735]

Post by Asect » Sat Jun 01, 2019 11:11 am

After importing a CD into the library, and entering properties for the CD (Group Properties), MM5 froze and attempted to send the following bug report (F1B46B6B), but failed during the send. Also, the current playing song began to "loop", playing approximately the first 10 seconds over and over. Task Manager had to be utilized to shut down MM5 version 2178. Attached is a link to the screenshots relating to the issue. Thank you.

https://flic.kr/s/aHsmDWwfAW

Ludek
Posts: 3039
Joined: Fri Mar 09, 2007 9:00 am

Re: CD Burning - Entering Properties - Playing Bug

Post by Ludek » Mon Jun 03, 2019 5:47 am

Hi, we have got the log ID F1B46B6B from AlsPlace att Cyberdude -- is this your address?

I cannot replicate , but from the log it failed when saving covers (artworks).
Did you add an artwork via the group properties? Was the CD still inserted for the library tracks being edited?
I am not able to add images (artworks) at all to the CDA tracks (as expected).
Could you please re-test in 2179 and send another crash log (in case you can still replicate this)?

Asect
Posts: 45
Joined: Fri Oct 21, 2016 6:25 pm

Re: CD Burning - Entering Properties - Playing Bug

Post by Asect » Fri Jun 07, 2019 7:51 am

Yes...that is the correct log.

Yes...I did add artwork via the group properties.

No...I have burning properties set to eject CD after import, so CD was not in drive.

I will retest in 2179 and see if it replicates. Thank you!

Ludek
Posts: 3039
Joined: Fri Mar 09, 2007 9:00 am

Re: CD Burning - Entering Properties - Playing Bug

Post by Ludek » Mon Jun 10, 2019 11:38 am

No...I have burning properties set to eject CD after import, so CD was not in drive.
I am a little bit confused now. You wrote that you imported CD into library -- so I suspect that you ripped it (not burnt) ?
Could you please re-test in 2181 and if the issues persists then write down the exact step by step workflow how to trigger the bug?
i.e. whether you ripped the songs, or just added to the library?

Asect
Posts: 45
Joined: Fri Oct 21, 2016 6:25 pm

Re: CD Burning - Entering Properties - Playing Bug

Post by Asect » Mon Jun 10, 2019 6:35 pm

Hey Ludek,

Yes, I was ripping a CD and adding to the library. All the issues took place after the rip was complete and the CD auto ejected, while entering properties information (Disc Number, Genre, Date, Composer, Etc.). Also, I had highlighted the entire disk and was in the process of entering the properties as a group for all tracks. As soon as I rip another CD in MM5 version 2181 I'll let you know if the issues repeat. Thank you.

Asect
Posts: 45
Joined: Fri Oct 21, 2016 6:25 pm

Re: CD Burning - Entering Properties - Playing Bug

Post by Asect » Sat Jun 15, 2019 11:33 am

Ludek,

Ripped three CD's with MM5 2181...Attached are screenshots of the various error codes. After ripping the CD's, attempted to input tag data from right click properties (both as a group & per track). This included artwork from a local disk file, and inputting disc number, composer, lyricist, etc. Error logs sent from Alsplace@C*.com included F1B46B6B & 249A8C4C & 249A8AFD. Each of these error logs resulted in a "white screen crash" that required a Task Manager shut down and restart of MM5. Thanks!

https://flic.kr/s/aHsmEhiMgv

Ludek
Posts: 3039
Joined: Fri Mar 09, 2007 9:00 am

Re: CD Burning - Entering Properties - Playing Bug

Post by Ludek » Mon Jun 17, 2019 7:50 am

Thanks, I will look into the logs.

A tip: Don't include your email address in the exact form here -- so that bots are not scanning it and spamming you.

EDIT: Based on your crash logs the issue/regression has been already fixed in 2182 as https://www.ventismedia.com/mantis/view.php?id=15735

Asect
Posts: 45
Joined: Fri Oct 21, 2016 6:25 pm

Re: CD Ripping - Entering Properties - Playing Bug [#15735]

Post by Asect » Fri Jun 21, 2019 9:04 pm

Ludek,

Thanks for catching the email snafu.....guess I’m too used to typing the whole thing! Thanks for the great work you folks are doing on MM5. Every version released now is operating smoother and with less hiccups. Appreciate the effort.

Post Reply