Multiple issues with custom views [#16379, 16437]

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Multiple issues with custom views [#16379, 16437]

Post by thebertster »

MM 5.0.0.2226

I create a custom view e.g. based on the "List (by Album)" type, e.g. as follows:
Image

(also note that the default size of the dialog box seems to be too small and the buttons overlap the content and the "Sub views" option is hidden off the bottom of the dialog - have to resize to see it).

When I click save, the list view briefly sorts as I've just defined, but then a second or so later reverts to the default sort order which is by Album.

I then go to View->Main Panel View and see my "List (by Album Date)" is already highlighted, but if I click on this again, sometimes the view does sort according to my order but sometimes it does not. Regardless, the next time I hit F5, it switches back to the default sort order of the "List (by Album)" view. I just cannot get my custom view sort order to "stick" reliably.

The next issue is that if I edit the view I created (View->Manage Views->Edit), it seems to have lost the custom sort order I created completely:

Image

The I intermittently see really weird behaviour where what the view shows seems to reflect the last-but-one configuration I had in the custom view. For example, if I change the columns once, then edit the view and change the columns again, then re-select the view, it is showing the columns as I edited them the first time, not the most recent time. It's really hard to describe this because the behaviour seems to be completely random and inconsistent.

Basically, I just can't get the custom views to work!
PetrCBR
Posts: 1754
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech
Contact:

Re: Multiple issues with custom views

Post by PetrCBR »

I've tried in music/all tracks and it work just fine. What node are you testing ? Can you try with latest release (2227) ?
How to make a debuglog - step 4b: viewtopic.php?f=30&t=86643
thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Re: Multiple issues with custom views

Post by thebertster »

No different in 2227. This is on the Music root node as well as Music->All Tracks node.

As it's quite hard to describe the issue, I made a video showing the problem.

https://youtu.be/VnUVSmlyUR4

I also noticed that the columns in the column filter do not consistently stick. I have different columns in different tabs (e.g. my "Classical Music" tab will have Composer rather than Album Artist).

I did quickly test to see if the issue was related to having multiple open tabs, but it seems not - behaviour is the same with just one tab open.

I also tried with a completely blank profile (renamed %appdata%\MediaMonkey5 folder and let it to create an empty profile), rescanned a portion of my library, and immediately had the exact same behaviour.
MiPi
Posts: 768
Joined: Tue Aug 18, 2009 2:56 pm
Location: Czech Republic
Contact:

Re: Multiple issues with custom views

Post by MiPi »

Thank you, video helped a lot, the bug was caused by calling "Refresh" when custom view was active, we reproduced it then, should be fixed in the next build.
thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Re: Multiple issues with custom views

Post by thebertster »

There are still issues with refresh on custom views in 2228 - did the fix not make it into this build? There does seem to have been a change in behaviour however:

Now, when I hit refresh in a custom list view I am getting different results on each refresh, with various combinations of the below on each refresh:

Sometimes the sort order I've defined is used, sometimes the default sort order by Album name is used.
Sometimes all tracks are shown, sometimes only 2000, 4000 or 8000 out of the total 8318 tracks is shown.
Sometimes the column browser is shown, sometimes that panel is blank
Sometimes the entire track list is blank

This only seems to happen for the Music node (top level, All Tracks etc.) - other nodes, including custom collections, seem to be behaving correctly.

Note that my Music collection is also customised slightly with a criteria rule that excludes a couple of specific genres.
PetrCBR
Posts: 1754
Joined: Tue Mar 07, 2006 5:31 pm
Location: Czech
Contact:

Re: Multiple issues with custom views

Post by PetrCBR »

Thanks. Will check.
How to make a debuglog - step 4b: viewtopic.php?f=30&t=86643
thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Re: Multiple issues with custom views

Post by thebertster »

Still massive issues with custom views in 2229 despite https://www.ventismedia.com/mantis/view.php?id=16379.

Behaviour pretty much the same as before. I uploade a video showing what I see.

https://youtu.be/i9TQQUCCyKA
thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Re: Multiple issues with custom views

Post by thebertster »

Any feedback on this? MediaMonkey 5 is becoming increasingly unusable for me because of this issue.
Peke
Posts: 14907
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Multiple issues with custom views

Post by Peke »

Hi,
This should be fixed in Next build.

At least my tests show it is fixed.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Re: Multiple issues with custom views

Post by thebertster »

Still completely broken for me with 2230 I'm afraid. I removed the custom view I previously created and started again.

I am still getting the sort order I configure in the custom view not being applied and I still get the issues when I refresh where it shows no tracks, or only 2000, 4000 or 8000 tracks (always exact multiples of 2000) and the column browser randomly not showing anything at all independently of what is shown in the tracks view.

Since this seems to be difficult to replicate, and yet I have this issue completely consistently, even starting with a completely fresh profile and database and just re-scanning my music library, what could be the trigger? What further information can I get to troubleshoot this beyond what I've already provided?
thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Re: Multiple issues with custom views

Post by thebertster »

I rebuilt the database and am now finding that the issues remain the same when I refresh the view, but if I switch to a different library node and then back to the Music node, the view is displayed correctly.

The refresh operation seems to be the thing that is really buggy at the moment.

EDIT: After a while, the above no longer seems to be working. I am noticing that sometimes when I switch to a node with a custom view, the correct sort order is briefly shown, then it reverts to the default sort order. There are just so many weird and inconsistent behaviours when using Custom Views, it's difficult to keep track of it!

I have also had MM crash multiple times with 2230 while doing this testing. The crash does not result in the usual option to submit a crash log. When I restart MM5, my custom views have completely disappeared. This is a new behaviour with 2230.
Peke
Posts: 14907
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Multiple issues with custom views

Post by Peke »

Hi,
Try to rename persistent.json to !persistent.json and then start MM5. You may have some configuration conflicts that exhibit in such behavior.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Re: Multiple issues with custom views

Post by thebertster »

Hi,

This makes no difference. As I've mentioned, I've gone even further than this and completely renamed the whole %appdata%\MediaMonkey5 folder, started completely from scratch, rediscovered my music collection and immediately the exact same symptoms.

I can try it on a completely different PC too, but I wouldn't expect it to make any difference...
Peke
Posts: 14907
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: Multiple issues with custom views

Post by Peke »

Hi,
Can you test in 2232 when it gets out?
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
thebertster
Posts: 33
Joined: Wed Jan 19, 2011 1:47 pm

Re: Multiple issues with custom views

Post by thebertster »

Hi there,

Many of the issues seem to be fixed with 2232, however a number of issues remain:

When I refresh any tab that uses a custom view based on "List (by Album)", the sort order, displayed columns, column order and column widths all still revert to the defaults for "List (by Album)". When I close MM and reopen it, the custom view is initially displayed exactly as defined, until the next time the tab is refreshed.

I also noticed that if I edit a custom view that is already in use on a tab, the tab using that custom view once again reverts to default sort order (just like the issue with refresh). Again, closing MM and re-opening, the sort order is correct again (until the next time the view is refreshed or the custom view edited).

In addition, changes made to column widths or column order in a tab that is using a custom view don't seem to be retained when MM is closed and re-opened. I would expect at least column widths to be retained since there is nowhere to define column widths in the custom view definition itself - I'm not sure what the intended behaviour is for column order (or displayed columns) since these are specifically defined in the custom view.

I did rename persistent.json before any of the above testing. Also to note that automatic column sizing is not enabled.
Post Reply