Linux.... mediamonkey.... meant to be..?

Any ideas about how to improve MediaMonkey? Let us know!

Moderator: Gurus

Would you use mediamonkey on ubuntu?

You may select 1 option

58
1%
4541
99%
 
Total votes: 4599
 

Owyn
Posts: 2018
Joined: Fri Mar 21, 2008 10:55 am
Location: Canada

Post by Owyn » Mon May 05, 2008 3:42 pm

Just noticed (via top) that all my idle time has gone to iowait. One more part of the puzzle.

Closing MM cleared the iowait, and, gave me back the rest of my system, FF3 response had got brutal.
Cogito cogito ergo cogito sum. (Ambrose Bierce)
I drink therefore I am. (Monty Python)
Vista 32bit Home Premium SP2 / MM3.2.1.1297 Gold / Last.Fm 1.0.2.22 / IE8
Dell Inspiron 530 (1.8 Core2 / 2GB)
Skin: Vitreous Blue
Scripts: Add/Remove Playstat|Advanced Duplicate Find & Fix|Album Art Tagger|Backup|Batch Art Finder|Calculate Cover Size|Case&Leading Zero Fixer|DB_Audit|DB_Clean|DB_Schema|Event Logger|Genre Finder|Lyricator|Magic Nodes|MM2VLC|Monkey Rok|MusicIP Tagger|PUID Generator|RegExp Find & Replace|Right Click for Scripts|Scriptreloader|SQL Viewer|Stats(Filtered)|Tagging Inconsistencies

botijo
Posts: 415
Joined: Fri Dec 07, 2007 3:20 am
Location: Ireland

Post by botijo » Tue May 06, 2008 3:14 pm

Let me start with the bad news. It looks like the actual implementation using Gecko is not sufficient for MM. As far as I get from WINE's wiki, there are lots of missing functions that are not implemented, and MM uses them. I will be trying to install IE for Linux and see if that helps. The problem with this option is that IE EULA states that you should own a version of Windows. We should be careful not to require something ilegal.
Some sort of good news is that I categorized the errors on the plugins.

UPDATE: I installed IE via the method described before, and well, it does not work well with the things we are trying here. The directories are a little bit messed up, however, I got MM and IE in the same place and webpages could be opened. I had some trouble with opening URLs, so I am not sure it works. It could be something simple as I did not installed the MAD plugin in this case. Well, I will try that other time. Time to update the WIKI.

Owyn
Posts: 2018
Joined: Fri Mar 21, 2008 10:55 am
Location: Canada

Post by Owyn » Tue May 06, 2008 8:36 pm

Tx.

I am working in WXP tonight. Catching up on some beta issues plus trying, really hard, to understand exactly how the plugins work with MM3. This got confusing enough that I actually resorted to printing some working documents. Hopefully I should I have a significant update to the Wiki soon, not real soon, but soon.

Just downloaded Apple's QT7 installer. See if it works any better than QTA lite.

Noticed tonight that if MM3 is maximized and in background on WXP it will sometimes jump to foreground. This makes me think that the jumping desktop in Gnome is related to the WXP action. It actually got annoying enough (in WXP) that I am running with the mini-player. Fatal in Linux. Well killall fatal.

Looks like that I need winetrick wmp10 (or wmp9) to resolve wav play. Will try in_wmp3.dll instead of in_mad.dll after install.

Could be the weekend before I can get back to any significant testing in Linux. I want to catch up on my documentation and notes before moving on. With luck it should not take me too long to catch up to your tests / investigations.

...

Just got back from reviewing your Wiki edits. The IE hack might have fixed the podcasting support. If you can scan a Podcast Directory now the key pieces for Podcast Updates are in place.

I have no personal problems with Windows Licensing requirements. My test system is legal and I have another spare portable license. Still leaning towards a two phase approach, get it working, then, get it working right, or, at least identify what would be needed to get it right.

Good luck.
Cogito cogito ergo cogito sum. (Ambrose Bierce)
I drink therefore I am. (Monty Python)
Vista 32bit Home Premium SP2 / MM3.2.1.1297 Gold / Last.Fm 1.0.2.22 / IE8
Dell Inspiron 530 (1.8 Core2 / 2GB)
Skin: Vitreous Blue
Scripts: Add/Remove Playstat|Advanced Duplicate Find & Fix|Album Art Tagger|Backup|Batch Art Finder|Calculate Cover Size|Case&Leading Zero Fixer|DB_Audit|DB_Clean|DB_Schema|Event Logger|Genre Finder|Lyricator|Magic Nodes|MM2VLC|Monkey Rok|MusicIP Tagger|PUID Generator|RegExp Find & Replace|Right Click for Scripts|Scriptreloader|SQL Viewer|Stats(Filtered)|Tagging Inconsistencies

Psyker7
Posts: 255
Joined: Sat Mar 03, 2007 8:00 am

Post by Psyker7 » Sun May 11, 2008 11:36 pm

Installed and running nicely, except wine RC1 won't let me install the ie hack...

Guess I can survive for the moment :D

Thanks a lot for the wiki writeup.

Psyker7
Posts: 255
Joined: Sat Mar 03, 2007 8:00 am

Post by Psyker7 » Mon May 12, 2008 1:34 am

Hrm... strange error I've found.

When *clicking* on a playlist in the tree, the entire browsing window goes white, and will not reappear until a restart.

The player continues playing, and you can start / stop, select new tracks from three itself, and view the Now Playing window, but the main window stays white.

Odd...

edit: seems it's a bit inconsistant actually.... and doesn't just happen with playlists. I've seen it happen both when skinned and not. /shrug

Owyn
Posts: 2018
Joined: Fri Mar 21, 2008 10:55 am
Location: Canada

Post by Owyn » Wed May 14, 2008 2:00 pm

Yep. I saw this with MM1166 using both Wine 0.9.61 and 1.0rc1.

Just getting back to this.
Cogito cogito ergo cogito sum. (Ambrose Bierce)
I drink therefore I am. (Monty Python)
Vista 32bit Home Premium SP2 / MM3.2.1.1297 Gold / Last.Fm 1.0.2.22 / IE8
Dell Inspiron 530 (1.8 Core2 / 2GB)
Skin: Vitreous Blue
Scripts: Add/Remove Playstat|Advanced Duplicate Find & Fix|Album Art Tagger|Backup|Batch Art Finder|Calculate Cover Size|Case&Leading Zero Fixer|DB_Audit|DB_Clean|DB_Schema|Event Logger|Genre Finder|Lyricator|Magic Nodes|MM2VLC|Monkey Rok|MusicIP Tagger|PUID Generator|RegExp Find & Replace|Right Click for Scripts|Scriptreloader|SQL Viewer|Stats(Filtered)|Tagging Inconsistencies

Psyker7
Posts: 255
Joined: Sat Mar 03, 2007 8:00 am

Post by Psyker7 » Thu May 15, 2008 1:04 am

Here's a tricky one...

My music collection is located on a windows NTFS partition. I can see it using Media Monkey in wine OK, and have this partition set as my F:\ drive, with the music located at F:\My Music

When I boot windows, this drive is also F:\ again with the music located at F:\My Music

Problem is, I cannot share the MM database between windows and wine because wine does not seem to recognise the disk the same way as windows does, and as MediaMonkey uses some wierd serial numbers and stuff to recognise it's disk rather than relying on drive letters, it sees the disk under windows as different to the disk under wine.

Any ideas how I could convince it they are one and the same? :P

PS: ie4linux has been updated to work with wine RC1, and apparently minimising to tray and restoring resolves the main window being blank.

2uantuM
Posts: 25
Joined: Wed Aug 09, 2006 11:27 pm

Post by 2uantuM » Thu May 15, 2008 11:08 pm

In mediamonkey.ini, you can specify where to look for the database:

under [System], i have

DBName=D:\Music\MM.DB

Have Linux specify one path, and Windows use the regular one. Maybe that will help you.

Psyker7
Posts: 255
Joined: Sat Mar 03, 2007 8:00 am

Post by Psyker7 » Fri May 16, 2008 1:08 am

Nah it's not the database location that's the issue, but the music's location :(

i.e.: either windows or linux will have the database with all tracks listed as inaccessible. I can edit the media table in the database directly to fix it one way or another, but not so both work with the same database. :(

Owyn
Posts: 2018
Joined: Fri Mar 21, 2008 10:55 am
Location: Canada

Post by Owyn » Fri May 16, 2008 5:29 am

Psyker7 wrote:I can edit the media table in the database directly to fix it one way or another, but not so both work with the same database. :(
You got it.
Cogito cogito ergo cogito sum. (Ambrose Bierce)
I drink therefore I am. (Monty Python)
Vista 32bit Home Premium SP2 / MM3.2.1.1297 Gold / Last.Fm 1.0.2.22 / IE8
Dell Inspiron 530 (1.8 Core2 / 2GB)
Skin: Vitreous Blue
Scripts: Add/Remove Playstat|Advanced Duplicate Find & Fix|Album Art Tagger|Backup|Batch Art Finder|Calculate Cover Size|Case&Leading Zero Fixer|DB_Audit|DB_Clean|DB_Schema|Event Logger|Genre Finder|Lyricator|Magic Nodes|MM2VLC|Monkey Rok|MusicIP Tagger|PUID Generator|RegExp Find & Replace|Right Click for Scripts|Scriptreloader|SQL Viewer|Stats(Filtered)|Tagging Inconsistencies

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Post by nohitter151 » Fri May 16, 2008 5:32 am

Psyker7 wrote:Nah it's not the database location that's the issue, but the music's location :(

i.e.: either windows or linux will have the database with all tracks listed as inaccessible. I can edit the media table in the database directly to fix it one way or another, but not so both work with the same database. :(
If you're feeling adventerous you could try changing your volume ID to match that of the ID of the linux partition:

http://www.microsoft.com/technet/sysint ... umeid.mspx
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

Guest

Post by Guest » Fri May 16, 2008 9:28 pm

nohitter151 wrote:
Psyker7 wrote:Nah it's not the database location that's the issue, but the music's location :(

i.e.: either windows or linux will have the database with all tracks listed as inaccessible. I can edit the media table in the database directly to fix it one way or another, but not so both work with the same database. :(
If you're feeling adventerous you could try changing your volume ID to match that of the ID of the linux partition:

http://www.microsoft.com/technet/sysint ... umeid.mspx
Good idea.
Too bad my linux partition's serial number is negative:
-106568218 :o

Thanks though!

Psyker7
Posts: 255
Joined: Sat Mar 03, 2007 8:00 am

Post by Psyker7 » Fri May 16, 2008 9:29 pm

Anonymous wrote: Good idea.
Too bad my linux partition's serial number is negative:
-106568218 :o

Thanks though!
My bad... stupid guests

To advance further though, you made me think of changing the other end, which turns out to be rather simple in the wine config file, you can actually manually set the serial numbers of partition drives. Seems good so far :D
http://www.codeweavers.com/support/docs ... onfig-file if anyones interested.
Oh and remember to put hexadecimal in the winecfg... mediamonkey stores a decimal code, (google works a treat for converters :P )

Yay for more problems though, seems that scripts will only work upon install until MediaMonkey is shut down the first time, subsequently on startup they simply throw error messages and do not appear where they are supposed to :|

Owyn
Posts: 2018
Joined: Fri Mar 21, 2008 10:55 am
Location: Canada

Post by Owyn » Sat May 17, 2008 5:14 am

Yeah. That would work, but, I don't trust MM3 on Linux enough to let it play with my "real" database. I also have multiple media partitions in WXP which appear as a single partition to Linux.

Building a new test database made testing simpler and made me feel a whole lot safer.
Cogito cogito ergo cogito sum. (Ambrose Bierce)
I drink therefore I am. (Monty Python)
Vista 32bit Home Premium SP2 / MM3.2.1.1297 Gold / Last.Fm 1.0.2.22 / IE8
Dell Inspiron 530 (1.8 Core2 / 2GB)
Skin: Vitreous Blue
Scripts: Add/Remove Playstat|Advanced Duplicate Find & Fix|Album Art Tagger|Backup|Batch Art Finder|Calculate Cover Size|Case&Leading Zero Fixer|DB_Audit|DB_Clean|DB_Schema|Event Logger|Genre Finder|Lyricator|Magic Nodes|MM2VLC|Monkey Rok|MusicIP Tagger|PUID Generator|RegExp Find & Replace|Right Click for Scripts|Scriptreloader|SQL Viewer|Stats(Filtered)|Tagging Inconsistencies

liuzerus87
Posts: 5
Joined: Wed Nov 21, 2007 12:57 pm
Contact:

Post by liuzerus87 » Thu May 22, 2008 5:35 pm

Quick question (I didn't see anything on this)
Under wine, does it play and rip CDs from the CD drive correctly?

Post Reply