Page 8 of 15

Re: Running MM under Mac OS X with Wineskin

Posted: Thu Feb 09, 2012 3:53 am
by markstuartwalker
I think that this was the MM4 version....

k: is the mapped share on the NAS
k:\music\mmdb\mm.db is the location of the db on the NAS
The "rename mm.db mm.db-%date:~6,4%%date:~3,2%%date:~0,2%%time:~0,2%%time:~3,2%00.bak" bit is to create a backup of the DB before copying back

It
1. copies the DB to local C:
2. runs MM
3. copies the DB back to K: after MM has closed

Code: Select all

dir k:\music\mmdb
pause
copy   k:\music\mmdb\mm.db "c:\users\name\Application Data\MediaMonkey\MM.DB"
k:
cd \music\mmdb\
rename mm.db mm.db-%date:~6,4%%date:~3,2%%date:~0,2%%time:~0,2%%time:~3,2%00.bak
c:
"c:\Program Files\MediaMonkey\MediaMonkey (non-skinned).exe" /NOSPLASH
copy "c:\users\name\Application Data\MediaMonkey\MM.DB" k:\music\mmdb\MM.DB
pause
This was saved as "start-mm4.bat" and set as the wineskin initial program to run.

Re: Running MM under Mac OS X with Wineskin

Posted: Thu Feb 16, 2012 2:59 am
by tigertales
Well thank you!!
I got this up and running and working pretty well, so far. Plays my FLACS, and tags from web, so far so good. Don't like the un-dkinned look, but will attend to that later.

Loevin it.

Re: Running MM under Mac OS X with Wineskin

Posted: Thu Feb 16, 2012 3:49 am
by tigertales
Bummer, first time I had to shut it down, refuses to start up again.
Damn. Good while it lasted.

Re: Running MM under Mac OS X with Wineskin

Posted: Mon Feb 20, 2012 2:29 am
by tigertales
Had another go at it today and is working well. God I missed tree browsing.

Re: Running MM under Mac OS X with Wineskin

Posted: Tue Mar 06, 2012 12:49 am
by tigertales
thoki wrote:Hi,

MediaMonkey 4.0.1 runs fine, but after installing the Last.FM scrobbler plugin (version 1.0.2.29 also 1.0.2.26) I get an OLE error 8007000E during startup, the "Last.FM" entry in the options menu is missing and it doesn't seem to scrobble. Regardless of the OLE error, the rest of MediaMonkey seems to run fine.


Thorsten.

I'm having the exact same problem; any work-arounds? how to get rid of that error - delete/uninstalling the pllugin didn't work

Re: Running MM under Mac OS X with Wineskin

Posted: Wed Mar 14, 2012 11:00 am
by markstuartwalker
This message seems to appear with plugins that hook into shortcut key codes or configuraion pages. There is no workaround.

Unfortunately the MM crew don't consider OSX+Wine a supported platform so it won't get looked at.

Re: Running MM under Mac OS X with Wineskin

Posted: Wed Mar 14, 2012 7:34 pm
by tigertales
Alright, thanks for the reply.
Any news on future upgrades, developments etc??

Re: Running MM under Mac OS X with Wineskin

Posted: Thu Mar 15, 2012 4:02 am
by markstuartwalker
You can look in the Wineskin and Wine sites for upgrades. Unfortunately it is very hard to map their changes to problematical MM features.

http://www.winehq.org/
http://wineskin.doh123.com/
http://wineskin.doh123.com/tiki-view_bl ... ?postId=42

Wine is advertising 1.4 now which has been very long awaited. http://wiki.winehq.org/WineReleaseCriteria
*USB support was supposed to be included but it was proving very hard to create a workable solution and I can't find anything in the release notes. However http://wine.1045685.n5.nabble.com/USB-W ... 37594.html suggests some progress
*Improved audio support was also under development. This was limiting us to version 1.3.24. Going past this version may help. http://bugs.winehq.org/show_bug.cgi?id=10495

So, in summary it is probably worth a look to see if the newest version works any better.

UPDATE: I copied my MM4 installation and upgraded to the latest Wineskin/Wine (1.4) and MM (4.0.3.1476). A very quick test showed that there was no change so it looks like the audio issues have been fixed. I shall test more when I get chance. I am particularly interested to know if the USB support extends to iPhones ....

Re: Running MM under Mac OS X with Wineskin

Posted: Thu Mar 15, 2012 7:51 pm
by tigertales
Thanks. Please keep us posted. Tempted to try the upgrade, but dont want to tinker with something that works right now...

Re: Running MM under Mac OS X with Wineskin

Posted: Fri Mar 16, 2012 3:54 am
by markstuartwalker
Well, it works perfectly. I didn't have my iPhone to hand so I got no chance to experiment with USB though :roll:

Tinkering is easy - by duplicating the complete MM4.app folder you get an independent copy. If it goes wrong, simply delete it.

Re: Running MM under Mac OS X with Wineskin

Posted: Sat Mar 17, 2012 5:42 am
by tigertales
Will look into this tomorrow. Any walkthrough guides?

Re: Running MM under Mac OS X with Wineskin

Posted: Thu Jul 05, 2012 6:47 am
by markstuartwalker
I've been using this for many months now - still working even on the MM4.0.6.1500 build.

I have recently tried to have a portable MM instance sited on a NAS to run in this manner - I considered this a good option as it keeps all of the configuration on the NAS and I get the same behaviour on all PCs that I use.

Curiously this failed on my Mac due to the MM.DB file not being able to be opened. Very peculiar 'cos the Windows 7 PCs are all fine.

Any thoughts from anyone?

Re: Running MM under Mac OS X with Wineskin

Posted: Thu Jul 05, 2012 6:51 am
by oddBeat
Maybe try to check user permissions...

Roger

Re: Running MM under Mac OS X with Wineskin

Posted: Fri Jul 13, 2012 11:19 pm
by angelicalee8
oddBeat wrote:Maybe try to check user permissions...

Roger
I was having this same issue, and i tried messing with user permissions per your recommendation and it worked. Thanks for the info. Now if I could only figure out what the best service is... I have been doing some research, but it seems like there are too many options available, it is impossible to choose which one is the best for me. :)

Re: Running MM under Mac OS X with Wineskin

Posted: Mon Jul 16, 2012 3:32 pm
by oddBeat
angelicalee8 wrote:
oddBeat wrote:Maybe try to check user permissions...

Roger
I was having this same issue, and i tried messing with user permissions per your recommendation and it worked. Thanks for the info. :)
Im glad it helped :-)

Roger