"Now Playing" Panel Height Resizes When MM Starts

Beta Testing for Windows Products and plugins

Moderator: Gurus

Stigg
Posts: 228
Joined: Wed May 18, 2011 7:56 pm

"Now Playing" Panel Height Resizes When MM Starts

Post by Stigg » Sat Jun 09, 2018 2:08 am

I have my "Now Playing" panel at the bottom of MM, and ever since you updated MM to fix Windows 10 1803 issues my "Now Playing" panel height shrinks to about the size of one track, then eventually enlarges back to where I have it originally set, which is 10 tracks.

This problem occurs in both 4.1.21.1868 RC, and now with 4.1.21.1869 RC.
I think it may have started before 4.1.21.1868 RC. But, I can't be sure.

4.1.20.1864 doesn't have this issue. So, I have gone back to that for now.

Lowlander
Posts: 44839
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by Lowlander » Mon Jun 11, 2018 11:45 am

I can't reproduce. You should capture it in a debug log (step 4b) and attach the log to a Support Ticket: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
Lowlander (MediaMonkey user since 2003)

Ludek
Posts: 2491
Joined: Fri Mar 09, 2007 9:00 am

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by Ludek » Tue Jun 12, 2018 7:16 am

I am also unable to replicate, could you please post screenshot of your layout?
then eventually enlarges back to where I have it originally set, which is 10 tracks.
I guess that this happens once all startup scripts are loaded, right? i.e. once the ''"Loading... MagicNodes.vbs" and similar disappears?

Stigg
Posts: 228
Joined: Wed May 18, 2011 7:56 pm

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by Stigg » Fri Jun 29, 2018 1:57 am

My problem still exists in 4.1.21.1872 RC, I am sorry to say. :(
I can either just put up with it, or go back to 4.1.20.1864, which I have done for now.

Notice the height of the Now Playing panel and the disappearance of Art Browser with Details.

Image

Ludek
Posts: 2491
Joined: Fri Mar 09, 2007 9:00 am

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by Ludek » Fri Jun 29, 2018 4:35 am

Hi Stigg,
my understanding was that we clarified the issue and you have already confirmed it as fixed, see:
viewtopic.php?f=6&t=89945&start=15#p446886

Is it that the issue does not appear with the testing EXE that I posted and appears with 1872 ?

How long are the blank panels shown, only for two seconds (while the scripts are loading) or longer?
This screenshot was taken before or after the script loading progress was shown?
Can you please generate debug log?

Stigg
Posts: 228
Joined: Wed May 18, 2011 7:56 pm

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by Stigg » Fri Jun 29, 2018 7:02 pm

With 4.1.21.1872, the blank panels and the short "Now Playing" panel only lasts for a few (maybe 3) seconds, but with 4.1.20.1864, it doesn't happen at all. Everything loads immediately. Here is the 4.1.21.1872 RC log.

If I have to, I guess I can just live with it, but it would be good to get it working like 4.1.20.1864 and previous versions. :)

Ludek
Posts: 2491
Joined: Fri Mar 09, 2007 9:00 am

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by Ludek » Mon Jul 02, 2018 5:37 am

Thanks,
as I already explained here viewtopic.php?f=6&t=89945&start=15#p446886 and here https://www.ventismedia.com/mantis/view ... 898#c50615

The difference is that with 1864 the script loading (2 or 3 seconds in your case) was before the main window was shown and after the splash screen disappeared, BUT with the latest Windows 10 upgrade some scripts (like RegExp Find & Replace) took 60 seconds to load (issue #14820). So there was 60 seconds of "nothing" after the splash screen hide and before the main window showing. Therefore in 4.1.21 we have to change the workflow to show main window at first (immediately after splash screen hide) with the scripts loading progress, so in case of issue #14820 user is seeing "Loading... RegExp Find & Replace.vbs" and is aware what is happening and which script is slow to load. The negative effect is that you can see the blank panels for the scripts that are not loaded yet.

Stigg
Posts: 228
Joined: Wed May 18, 2011 7:56 pm

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by Stigg » Sat Oct 06, 2018 3:54 am

Ludek wrote:
Mon Jul 02, 2018 5:37 am
Thanks,
as I already explained here viewtopic.php?f=6&t=89945&start=15#p446886 and here https://www.ventismedia.com/mantis/view ... 898#c50615

The difference is that with 1864 the script loading (2 or 3 seconds in your case) was before the main window was shown and after the splash screen disappeared, BUT with the latest Windows 10 upgrade some scripts (like RegExp Find & Replace) took 60 seconds to load (issue #14820). So there was 60 seconds of "nothing" after the splash screen hide and before the main window showing. Therefore in 4.1.21 we have to change the workflow to show main window at first (immediately after splash screen hide) with the scripts loading progress, so in case of issue #14820 user is seeing "Loading... RegExp Find & Replace.vbs" and is aware what is happening and which script is slow to load. The negative effect is that you can see the blank panels for the scripts that are not loaded yet.
I understand you VERY clearly.
But, in my opinion, that workaround is not good enough, and that's why I will be sticking with v4.1.20.1864 as long as I can until you find a proper fix.

Ludek
Posts: 2491
Joined: Fri Mar 09, 2007 9:00 am

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by Ludek » Mon Oct 08, 2018 6:33 am

And how would you suggest to make the workaround better? User will either have slow startup (because of scripts) and won't be aware why the start is slow. Or (in the new version) the startup is fast and users are seeing the script loading progress and see which script is slow to load and can identify the problem/issue better.

ZvezdanD
Posts: 3070
Joined: Thu Jun 08, 2006 7:40 pm

Re: "Now Playing" Panel Height Resizes When MM Starts

Post by ZvezdanD » Mon Oct 15, 2018 3:09 am

Ludek wrote:
Mon Oct 08, 2018 6:33 am
(in the new version) the startup is fast
I don't have Win 10, so I am not speaking for myself, but the users of my add-ons reported that they have unresponsive the new version of program during startup until the scripts finish loading. So, it seems that your fast startup of the program is not as fast as you claim.

I have also experienced the strange behavior with the newer versions of the program during startup with jumping toolbars and similar, even on Win XP, i.e. without the slow startup of the program. However, I stayed with b1751 for another reason described here: https://www.ventismedia.com/mantis/view.php?id=14870 and here: https://www.mediamonkey.com/forum/viewt ... 37#p446937

Maybe you should not remove the splash window until the program and scripts finish loading, and during that time just make the main window invisible to not confuse users. And you could display which script is loading in the splash window instead.
Magic Nodes 4.3.3 / 5.2 RegExp Find & Replace 4.4.9 / 5.2  Invert Selection/Select None 1.5.1  Export/Create Playlists for Child Nodes 4.1 / 5.4  Expand Child Nodes/Expand All 1.1.2  Event Logger 2.7  Filtered Statistics Report 1.6  Track Redirection & Synchronization 3.4.2  Restore/Synchronize Database 3.1.7 / 4.0  Find Currently Playing Track 1.3.2  Queue List 1.2.1  Add to Library on Play 1.0.1  Tree Report for Child Nodes 1.1.1  Update Location of Files in Database 1.4.3 / 2.2.2  Inherit Child Playlists 1.0.2  Add Currently Playing/Selected Track(s) to Playlist 1.1.2

Post Reply