MM3 RC 5: Crashes at the end of scanning new files

Beta Testing for Windows Products and plugins

Moderator: Gurus

Randall_Lind
Posts: 134
Joined: Sat Jul 29, 2006 11:17 am
Contact:

MM3 RC 5: Crashes at the end of scanning new files

Post by Randall_Lind »

When I add/rescan files to add to MM3 library when it gets toward the end all a sudden it stopped and MM3 close. This happen two different times. No error screens.

I downloaded the debug version so I could report it and it doesn't happen wiith it.
Stef61
Posts: 12
Joined: Mon Dec 17, 2007 3:15 pm
Location: Paris (France)
Contact:

Post by Stef61 »

This problem also happens to me 2 or 3 times : a lot of windows appear and the only way to take control is the "famous" Ctrl-Alt-Del (to kill the MediaMonkey job)

PS : This time, for the RC5, I didn't download the debug version, but only the "regular" version. What are the differences exactly ? (except you can get a error report)
Devices : IPod Classic 80 Go, Archos XS202 (20 Go), Mobile SonyEricsson W910i
muzika
Posts: 10
Joined: Wed Dec 19, 2007 4:13 pm
Contact:

Post by muzika »

Stef61 wrote:This problem also happens to me 2 or 3 times : a lot of windows appear and the only way to take control is the "famous" Ctrl-Alt-Del (to kill the MediaMonkey job)

PS : This time, for the RC5, I didn't download the debug version, but only the "regular" version. What are the differences exactly ? (except you can get a error report)
same thing is happening to me! drives me nuts! and I can't send in a report because it just freezes everything and all I can do is crl-alt-del
rusty
Posts: 7328
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada
Contact:

Freeze when adding files

Post by rusty »

Hi,

The only difference between the debug and regular versions is that the debug version spits out debug messages (either automatically or in conjunction with dbgview.exe).

Please try to install the debug version, and use dbgview (as describe at step 4b of http://www.mediamonkey.com/forum/viewtopic.php?t=341 ).

Thank you.

-Rusty
Randall_Lind
Posts: 134
Joined: Sat Jul 29, 2006 11:17 am
Contact:

Post by Randall_Lind »

running that tool crashed MM# RC 5 Debug big time.
Last edited by Randall_Lind on Sat Dec 22, 2007 11:34 pm, edited 1 time in total.
rusty
Posts: 7328
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada
Contact:

Post by rusty »

Muzika, Stef61,

Please try the debug version and see if you can trigger the bug with it and generate a log for me...

Thx.

-Rusty
Randall_Lind
Posts: 134
Joined: Sat Jul 29, 2006 11:17 am
Contact:

Post by Randall_Lind »

Rusty,

I sent you a log file. I used Debug View and was scanning my HD to add music and then all a sudden MM3 went nuts.


Look at line 00024618 +

Hope the log helps.
rusty
Posts: 7328
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada
Contact:

bug

Post by rusty »

It looks like it's related to an issue that's resolved in RC-6.

Please test with RC6 and let us know--if the bug persists, please send another debug log.

Thx.

-Rusty
Randall_Lind
Posts: 134
Joined: Sat Jul 29, 2006 11:17 am
Contact:

Post by Randall_Lind »

Problem is fixed for me at least. I did an add/rescan two different times on my mp3 drive and had no issue.


Thanks
Post Reply