3.1 unstable streaming

Beta Testing for Windows Products and plugins

Moderator: Gurus

mmfan
Posts: 113
Joined: Mon Nov 21, 2005 4:59 pm

3.1 unstable streaming

Post by mmfan »

I've been testing 3.1 for quite a few builds now, and I found out that it is very unstable playing a shoutcast or a streaming podcast. When network is disconnect, it would just go haywired and I have to Ctrl Alt Del it. Especially more recent builds. I was playing a shoutcast stream just now when my wifi was disconnected and i got a unresponsive note so I have to kill it. PLZ fix before final product! This is a big showstopper for me.
y8 | Miniclip | y3 | friv | ben10 |
Ludek
Posts: 3657
Joined: Fri Mar 09, 2007 9:00 am

Re: 3.1 unstable streaming

Post by Ludek »

Thanks for contributing.

Could you put here an exact link so that we could try to reproduce this issue and fix it.
Thx.
mmfan
Posts: 113
Joined: Mon Nov 21, 2005 4:59 pm

Re: 3.1 unstable streaming

Post by mmfan »

Well, I listen to 977 hit radio on shoutcast and a couple similar stations. The problem is that when my wifi disconnect (I have a rather unstable wifi connecttion too :( ) MM3.1 just hang and loop the buffered tunes. Couldn't do much after that except kill its process. You guys can try it on your laptops or then kill the wifi switch and you'll see...it's the same effect or may be I'm just alone out there :D
y8 | Miniclip | y3 | friv | ben10 |
Ludek
Posts: 3657
Joined: Fri Mar 09, 2007 9:00 am

Re: 3.1 unstable streaming

Post by Ludek »

I cannot reproduce, but I have tested this by disconnecting network cable. Not by using wifi.
There were some similar problems in the past which we could not reproduce neither by using WIFi connetction.
I will try this one on a wifi connection.

Are you sure that this issue is specific to MM 3.1 and that you have never observed this with MM 3.0 ?

Anyone else can confirm this issue?
rusty
Posts: 7360
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: 3.1 unstable streaming

Post by rusty »

I can't replicate this either. Has anyone else had problems with MM freezes / sound loops in relation to disconnected streams ?

-Rusty
badjeros
Posts: 12
Joined: Tue Mar 20, 2007 9:12 pm

Re: 3.1 unstable streaming

Post by badjeros »

Yes, I routinely have that problem. When the player loses the stream, it goes into a loop and is unresponsive to controls, sometimes for as much as 30 seconds. The only solution is to mute the entire computer and wait it out. Seems to occur on all streaming radio stations (although come to think of it I may only listen to mp3 format stations in MM).

I recall this was an issue in 2.x versions as well.

Anybody found a work-around for that by the way? A different plug-in perhaps? I listen to a lot of streaming radio and deal with that glitch multiple times a day. It's about the only thing I really dislike about MM.
Ludek
Posts: 3657
Joined: Fri Mar 09, 2007 9:00 am

Re: 3.1 unstable streaming

Post by Ludek »

Yes, if connection to a stream is lost then there is 30 seconds timeout in which MM tries to keep the connection.
During that time MM player is unresponsive, we track the issue here:
http://www.ventismedia.com/mantis/view.php?id=5458
badjeros
Posts: 12
Joined: Tue Mar 20, 2007 9:12 pm

Re: 3.1 unstable streaming

Post by badjeros »

OK, glad to hear it's a known bug, hopefully it will get squashed. Thanks for the update.
dutty.p

Re: 3.1 unstable streaming

Post by dutty.p »

i got the same problem. First, i love mm. But i love streamin too, please fix it fast!!
The exact problem:
when i stream via mm (mm/web-radio/shoutcast radio/any radio station) and my router(FRITZ!Box Fon WLAN 7170) got a 24hour reconnect for example (germany, DSL, its normal that your provider reconnects you automatic) or i get new ip via web interface of the router mm loops the stream. I can press pause, and it works. But selecting stop, another stream and so on let mm freeze. The skin rolls back to windows theme, or, half of it, and just quitting the prozess works. That sux baldy!

btw another problem: Some streams like http://yp.shoutcast.com/sbin/tunein-station.pls?id=2886 (bigupradio.com) doesnt work propperly. The stream runs after 5 sec, but stops 2 sec later, plays a bit, jumps back to a sec ive heard alrdy and plays on... all the time.. plays 20 sec.. jumps back 5 sec and plays 20 again. Dono what it is. Mabye the low kbps rate of 96 is a problem for mm. Its just mp3 stream. And i got the problem just with this radio. Others work fine. The website stream from bigupradio.com works fine. So it must be a mm problem again.

Hope thats enough info.
dutty.p

Re: 3.1 unstable streaming

Post by dutty.p »

what i forgot to say:

http://www.ventismedia.com/mantis/view.php?id=5458

this link LudeK posted isnt the same problem. There is something written with firewall. But i dont use any firewall (the fritzbox got something like i firewall but still i think its not the same). And theres written its solved. But from version 2.9 to 3.1.1.1.1.1.1 whatever (the newest) the problem still exist.

PLEASE fix it. STREAMING IS ONE OF THE MOST IMPORTANT THINGS A MEDIAPLAYER SHOULD DO!!!
mmfan
Posts: 113
Joined: Mon Nov 21, 2005 4:59 pm

Re: 3.1 unstable streaming

Post by mmfan »

that page says the problem is fixed in build 1300? where's that?
y8 | Miniclip | y3 | friv | ben10 |
Lowlander
Posts: 48693
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 3.1 unstable streaming

Post by Lowlander »

mmfan wrote:that page says the problem is fixed in build 1300? where's that?
The latest release is 1267. Build 1300 will have that particular fix, but isn't yet released as other items are pending.
Lowlander (MediaMonkey user since 2003)
Post Reply