1236: DistributedCOM errors on Vista 64

Beta Testing for Windows Products and plugins

Moderator: Gurus

gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

1236: DistributedCOM errors on Vista 64

Post by gpzbc »

I am running Vista 64 bit and I installed the beta version 3.1.0.1235 and I am really enjoying it. But I noticed that every time I open MediaMonkey, there are 4 instances of an error immediately logged in the windows event log. The error has an event ID of 18213 and is labeled as a DistributedCOM error. The description is:
"The launch and activation security descriptor for the COM Server application with CLSID {7DB2DA7A-8F3D-4329-990C-32E15C849F00} is invalid. It contains Access Control Entries with permissions that are invalid. The requested action was therefore not performed. This security permission can be corrected using the Component Services administrative tool."

This never occurred when I was on MM 3.0 and it started occurring the very first time I opened MM3.1. And it continues to happen every single time I open MM 3.1. I have also tried running MM as an administrator and that makes no difference. I still get 4 DistributedCOM errors as soon as MM opens up.

I just recently updated to version 3.1.0.1236 and the problem is still occurring every single time.
--
Here is the detailed error event log:

Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 4/14/2009 7:31:42 PM
Event ID: 18213
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: DyLAPTOP
Description:
The launch and activation security descriptor for the COM Server application with CLSID
{7DB2DA7A-8F3D-4329-990C-32E15C849F00}
is invalid. It contains Access Control Entries with permissions that are invalid. The requested action was therefore not performed. This security permission can be corrected using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="49152">18213</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2009-04-15T01:31:42.000Z" />
<EventRecordID>61782</EventRecordID>
<Correlation />
<Execution ProcessID="0" ThreadID="0" />
<Channel>System</Channel>
<Computer>DyLAPTOP</Computer>
<Security />
</System>
<EventData>
<Data>{7DB2DA7A-8F3D-4329-990C-32E15C849F00}</Data>
</EventData>
</Event>
Last edited by gpzbc on Fri Apr 17, 2009 9:26 pm, edited 1 time in total.
--
The gpzbc
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

gpzbc wrote: "The launch and activation security descriptor for the COM Server application with CLSID {7DB2DA7A-8F3D-4329-990C-32E15C849F00} is invalid. It contains Access Control Entries with permissions that are invalid. The requested action was therefore not performed.


I'm wondering what action MediaMonkey is attempting to perform that Windows is not granting permission for?
--
The gpzbc
Peke
Posts: 13578
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by Peke »

Windows Scripting Host.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

Thanks for the reply.
Is this a problem that I should be concerned with? I haven't noticed any scripts that aren't working properly. Then again, some of my scripts are used infrequently. The main ones all seem to be functioning properly.

And more importantly, is there a way to fix it? Or is it a problem with 3.1 beta?
Thank you.
--
The gpzbc
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

-- bump --

Is there anyone that can help answer this or should I just wait for a new beta build?
Thanks!
--
The gpzbc
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

Ugh....

I just updated from 3.1 build 1236 to build 1237 to see if it fixed the problem, but unfortunately I am still getting the DistributedCOM errors.
Is there anyone that can help answer this or should I just wait for a new beta build?
Thanks!
--
The gpzbc
Peke
Posts: 13578
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by Peke »

Try to install MM as administrator (Right click on MM installation -> Run as Administrator) and then Start MM same Way?

{7DB2DA7A-8F3D-4329-990C-32E15C849F00} means that COM Object is classified/started with Interactive user permitions which can be limited with several Windows settings.
Best regards,
Pavle
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

Peke wrote:Try to install MM as administrator (Right click on MM installation -> Run as Administrator) and then Start MM same Way?

{7DB2DA7A-8F3D-4329-990C-32E15C849F00} means that COM Object is classified/started with Interactive user permitions which can be limited with several Windows settings.
Thanks for the tip.
I just uninstalled and reinstalled as Administrator and it didn't work. I am still getting the DCOM errors.
--
The gpzbc
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

Is it possible that it is related to this other bug I am experiencing?
http://www.mediamonkey.com/forum/viewto ... =1&t=38891
--
The gpzbc
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

:D I figured it out. :D
As it turns out, it is an access/permissions issue. Although, I'm not sure if it is related to the problem I am having in http://www.mediamonkey.com/forum/viewto ... =1&t=38891

Anyways, here is the info that I used to solve it in case anyone else has the same problem.
http://support.microsoft.com/kb/899965
I didn't need to reference the registry because it was obvious to me that MediaMonkey was the culprit since it occurred instantaneously every time that I opened MM. Plus it was easy to verify the CLSID value in the error event viewer. And I had no problems finding MM in Component Services/DCOM Config.

I hope that helps someone else that may be having a similar problem.
--
The gpzbc
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

Well, I just updated to build 1240 and I started getting these error messages again. Bummer. :(

Well, at least I know how to fix them (at least until I upgrade to the next version :) )
--
The gpzbc
mistresso
Posts: 67
Joined: Sun Feb 24, 2008 11:15 am
Location: New Haven
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by mistresso »

I haven't installed the beta build on my new x64 laptop yet, but this is good to know. I somehow *doubt* it will get fixed by MM though, they seem to have enough higher-profile showstoppers to deal with. One can hope though, that Microsoft fixes this as part of Vista SP2 ... which they've been working on for a while now.
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

I agree. Until then, the fix I provided a link to works well and only takes a second or two to do.
--
The gpzbc
rusty
Posts: 7329
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by rusty »

gpzbc,

Another potential approach to solving this problem is to:
-uninstall MediaMonkey
-re-install MediaMonkey afresh

Let me know if that does the trick. Thx.

-Rusty
gpzbc
Posts: 1226
Joined: Sat Sep 13, 2008 12:02 am
Location: Colorado, USA
Contact:

Re: 1236: DistributedCOM errors on Vista 64

Post by gpzbc »

rusty wrote:gpzbc,

Another potential approach to solving this problem is to:
-uninstall MediaMonkey
-re-install MediaMonkey afresh
Thanks for the tip. I think that is what I did when I updated from 1236 to 1237, and I still got the errors. However, I can't be certain.
Perhaps I will try it from 1240 to the next version.
Thanks!
--
The gpzbc
Post Reply