1343: Stereo music plays on all speakers with WASAPI [#7379]

Beta Testing for Windows Products and plugins

Moderator: Gurus

abraxxa
Posts: 54
Joined: Fri Apr 17, 2009 1:18 pm

1343: Stereo music plays on all speakers with WASAPI [#7379]

Post by abraxxa »

My ATI 5870 is connected via HDMI to my Onkyo PR-SC5507.
My Windows 7 x64 playback settings are 5.1 44,1khz 16bit.
Exclusive mode is disabled in the WSAPI plugin.
It happens with both flac and mp3 files.
Guest

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by Guest »

I think that is normal...in shared mode the output follow the windows speaker configuration setting.
abraxxa
Posts: 54
Joined: Fri Apr 17, 2009 1:18 pm

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by abraxxa »

It happens even in exclusive mode.
Who does the mixing? Windows? I've disabled all 'enhancements'.
Peke
Posts: 13785
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by Peke »

How other player work?
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
rusty
Posts: 7360
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by rusty »

abraxxa,

I'm not an expert on this, but I'd expect that:
-in non-exclusive mode, windows mixer settings are used
-in exclusive mode, the windows mixer is bypassed, but sound card driver is used (i.e. the soundcard driver can output to all speakers).

Jiri can give the definitive answer, but until then, I'm curious re. Peke's question: is MM behaving any differently than other apps with wasapi plugins?

Thanks.

-Rusty
abraxxa
Posts: 54
Joined: Fri Apr 17, 2009 1:18 pm

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by abraxxa »

Hi rusty,
which other app do you recommend for testing?
I'm using the HDMI output of my ATI 5870 as soundcard, the onboard is disabled in BIOS and no drivers for it are installed.

Is there some sort of WSAPI monitor that show's per-channel levels?
abraxxa
Posts: 54
Joined: Fri Apr 17, 2009 1:18 pm

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by abraxxa »

I've installed the latest beta version 4.0.0.1348 and tried the new automatic choice of format mode.
Thanks for that mode, I'm using the asio output plugin in combination with ASIO4ALL to achieve a similar thing with MM3.
It fails to output anything with the multichannel flac files.
Note that the exclusive mode dropdown now only includes 16 and 32bit modes although the windows output screen lists 16,20 and 24bit as supported.
Maybe it tries to set the output to 24bit which isn't available because of another bug which leads to the option missing from the dropdown too.
When setting a 16bit mode the multichannel flacs work.
Peke
Posts: 13785
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by Peke »

Hmmm, I have ATi 4890 (see my sysprofile fron signature) and here is what I have found.

When I have worked on my HDMI back in 2008 I based settings on http://www.avsforum.com/avs-vb/showthread.php?t=1029603 please check if your device support 32Bit multichannel Audio. I have found that lots of TV do not have Automatic Downsampling

One thing is for sure:
Enable On board Card in BIOS (I'm guessing it is realtek one) Download Realtek Drivers from http://218.210.127.131/downloads/downlo ... Down=false and install them (in below order) and you should be able to control your HDMI much better. Realtek have connection detection so you should not see it available at all.

My Current Drivers are:
Vista_Win7_R257.exe
HDMI_R255.exe

P.S. Windows shows non-Exclusive support not Exclusive, but that is another topic.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
abraxxa
Posts: 54
Joined: Fri Apr 17, 2009 1:18 pm

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by abraxxa »

My Onkyo Pre doesn't support 32bit according to what the Windows properties display, so it shouldn't be listed in the dropdown.
Instead 20bit and 24bit should be available.

My onboard soundcard is not from Realtek, so their drivers won't help.
I know that the ATI integrated soundchip is from Realtek but their driver doesn't work with it.
Whiteball

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by Whiteball »

I have Win7 x64 and use a creative x-fi card. I too get the sound from all 5.1 speakers with wasapi in MM4 1345. I also use xmplay and that does not produce this effect on stereo files with wasapi (which is the correct behaviour)
Peke
Posts: 13785
Joined: Tue Jun 10, 2003 7:21 pm
Location: Serbia
Contact:

Re: 1343: Stereo music plays an all speakers with WASAPI out

Post by Peke »

abraxxa and Whiteball

I would need more info about this a screenshot maybe?

Note that exclusive mode show output hardware capabilities not Input pre Amp.

I have ALC889 that in exclusive support Stereo 16Bit only but Realtek drivers support 24Bit in shared mode.
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
How to add SCREENSHOTS to forum
abraxxa
Posts: 54
Joined: Fri Apr 17, 2009 1:18 pm

Re: 1343: Stereo music plays on all speakers with WASAPI [#7

Post by abraxxa »

Sorry for the delayed response, which screenshot do you need Peke?
Post Reply