Random noise inserted into MP3s

Beta Testing for Windows Products and plugins

Moderator: Gurus

olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Random noise inserted into MP3s

Post by olivechicago »

I am not too sure when this started, but over the past few weeks I've encountered some weirdness with some of the songs in my collection.

While I am still gathering information right now, I wanted to throw this out there and see if anyone else has experiences this.

I have one track isolated now, and am replaying my recently played list to find more, but some songs are getting random snippets from other songs inserted into them.

Here is a sample: https://www.dropbox.com/s/80ucx7lmkfjt1 ... andgun.mp3

Listen to the whole track, or just to 3:25 and and 3:30, you'll here a few seconds of a random song.

Any idea how this happened?
Last edited by Lowlander on Mon Nov 25, 2013 11:19 am, edited 1 time in total.
Reason: Moved to correct Forum
Lowlander
Posts: 48378
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Random noise inserted into MP3s

Post by Lowlander »

Which version of MediaMonkey? Also did the file previously work without problems?
Lowlander (MediaMonkey user since 2003)
olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Re: Random noise inserted into MP3s

Post by olivechicago »

4.1.0.1672

These tracks in particular have always been fine. It seems to have surfaced for me around build 1670.

3:30 as well for this track https://www.dropbox.com/s/auyl8a326gzif ... aiting.mp3 which I find peculiar, as it's the same time on the track in the opening post.. No weird noise, this time a "skip" almost.

2:45 for this one... a skip https://www.dropbox.com/s/lujkrhqyvy29u ... 0Metro.mp3

I did run most of my library against Picard to get acousticID tags, but I cannot imagine how that would have edited a file.
rovingcowboy
Posts: 14163
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Random noise inserted into MP3s

Post by rovingcowboy »

i'm guessing the mulitple core's are doing it. some have had trouble with burning cd's where parts of the songs end up on the other songs.
and others including me have had the songs ripped in to the library in the wrong playlist order, but that is because of the mulitple cores. one song longer then the other song will always finish second and the short one will finish first and jump in to the library, then the longer one will. so i'm guessing it is the same thing here the songs are being loaded in to the ram fast when they are gathered and that might be adding part to the wrong song, but if it does this to the same song all the time then it might be adding the part in to the wrong one when it is reloading them back in to the hd storage after writing the updates to the tags..
i've had some songs completely changed on me and some cut in half for different reasons but this mix of different songs only happens now and then on my dual core but very rarely. so i'm thinking it is only showing up on win 7 or 8 on 4 or more core's
maybe a third party program to manage the use of your core's will help by letting you set mm to use only 2 cores for everything, and you can set mm's own core options to write only using one core. see if that fixes it. :-?
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy A51 5G Android ) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.
Lowlander
Posts: 48378
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Random noise inserted into MP3s

Post by Lowlander »

I've not seen this myself. I also don't see why this would happen unless some encoding (like conversion) would be going on. Did you just play affected files? Maybe you have UPnP streaming going on as well?

If you can reproduce you should capture this in a debug log (step 4b) as this is a very serious bug (I presume the files are ruined) and send it to support: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
Lowlander (MediaMonkey user since 2003)
dtsig
Posts: 3300
Joined: Mon Jan 24, 2011 6:34 pm
Contact:

Re: Random noise inserted into MP3s

Post by dtsig »

olivechicago wrote:4.1.0.1672

These tracks in particular have always been fine. It seems to have surfaced for me around build 1670.

3:30 as well for this track https://www.dropbox.com/s/auyl8a326gzif ... aiting.mp3 which I find peculiar, as it's the same time on the track in the opening post.. No weird noise, this time a "skip" almost.

2:45 for this one... a skip https://www.dropbox.com/s/lujkrhqyvy29u ... 0Metro.mp3

I did run most of my library against Picard to get acousticID tags, but I cannot imagine how that would have edited a file.
olivechicago .. i can confirm that although I had trouble tapping my foot and snapping my fingers were a problem with "02 - Alkaline Trio - While You're Waiting", at 3:29 it did *skip*. I'm on a HP dual core Win7 box. My daughter is currently watching a video through DLNA so that *shouldn't be the problem*.

Off the subject, I kind of liked that track (the other one i couldn't get connected to). the only other track by Alkaline Trio was from the soundtrack to "Underworld: Evolution", 'Burn'. Think i will have to get some more of them. Thanks for that
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig
olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Re: Random noise inserted into MP3s

Post by olivechicago »

https://www.dropbox.com/s/qjk3geoub2dvb ... %20Ran.mp3

3:30 again. And TWO songs this time. I can easily identify one these two thanks to some lyrics...

First is from De La Soul, Ego trippin (Part 2) minute 2:47

Second is from MAYBE Issac Green and the Skalars. Still listening for this part.

What is it with 3:30???
olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Re: Random noise inserted into MP3s

Post by olivechicago »

rovingcowboy wrote:i'm guessing the mulitple core's are doing it.
Interesting. Especially since I've been using MM for almost 2 years now with no problems. Granted with 13,000 songs, it's impossible to listen to them all in a timely manner so who knows when this started. I will say that some of these songs are on a regular rotation, and this seems to have happened around the time the Android player was released and I moved to Beta releases of MMW so I can utilize the sync feature.
dtsig
Posts: 3300
Joined: Mon Jan 24, 2011 6:34 pm
Contact:

Re: Random noise inserted into MP3s

Post by dtsig »

olivechicago, I opened the file i mentioned above in Audacity. The skip is there in the file. Have you done anything to the file? volume leveling or ...
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig
olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Re: Random noise inserted into MP3s

Post by olivechicago »

Lowlander wrote:I've not seen this myself. I also don't see why this would happen unless some encoding (like conversion) would be going on. Did you just play affected files? Maybe you have UPnP streaming going on as well?

If you can reproduce you should capture this in a debug log (step 4b) as this is a very serious bug (I presume the files are ruined) and send it to support: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
I don't know when it happens, but the files are permanently altered. UPnP was only recently enabled to allow the Android app to sync.
olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Re: Random noise inserted into MP3s

Post by olivechicago »

dtsig wrote:
Off the subject, I kind of liked that track (the other one i couldn't get connected to). the only other track by Alkaline Trio was from the soundtrack to "Underworld: Evolution", 'Burn'. Think i will have to get some more of them. Thanks for that
Best albums from them is the self titled and "Goddamnit," in my opinion of course.
olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Re: Random noise inserted into MP3s

Post by olivechicago »

dtsig wrote:olivechicago, I opened the file i mentioned above in Audacity. The skip is there in the file. Have you done anything to the file? volume leveling or ...
I have done track leveling in the past, yes.

Granted I don't know how all of this works, but I can accept that there would be a "skip" in a file from the leveling. But introducing other bits of one track into another? That seems odd to me.

And again... why always at 3:30? There has got to be something with that. With how random this is, between artist names/folders, track numbers, genre, duration... at 3:30 (actually seems more like 3:29:24 on both affected tracks) it cuts to another song for exactly 6 seconds (3:35:24.) There is nothing random about this.
olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Re: Random noise inserted into MP3s

Post by olivechicago »

So I'm up to about 142 tracks so far where this has occurred.

I'm considering reripping/downloading the effecting albums/songs.

Any know of a utility that could sync the metadata from the corrupt MP3 to the newly imported one?

Particularly fields like played, skipped, last played, and custom fields.
dtsig
Posts: 3300
Joined: Mon Jan 24, 2011 6:34 pm
Contact:

Re: Random noise inserted into MP3s

Post by dtsig »

I had a problem with a couple video files recently and asked the same basic question. Try this link
Where's the db and ini stored
Reporting Bugs
Where tags are stored

Not affiliated with MediaMonkey ... just a RABID user/lover
DTSig
olivechicago
Posts: 58
Joined: Sat Oct 26, 2013 11:57 am
Contact:

Re: Random noise inserted into MP3s

Post by olivechicago »

Looks promising! Danke
Post Reply