3.2 Crash/Not Responding

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

MusicMonkey5555

3.2 Crash/Not Responding

Post by MusicMonkey5555 »

I noticed after playing some songs for a while and using the Aero peek feature it crashes when going to the next song. That is about all I did, I will see if there is exactly something else I am doing.

Oh and I am running Windows 7 Ultimate RC I think it was with the latest updates except windows live tools or whatever and am running Firefox, Digsby and Dropbox as well. The crash has happened a couple times.

I should actually think it is a not responding error I will try and see next time it happens it has happened pretty frequently. I will try and let it wait as well if it is to see if it starts responding/is just hung up.
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 3.2 Crash/Not Responding

Post by nohitter151 »

If you can reliably reproduce it try to get a debug log:
http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=69
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
wowzabo
Posts: 4
Joined: Wed Nov 25, 2009 6:50 pm
Contact:

Re: 3.2 Crash/Not Responding

Post by wowzabo »

MusicMonkey5555 wrote:I noticed after playing some songs for a while and using the Aero peek feature it crashes when going to the next song. That is about all I did, I will see if there is exactly something else I am doing.

Oh and I am running Windows 7 Ultimate RC I think it was with the latest updates except windows live tools or whatever and am running Firefox, Digsby and Dropbox as well. The crash has happened a couple times.

I should actually think it is a not responding error I will try and see next time it happens it has happened pretty frequently. I will try and let it wait as well if it is to see if it starts responding/is just hung up.
I seem to have the same problem, though I do no think that it is related to the Aero Peek functions. Every few songs, MM becomes unresponsive and plays the first ~10 seconds over and over. Usually this situation resolves itself after about a minute, but it is highly annoying. I'll try to reproduce this bug and give some more useful feedback.

I am using Windows 7 64 bit, 3.1 worked fine on this platform.
MusicMonkey5555

Re: 3.2 Crash/Not Responding

Post by MusicMonkey5555 »

Ok so I can produce it reliably. It is a crash fro sure. While a song is play just use the new windows 7 feature and click the -* +* several times until it crashes, happens every time.

I did get it to crash while just playing a song and not clicking the rating button at that exact moment, but I am guessing it was related to this, because I was rating songs.
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 3.2 Crash/Not Responding

Post by nohitter151 »

MusicMonkey5555 wrote:Ok so I can produce it reliably. It is a crash fro sure. While a song is play just use the new windows 7 feature and click the -* +* several times until it crashes, happens every time.

I did get it to crash while just playing a song and not clicking the rating button at that exact moment, but I am guessing it was related to this, because I was rating songs.
Ok, please generate a debug log and either post here or send to the developers via a support ticket. I've tried but can't reproduce the problem.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
MusicMonkey5555

Re: 3.2 Crash/Not Responding

Post by MusicMonkey5555 »

So I installed the debug build to get a log and it doesn't crash now when I rapidly hit the -/+* in the peek pane. I wonder if it is a bug that only shows up in release. Are you running debug I am guessing being a dev you are. Is there any easy way for me to get a release build (can I just install it over the debug) to see if it happens again?
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 3.2 Crash/Not Responding

Post by nohitter151 »

MusicMonkey5555 wrote:So I installed the debug build to get a log and it doesn't crash now when I rapidly hit the -/+* in the peek pane. I wonder if it is a bug that only shows up in release. Are you running debug I am guessing being a dev you are. Is there any easy way for me to get a release build (can I just install it over the debug) to see if it happens again?
No, I'm using the regular build. Also, I'm not a dev, just a moderator on the forum. You can just install the regular build right over the debug to see if the problem occurs again but there really shouldn't be any difference between the two builds other than that the debug build releases debug info for the debug viewer app to log what is going on.
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
wowzabo
Posts: 4
Joined: Wed Nov 25, 2009 6:50 pm
Contact:

Re: 3.2 Crash/Not Responding

Post by wowzabo »

Still hanging quite often here. It seems to happen more with FLAC files than with mp3, but it happens with both. It seems totally random, have no idea what triggers it, so I cannot reproduce. Sometimes, when MM hangs, Firefox also becomes unresponsive. I am going back to the latest 3.1 version to see if that works better.

EDIT: 3.1.1.1 has the same problem... Could this have anything to do with the fact that I am playing a large library (18k songs, 140GB) from an external (eSATA) drive :-? ?
nrb5
Posts: 13
Joined: Thu Mar 20, 2008 9:32 pm
Contact:

Re: 3.2 Crash/Not Responding

Post by nrb5 »

This is MusicMonkey5555 for some reason I can sign in to my account forgot my password or something, so I just used my old one (guess I had 2) anyway. I got it to crash in the debug version here is the output:
Problem signature:
Problem Event Name: APPCRASH
Application Name: MediaMonkey.exe
Application Version: 3.2.0.1294
Application Timestamp: 2a425e19
Fault Module Name: StackHash_fa45
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: 00000000
Exception Offset: 00000000
OS Version: 6.1.7100.2.0.0.256.1
Locale ID: 1033
Additional Information 1: fa45
Additional Information 2: fa4551033bdddae5d38ef44e81306dca
Additional Information 3: 7757
Additional Information 4: 775796646de452334fdbd54213ced568

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid= ... cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

This time I was just running it for a while, I did run a game in the background and then tab out and close MediaMonkey. Bit different and more from what I was doing before.

Wasn't running debug view though I will run it next time.
Dasparks

Re: 3.2 Crash/Not Responding

Post by Dasparks »

I am getting the same problem, anyone find a fix for this?
Lowlander
Posts: 48106
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: 3.2 Crash/Not Responding

Post by Lowlander »

Try to create a debug log as described in the Bug Reports forum so that the developers can look into what's happening.
Lowlander (MediaMonkey user since 2003)
Post Reply