Incorrect album art at album level

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

avh

Incorrect album art at album level

Post by avh »

Album art for some albums are incorrect. When showing the album with all its tracks, each track has the correct album art (lower right corner), but the album level art is incorrect (left of the list in the main area). When the album art is wrong, the image of some other random album in my collection is used (and may vary for the images that are wrong). When I right-click the incorrect album art and choose "show full size", I get the correct album art.

I have tried to delete the cache and remove images in the same folder, removing music files from the library and then importing them again, but the problem is not solved. This is the case for both flac and mp3 files.
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Incorrect album art at album level

Post by Lowlander »

Did you delete the MMCache folders in the MediaMonkey Temp folder (set under Tools > Options > General)?
Lowlander (MediaMonkey user since 2003)
avh

Re: Incorrect album art at album level

Post by avh »

Yes, I deleted that image cache. I also looked inside the DB - could not see any apparent patterns for when it failed.

Question to developers: Which image is used for the album art at the album level?
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Incorrect album art at album level

Post by Lowlander »

First art of the first track, which then gets saved in cache and called from cache (this latter part can call an old cached art in certain situations).
Lowlander (MediaMonkey user since 2003)
avh

Re: Incorrect album art at album level

Post by avh »

(this latter part can call an old cached art in certain situations)
Where is the old cached art kept? In memory, somewhere else on disk?
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Incorrect album art at album level

Post by Lowlander »

Lowlander wrote:MMCache folders in the MediaMonkey Temp folder (set under Tools > Options > General)
Lowlander (MediaMonkey user since 2003)
Guest

Re: Incorrect album art at album level

Post by Guest »

OK. I thought that there might be some additional cache. Then I do not understand the incorrect album art that I get.
jorgebuster
Posts: 5
Joined: Wed Jul 25, 2007 9:59 am
Contact:

Re: Incorrect album art at album level

Post by jorgebuster »

I have exactly the same issue, cant figure it out why, please any help??
Lammy

Re: Incorrect album art at album level

Post by Lammy »

Same issue here. It's an obvious bug that Media Monkey is doing a pretty lame job of even acknowledging, let alone fixing. Pff and this was supposed to be the only good program for managing 16GB+ music libraries? Now what?

Here's the worst part, I recently downloaded 2chainz (for a friend, I think 2chainz is absolutely horrible), and now I'm seeing the stupid 2chainz album art for about 20% of my 40GB library! :evil:
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Incorrect album art at album level

Post by Lowlander »

At this point there is no confirmation of a bug, almost all cases are user error. 1 common error is running Auto-Tag from Web on more than 1 Album and thus applying the Artwork (and often Album and Artist tags) to all the tracks. Another problem relates to scanning file directories for Artwork (can be disabled under Tools > Options > Library and can cause strange results when enabled in a poorly organized environment) and poorly tagged files (missing Album or Album Artist).

If you have steps to reproduce a bug or can capture it in a debug log (http://www.mediamonkey.com/forum/viewtopic.php?t=69), then there would be something to go on to see what causes this.

Note, some users are forced to delete the MMCache folders in the MediaMonkey Temp folder to see the correct Art within MediaMonkey. This shouldn't happen and if anyonecan capture this happening in a debug log it can be addressed. I do a lot of work with Art myself and haven't seen this issue. Fortunately this bug is only a display issue, the files still have the correct Art associated.
Lowlander (MediaMonkey user since 2003)
rovingcowboy
Posts: 14162
Joined: Sat Oct 25, 2003 7:57 am
Location: (Texas)
Contact:

Re: Incorrect album art at album level

Post by rovingcowboy »

i save all album covers to the name of the artist or album artist this makes it easier to have monkey scan for the covers because each one has more different charcaters then just using "folder.jpg"
mediamonkey does have its own popup notifiyer and it uses album covers named the way i name them. why bother with anything that needs name of folder.jpg. that is the fastest way i can think of to cause trouble same named files but only saved in different folders.? each file should have its own name as well as it being in different folder.

i don't have trouble with album art in mediamonkey anymore not since like mm 3.01 or way back then. 8)
roving cowboy / keith hall. My skins http://www.mediamonkey.com/forum/viewto ... =9&t=16724 for some help check on Monkey's helpful messages at http://www.mediamonkey.com/forum/viewto ... 4008#44008 MY SYSTEMS.1.Jukebox WinXp pro sp 3 version 3.5 gigabyte mb. 281 GHz amd athlon x2 240 built by me.) 2.WinXP pro sp3, vers 2.5.5 and vers 3.5 backup storage, shuttle 32a mb,734 MHz amd athlon put together by me.) 3.Dell demension, winxp pro sp3, mm3.5 spare jukebox.) 4.WinXp pro sp3, vers 3.5, dad's computer bought from computer store. )5. Samsung Galaxy 5 Android 5) 6. amd a8-5600 apu 3.60ghz mm version 4 windows 7 pro bought from computer store.
pedromarga

Re: Incorrect album art at album level

Post by pedromarga »

Hi,

I am having almost same problem.

I have some different albums that have the same album name and album artist name (for example, Singles from the same band but released on UK and US), I sort then by summary on Show Art With Details view and they have different summaries, so they are grouped correctly (different summaries -> not grouped together). But the Artwork displayed on the left side is the same for all albums that have the same Name/Artist (but they are different on all tracks, I checked one by one).

If I right click on the Album Artwork and click on "Image 1: Cover 1" the image is corrected, but it is undone when I select another "filter" on column browser.

Am I clear? Do I need to send a Log or Screen Shot or it is a expected behavior (if expected it can be fixed?)?
2many
Posts: 3
Joined: Mon Oct 22, 2012 4:56 pm
Contact:

Re: Incorrect album art at album level

Post by 2many »

I'm having similar issues. In my case I have no artwork in the mp3 or even the folder where the mp3 is. It does show blank in the lower right corner. In the main area I have artwork showing for another one in my collection. I even tried adding an image to the properties. It showed correctly in the lower right, but not the main. I then removed it and again the lower right area show the generic music note for no artwork. The main area never displayed the correct image.

MM needs to fix this. I've had this issue for a long time and it's just plain annoying to say it in a safe "PC" way.
Lowlander
Posts: 47885
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Re: Incorrect album art at album level

Post by Lowlander »

What version of MediaMonkey?

Note that the "main" ie. Filelisting shows Artwork from cache and at least on older versions sometimes showed old Artwork from cache while the file had new Artwork. Also note that the Filelisting normally shows Album based Artwork (taken from 1 track on the Album) thus if you update 1 file on the Album it may not be the file used for Artwork in the Filelisting. You can delete the MMCache folders in the MediaMonkey Temp folder (set under Tools > Options > General) to remove old cached Artwork.
Lowlander (MediaMonkey user since 2003)
amar3213
Posts: 11
Joined: Sat Oct 27, 2012 5:58 am
Contact:

Re: Incorrect album art at album level

Post by amar3213 »

avh wrote:Album art for some albums are incorrect. When showing the album with all its tracks, each track has the correct album art (lower right corner), but the album level art is incorrect (left of the list in the main area). When the album art is wrong, the image of some other random album in my collection is used (and may vary for the images that are wrong). When I right-click the incorrect album art and choose "show full size", I get the correct album art.

I have tried to delete the cache and remove images in the same folder, removing music files from the library and then importing them again, but the problem is not solved. This is the case for both flac and mp3 files.

use a very little but very useful free program CCleaner which deletes all the unwanted cached files of various application including mediamonkey, Internet Explorer...... Once you run this program And press "Run Cleaner" button, just restart your mediamonkey application and album art change reflected in your library. It is the same solution as deleting the cache location of MM but deleting manually by going to that location it is more easy to use this program which doesn't only clean your mediamonkey cache but of course it clean your PC very efficiently too. Download this useful program to keep clean your PC from junk: http://www.piriform.com/ccleaner/download

I suggest to windows 7 user just include your user specific windows temp folder in this program which generally in this location:
C:\Users\<your user name>\AppData\Local\Temp\

AppData folder is hidden by default so make hidden files viewable first.
To add this location in CCleaner program:
Run CCleaner, Click Options > Click include > Click ADD button > select Drive and folder Radio button > Browse the temp folder location and add them > In the following open window keep the radio button selected for all files and Select "Include files & subfolders" from Option drop down box. Done......
Now u can clean your PC by pressing "Run Cleaner" button from Cleaner Section
Post Reply