Invalid Characters in Track Names etc. need to be stripped.

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

Guest

Invalid Characters in Track Names etc. need to be stripped.

Post by Guest »

Right, so when I go and... oh, I dunno, convert a file that has a ? in the file name (or any of the other invalid characters that aren't allowed in Windows/DOS/Whatever, and I use one of the <album> or <artist> things in the file name selection thing for what to name converted files, MediaMonkey states that <filename> was not created.

I figure it's because of the existence of that ? in the track name or whatever, and MediaMonkey tries to actually create a file with that character in it.

I've tested this so far with two tracks, one with a ? at the end (that simply fails to be created) and another with a : in the middle (that results in a very WEIRD corrupted file who's name truncates before the :, and appears to be both empty and extensionless.

I did try to do a tiny search on here for similar situations, but I'm not sure I was searching for the right things, so apologies if this is already reported.
Moleculor
Posts: 1
Joined: Thu Jan 20, 2005 11:30 pm
Contact:

Post by Moleculor »

Grr. I coulda SWORN I was logged in when I posted that. *stabstabstab*

Anywho, I should probably mention that there are six or eight or ten invalid characters that can't be used in PC-based OSes, but I don't remember what they are. I think one might be a slash, then there's the ? and :, but the others? Not sure.
musicfreak
Posts: 21
Joined: Wed Oct 20, 2004 12:23 pm
Contact:

Post by musicfreak »

Hi,

i also had this problem and after asking i found a couple of entries in this forum :)

I'll do a quick search and tell you at least one article.

Markus
musicfreak
Posts: 21
Joined: Wed Oct 20, 2004 12:23 pm
Contact:

Post by musicfreak »

Ok,

search for "FilenameMappings" (without the quotes).

Or look into the readme.txt file

or

http://www.mediamonkey.com/forum/viewto ... memappings

http://www.mediamonkey.com/forum/viewto ... memappings
Lowlander
Posts: 48116
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5
Contact:

Post by Lowlander »

On a standard install of MM this shouldn't be a problem as MM will map them to - dashes if I'm correct.

But I don't know how the problem possibly got created in your installation. You're not the first one reporting it. I on the other hand haven't seen the problem in recent versions of MM.
Lowlander (MediaMonkey user since 2003)
jiri
Posts: 5398
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Post by jiri »

Moleculor,

as Lowlander wrote this should work on new MM installs. There were some reports from users that FilenameMappings section got erased from MediaMonkey.ini file, but this doesn't seem to happen anymore.

Jiri
musicfreak
Posts: 21
Joined: Wed Oct 20, 2004 12:23 pm
Contact:

Post by musicfreak »

Hi,

after a first time installation of version 2.2.2 i also had the problem, that the "extra" chars where not exchanged. That's why i knew there was an answer in the forum.

Markus
Octopod
Posts: 463
Joined: Tue Jun 10, 2003 9:09 am
Contact:

Post by Octopod »

Perhaps (in a future version) a small dialog from an option page could display the chars correspondence, allowing every user to easily check these (default) values.
Octopod
Image
Post Reply