1207 Quick search fails on [, ] and ! [5134]

Beta Testing for Windows Products and plugins

Moderator: Gurus

chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

1207 Quick search fails on [, ] and ! [5134]

Post by chrisjj »

I.e. if I type just the character ! into the quick search box, the tracklist goes blank, failing to show the tracks here having ! in searched fields.

This is a real PITA - I hope it will be fixed soon.
Chris
Ludek
Posts: 4473
Joined: Fri Mar 09, 2007 9:00 am

Re: 3.1.0.1207 Quick search fails on [, ] and !

Post by Ludek »

Chriss,
currently it is in contradiction with http://www.ventismedia.com/mantis/view.php?id=5004 and how full text search engines (like Google too) works.

Nevertheless we are about to improve this and in case of searching just for such a special chars disabple the full-text search and search them same as MM 3.0
chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 3.1.0.1207 Quick search fails on [, ] and !

Post by chrisjj »

Ludek wrote:currently it is in contradiction with http://www.ventismedia.com/mantis/view.php?id=5004
Assuming you mean the observed behaviour is by design, could you please refer me to to docs? I'd like to know what characters are now unavailable.

> and how full text search engines (like Google too) works.

No, Google does not do "characters like '.' should be removed from full-text query" as per http://www.ventismedia.com/mantis/view.php?id=5004 .

e.g. compare http://www.google.co.uk/search?hl=en&q=help! with http://www.google.co.uk/search?hl=en&q=help
Chris
chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 3.1.0.1207 Quick search fails on [, ] and !

Post by chrisjj »

It says
Typing just the character ! into the quick search box, the tracklist goes blank, failing to show the tracks here having ! in searched fields.

Currently this is in contradiction with 0005004 (Full-text-search: characters such as '.' should be removed from the query) and how full text search engines (like Google too) mostly works.
but sorry Ludek that claim of contradiction is in error and I really think this entry should be corrected rather than being left to cause confusion over what the issue really is.

FOAD, I'm saying the behaviour I reported does NOT contradict "Full-text-search: characters such as '.' [are] removed from the query". It accords.
Chris
chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 3.1.0.1207 Quick search fails on [, ] and !

Post by chrisjj »

says:
Nevertheless per discussion with Jiri over IM we could switch to the old search (we had in MM 3.0) in the case when only a single special char is typed to search bar('/','\','?',',','|',':','.','_','(',')','[',']','&','@','#','+','*','!','-',';')
That's not sufficient. It won't fix the fact that searching for Help! erroneously finds Help. Please would you just restore the 3.0 functionalilty? I didn't see anyone complaining about it. And If really there has to be a behaviour that ignores an arbitrary set of characters, please make it a special mode. And please document the list of characters it ignores. Thanks.
Last edited by chrisjj on Wed Jan 07, 2009 8:50 pm, edited 1 time in total.
Chris
Ludek
Posts: 4473
Joined: Fri Mar 09, 2007 9:00 am

Re: 3.1.0.1207 Quick search fails on [, ] and !

Post by Ludek »

Chriss, I don't even see a complaint that MM searchs help if help! is typed. This is simply how full text search engines works. i.e. if you search for help! in google you get help in results too. We decided to add proper full-text search engine so that quick searching would be faster on large DBs and it really is. i.e. text values are indexed in DB (in SongsText) table.

Nevertheless if you want to search for help! you can, just type: "Help!"
i.e. quote it
rusty
Posts: 7652
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: 3.1.0.1207 Quick search fails on [, ] and !

Post by rusty »

I think, that the current behavior makes sense:
a) Search for 'special character' --> special character is found
b) Search for 'special character' appended to other text --> special character is ignored
c) Search for 'special character' appended to other text all in quotation marks --> special character isn't ignored (an exact match must be found)

Regarding b), I tried out a couple of search engines, and it seems that special characters are generally ignored when doing full-text searches. However, as to whether this makes the most sense for MediaMonkey users, I'm not sure. Like ChrisJJ pointed out, there was only one complaint about it at http://www.mediamonkey.com/forum/viewto ... =6&t=34710 . On the other hand, the current implementation gives more flexibility since users can search for "B.B. King" or Trad. and get results. At the same time, I'm sure that many users won't even think to use Quotes and will wonder why a search for :30 isn't returning the expected results.

-Rusty
Lowlander
Posts: 51933
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 3.1.0.1207 Quick search fails on [, ] and ! [Bug 5134]

Post by Lowlander »

I would actually hope that help! would also find help. The whole idea of full text search is that you get similar matches so that you don't need to know the exact value. I think the suggestion to just allow single character search and ignore if multiple characters are entered is a good one.
chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 3.1.0.1207 Quick search fails on [, ] and !

Post by chrisjj »

> We decided to add proper full-text search engine so that quick searching would be faster on large DBs and it really is.

I have no problem with you adding a proper search engine, and/or speeding up searches. The problem I'm reporting is that you broke the existing search.

> Nevertheless if you want to search for help! you can, just type: "Help!"

Unfortunately that now (1209) does not work properly either - it false-matches "Help".
Last edited by chrisjj on Sun Jan 11, 2009 10:33 pm, edited 1 time in total.
Chris
Lowlander
Posts: 51933
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 3.1.0.1207 Quick search fails on [, ] and ! [Bug 5134]

Post by Lowlander »

It works for me search for "yo!" only shows yo! not yo.
chrisjj
Posts: 4933
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 3.1.0.1207 Quick search fails on [, ] and ! [Bug 5134]

Post by chrisjj »

I'm getting rather exhausted by this guessing game. Could someone please direct me to the docs saying what the 1209 search is actually supposed to do?
Chris
Lowlander
Posts: 51933
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 3.1.0.1207 Quick search fails on [, ] and ! [Bug 5134]

Post by Lowlander »

As indicated a few times before there are no docs yet!
nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: 3.1.0.1207 Quick search fails on [, ] and ! [Bug 5134]

Post by nohitter151 »

chrisjj wrote:I'm getting rather exhausted by this guessing game. Could someone please direct me to the docs saying what the 1209 search is actually supposed to do?
I believe Rusty stated it above:
rusty wrote:I think, that the current behavior makes sense:
a) Search for 'special character' --> special character is found
b) Search for 'special character' appended to other text --> special character is ignored
c) Search for 'special character' appended to other text all in quotation marks --> special character isn't ignored (an exact match must be found)

Regarding b), I tried out a couple of search engines, and it seems that special characters are generally ignored when doing full-text searches. However, as to whether this makes the most sense for MediaMonkey users, I'm not sure. Like ChrisJJ pointed out, there was only one complaint about it at http://www.mediamonkey.com/forum/viewto ... =6&t=34710 . On the other hand, the current implementation gives more flexibility since users can search for "B.B. King" or Trad. and get results. At the same time, I'm sure that many users won't even think to use Quotes and will wonder why a search for :30 isn't returning the expected results.

-Rusty
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.
Lowlander
Posts: 51933
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: 3.1.0.1207 Quick search fails on [, ] and ! [Bug 5134]

Post by Lowlander »

I think the following above indicates which characters are omitted:
Nevertheless per discussion with Jiri over IM we could switch to the old search (we had in MM 3.0) in the case when only a single special char is typed to search bar('/','\','?',',','|',':','.','_','(',')','[',']','&','@','#','+','*','!','-',';')
Post Reply