corrupted library after migration

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Daneel
Posts: 5
Joined: Tue Sep 21, 2010 11:23 am

corrupted library after migration

Post by Daneel »

hey

my first installation of media monkey 4 was good because i didnt know that it can be installed in portable mode . so i installed it and made it portable myself as i always do and nothing went wrong

the problem appeared when i wanted to install it on my other pc and this time i noticed the portable check box and i installed it on my previous portable folder .
this is what happened to the music paths in my library
Image

as you can see the start (shared) section of the path which was d:\media\audio\music has changed to [MUSIC] and i dont know how to fix it. i hoped that by writing a config line like this [music]=d:\media\audio\music\ would solve the problem but despite trying all the combinations i could guess , im still unable to fix this problem. please help

thanks in advance
Lowlander
Posts: 49063
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: corrupted library after migration

Post by Lowlander »

Maybe start fresh and install as Portable the first time? I'm not sure how this works with the Portable Install as MediaMonkey has always relied on driveID.
Lowlander (MediaMonkey user since 2003)
Daneel
Posts: 5
Joined: Tue Sep 21, 2010 11:23 am

Re: corrupted library after migration

Post by Daneel »

by driveID you mean drive letter like C: etc ?

i want to solve this problem because i have so many palylists that has been created inside MM and by starting fresh i will loose those and i dont want to write down the track list and recreate those ... it takes so much time.
also i dont want drop a problem until i get the answer or i become sure that there is no answer

it seems like MM has changed its way to store track data in its database and its a good thing but it should describe it too so problems like this dont happen ...

looking forward to hear an answer
Lowlander
Posts: 49063
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: corrupted library after migration

Post by Lowlander »

No it is an actual ID that is independent of drive letter. I don't know what to suggest as I'm unfamiliar with how the Portable Install is supposed to handle this. Part of the problem may stem from installing a Portable Install on top of a normal (user modified) install. Too many variables without enough details of how MM handles this to offer suggestions.
Lowlander (MediaMonkey user since 2003)
Post Reply