"Skipping tracks (missing codec)"

Get answers about the current release of MediaMonkey for Android

Moderator: Gurus

Posts: 1
Joined: Sat Mar 03, 2018 6:59 pm

"Skipping tracks (missing codec)"

Post by shamuslit »

I am using latest MMPro on an Asus Z3 (ASUS_Z012DC) . MMPro has worked well for many months. However after an update of both MMA and the OS (Android 8.0.0) from ASUS (though I have no evidence to suggest that these events are related) I am now getting the following error:
"Skipping tracks (missing codec)" and then "Skipping inacessible tracks"
for any and all MP3 files. All other media players work just fine on this device so I know the MP3 files are good. I've deleted and reinstalled MMPro but to no avail. Can anyone suggest a fix for this issue?

Re: "Skipping tracks (missing codec)"

Post by al2112 »

I have the exact same problem. MM Support was not helpful. Wish I could recommend something.

Re: "Skipping tracks (missing codec)"

Post by Jsb1111 »

I have the same problem with MMPA
On my android7.1 head unit It worked well with mp3s for six months. Then I started getting a missing codec message and my MMPA became worthless. VLC still works —so that’s what I will use for now. I would like to know if the MM people ever fix this because if it worked, I would prefer the MM interface.
Posts: 49033
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: "Skipping tracks (missing codec)"

Post by Lowlander »

MediaMonkey only supports those formats that are natively supported by the device. VLC uses its own codecs.

MediaMonkey for Windows can auto-convert files on sync to your device to a format your device supports.
Lowlander (MediaMonkey user since 2003)
Posts: 86
Joined: Mon Feb 07, 2005 10:36 pm
Location: Truckee, CA

Re: "Skipping tracks (missing codec)"

Post by ggibby »

I installed the November update on my Pixel 3a last night, and now MediaMonkey is reporting this error.
Google Play Music crashes when playback is attempted,
but VLC is able to play.

Based on posts above, I assume that FLAC is broken at the OS level.

Odd that I can't find any other users online having this problem.
Post Reply