using 'dead links' function in 'files to edit'

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus


using 'dead links' function in 'files to edit'

Post by tilala » Fri May 19, 2006 11:18 am

Hi everybody,

My post is a little long so I'll give the gist of my problem here, and background follows below for anyone needing more information.

I used "removed dead links" last night to do just that, remove DL's, and this morning my library of 30,000+ songs is missing from my external hard drive. The folder is still there, but it's empty.

I think I may've misunderstood just what's supposed to happen when you use the remove dead links function in 'files to edit'...I didn't think I was actually removing files in my library when using RDL, just removing links to files no longer present at the given location (the links were previously moved from/no longer present on C:, moved to/present on external F: drive). Did I make a mistake?

Just for a bit of background, I usually download music files to my desktop, and in that way I can make sure all of my tags are correct and I can make any other modifications I want before adding them to a folder on an external drive which MM monitors using the filemonitor function (yes, I have a Gold membership--and love it).

Well, somehow I wasn't using filemonitor properly because the files that were originally downloaded to my desktop, drive C:, and moved to drive F:, continued to appear as ghost links, or what I thought were dead links, on my C: drive.

After a while these were really adding up, so I decided to try 'remove dead links', and as far as I can tell, 90% of what was removed was in fact the list of greyed-out files on my C: drive, the rest being the handful of songs I had intentionally deleted from my F: drive previously.

This morning when I tried to search for a song on my F: drive, it came up as a dead link itself, which surprised me, so I decided to open up the folder on F: in which it was stored....the folder is empty.

I *had* +30,000 songs in that folder, and only removed ~5,000 dead links.

Also, when I click "properties" under F: I see that "free space" and "capacity" remain unchanged, which makes me think that my library is still intact somewhere.

Any help would be appreciated.

ps...I'm not bouncing off the walls over this because I really do think those files are still around AND I've got back-ups of everything, but still, it'd be nice if a can correct my mistake as painlessly as possible ;^D

Sorry for the long post, and thanks in advance for any help...

Posts: 47311
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Post by Lowlander » Fri May 19, 2006 11:59 am

Dead links will only remove links to files in the library. Dead links appears for files no longer available (It doesn't seem to show files on a disconnected harddrive).

So most likely something else has happened.

Can you see files on the external drive when going thru Windows Explorer? If no files appear the harddrive might be corrupted. This can easily happen when it's disconnected in the wrong way.
My best advice would be to do a checkdisk on the drive. This can often fix problems but might also result in loss of files. So maybe you should try to investigate this issue more before going ahead with checkdisk.
Lowlander (MediaMonkey user since 2003)


Post by tilala » Fri May 19, 2006 12:13 pm

Oh, holy cow! You know, when I sat down at the computer this morning there was a small window open in the task manager (?) tray with a message stating something to the effect that "the information couldn't be saved properly due to improper shutting down".... of the external drive, IIRC. I paraphrase as I'm at work at the moment.

Hmm, I'll definitely look into it further once I'm back at home.

And again, like I said, the amount of data on my external drive hasn't changed as far as I can tell....there were 10Gs available before this happened and there are still only 10Gs of space free on my F: drive, and of course if 30,000 mp3 files were truly wiped that would've naturally freed up a lot of space, so hopefully there's just some sort of glitch somewhere and the files haven't actually fallen off my harddrive yet.

Posts: 5537
Joined: Tue Sep 06, 2005 11:01 pm

Post by Teknojnky » Fri May 19, 2006 12:44 pm

Ack, hope you are not getting "delayed write failed" errors... these are typically first warnings of external drive failures.

I would get your drive backed up asap, then try to run chkdsk on it.


Post by Guest » Fri May 19, 2006 1:00 pm

Yeah, I hope it's nothing serious. It's a new hard drive from Seagate, tho I know "new" doesn't necessarily mean "safe" and "problem-free". I'm definitely anxious to get home and check the Recycle bin on my F: drive, I library's in there somehow.

Otherwise, thank Gosh I'm obsessive-compulsive enough to have back-ups in one form or another of the mp3's I've managed to collect up to this point (tho not so OCD that I'd already made a back-up of my library database, grrr).

My fault.

Posts: 47311
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Post by Lowlander » Fri May 19, 2006 5:25 pm

Are you using an USB/Firewire drive or one that connects via the network. The network drives are prone to these problems.

Anyway it looks like the drive was removed / got disconnected incorrectly without first disconnecting it in Windows. This probably lead to the file corruption. I unfortunately have been experiencing the same lately with my newest Ximeta harddrive. I once run checkdisk by taking the drive out and hang it in my machine which recovered all that was lost. The second time I run checkdisk thru the USB connection which fixed the unaccesble folders, but didn't recover my files.

You certainly try backing up if you have the space and if it's possible.
Lowlander (MediaMonkey user since 2003)

Posts: 210
Joined: Sat Apr 15, 2006 1:52 pm
Location: new orleans los angeles

Post by tinana » Fri May 19, 2006 6:29 pm

Well, mine is connected via USB/Firewire. I wish I could remember what the message in my tray was this morning, but I just can't. At first I thought that maybe my Firewire cable had slipped out of its socket on my computer as it doesn't seem to fit as snugly as the USB connection, and that's why I clicked on my F: drive to see what was wrong and discovered the missing library.

I'm at work yet for another half hour then I'll be at home and will see just what I can accomplish in relocating those files. The folder itself is still there, it's just empty.

Posts: 210
Joined: Sat Apr 15, 2006 1:52 pm
Location: new orleans los angeles

Post by tinana » Fri May 19, 2006 8:06 pm

HOLY COW!!!!!!

I just got home, got on the computer and immediately *was* greeted with the "delayed write failure" message mentioned earlier.


Now my entire external drive, not just my music folder, was quickly becoming inaccessible.

I quickly started researching possible fixes (it wasn't looking good) and in the meantime thought to take a chance and swap out the Firewire for a USB cable and...problem solved--nothing's been lost and everything works fine again.


Later, I'll try to find out exactly what the problem was...cable, driver, connection, I dunno...but in the meantime, I'm gonna pick up an extra HD this weekend for the peace of mind.

Thanks again for all those who chimed in with advice, it was appreciated!

Post Reply