Synching to a Mapped Drive - Curious Behavior [#17861 ]

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

IanRTaylorUK
Posts: 192
Joined: Fri Dec 27, 2019 4:41 pm

Synching to a Mapped Drive - Curious Behavior [#17861 ]

Post by IanRTaylorUK »

OK so I updated to the latest 2404 version of MMW5 and then created a new "collection" called 21st Century Music (21CM). This collection is for music with a data after 1st January 2000 and contains 20730 tracks out of my 30000+ library. All good so far.

I choose an album from my Entire Library and Play Now before moving the display to 21CM - just something to listen to while I use the new collection. Tracks added to Playing and play OK.

I select the first track of the new 21CM collection and then Select ALL. I then right click and Send To a mapped folder on a laptop. This mapped folder has been previously set-up under Devices / Storage and Services with the 21CM Collection selected under the Sync List(Library--> Device) with conversion / file location / tagging / playlists etc set.

The synch starts:
"Copying to Mapped Drive (Copying xx or yyyyy: Artist - Track) or (Converting)"

Now some interesting things start to happen!
  • Playing changes from the album selected to a arbitrary list
    Each track plays just 10s
    Message pops up "Playback failed: MediaMonkey cannot decode C:\Program Files(x86)\MediaMonkey 5\MediaMonkey 5\Plugins\in_wmp3.dll (or in_mfaudio.dll) (at the 10s mark).
    Copying count increments
    The Playing List has "blank" entries that seem the correspond to the DLLs


If I select a blank entry and right click to remove then I am asked whether I want to remove the DLL from the Playlist Only or database and drive. The DLL is not list in the library when viewing ALL Tracks under Entire Library.

If I select a new album to Play Now, after just 10s it gets displaced by to random choice with half the tracks blank (DLLs). The syn is still running. Cancelling the sync causes a pop-up listing most of the files and the problem of "Conversion of the file failed". Now my tracks go passed the 10s and I can clear the Playing list, add a new album etc.

The following video shows the issue:

https://octoberclub-my.sharepoint.com/: ... Q?e=g0yoT5
Ian Taylor
MM4W 4.1.29.1919 (Normal 12Feb2021) on Windows 10 Pro 64 Bit (v21H1 Build 19043.1110)
Add-Ons:Export / Import Playlists for Child Nodes; Magic Nodes; RegExp Find and Replace; Tagging Inconsistencies
Music library of 33,822 files (D:\) backed up to OneDrive
MMA 1.4.4.0952 on Sony Xperia XZ with Android 8 & ~15,000 Tracks in 925 Playlists
MMA 1.4.4.0952 on Samsung Tab S5e with Android 9 & ~15,000 Tracks in 925 Playlists
XZ synchronised with MM4W using USB; S5e synchronised with MM4W using USB
Trying MM5W 5.0.1.2422 (Normal 19Jul2021) on same Windows 10 PC with a copy of media files (E:\) (and separate library database for each major version!)
Ludek
Posts: 4136
Joined: Fri Mar 09, 2007 9:00 am

Re: Synching to a Mapped Drive - Curious Behavior

Post by Ludek »

That's really curious.

I am unable to replicate the issue, if you still can replicate could you please install debug build and catch it in debug log (item 4b here: https://www.mediamonkey.com/forum/viewt ... 30&t=86643 ) ?

Thanks!

EDIT: Nevertheless by testing this I found that the tracks are converted by default, this is unexpected, to be fixed as https://www.ventismedia.com/mantis/view.php?id=17861 for the next build.
IanRTaylorUK
Posts: 192
Joined: Fri Dec 27, 2019 4:41 pm

Re: Synching to a Mapped Drive - Curious Behavior [#17861 ]

Post by IanRTaylorUK »

Thanks Ludek, might be a few days before I can try to repeat using MMW5 Debug installation.
Ian Taylor
MM4W 4.1.29.1919 (Normal 12Feb2021) on Windows 10 Pro 64 Bit (v21H1 Build 19043.1110)
Add-Ons:Export / Import Playlists for Child Nodes; Magic Nodes; RegExp Find and Replace; Tagging Inconsistencies
Music library of 33,822 files (D:\) backed up to OneDrive
MMA 1.4.4.0952 on Sony Xperia XZ with Android 8 & ~15,000 Tracks in 925 Playlists
MMA 1.4.4.0952 on Samsung Tab S5e with Android 9 & ~15,000 Tracks in 925 Playlists
XZ synchronised with MM4W using USB; S5e synchronised with MM4W using USB
Trying MM5W 5.0.1.2422 (Normal 19Jul2021) on same Windows 10 PC with a copy of media files (E:\) (and separate library database for each major version!)
IanRTaylorUK
Posts: 192
Joined: Fri Dec 27, 2019 4:41 pm

Re: Synching to a Mapped Drive - Curious Behavior [#17861 ]

Post by IanRTaylorUK »

Hi Ludek,

I completely uninstalled MMW5 and then installed the latest 2405 version.

Repeated with a USB connected external drive mapped as my S: drive and was not able to repeat.

So it is possible the problem is fixed. Not able to test at the moment with a WiFi mapped drive on a laptop (as the laptop has been returned).
Ian Taylor
MM4W 4.1.29.1919 (Normal 12Feb2021) on Windows 10 Pro 64 Bit (v21H1 Build 19043.1110)
Add-Ons:Export / Import Playlists for Child Nodes; Magic Nodes; RegExp Find and Replace; Tagging Inconsistencies
Music library of 33,822 files (D:\) backed up to OneDrive
MMA 1.4.4.0952 on Sony Xperia XZ with Android 8 & ~15,000 Tracks in 925 Playlists
MMA 1.4.4.0952 on Samsung Tab S5e with Android 9 & ~15,000 Tracks in 925 Playlists
XZ synchronised with MM4W using USB; S5e synchronised with MM4W using USB
Trying MM5W 5.0.1.2422 (Normal 19Jul2021) on same Windows 10 PC with a copy of media files (E:\) (and separate library database for each major version!)
Post Reply