MMS not scanning mapped directory path

Report bugs & feature requests for MediaMonkey Server and learn about the newest builds.

Moderator: Gurus

allwi
Posts: 58
Joined: Sun Jan 22, 2012 7:34 pm
Location: Sydney NSW

MMS not scanning mapped directory path

Post by allwi »

Hi,

as I'm trying to create a network based media system. So far I used DLNA but was missing the ability to set ratings for the files.
So I gave MediaMonkey Server (0.4.1) a try ... but failed miserably :(

I understand that the current alpha version doesn't support network paths like \\NAS\Music\Library, right?
So I mapped my Music folder to the drive letter M:
The "Library" sub-folder contains my music library in the structure

Code: Select all

Library
+ [ABC]
++[AlbumArtist]
+++[Album]
+[DEF]
++ ...
This is organised by MM4 with the Auto-Organize filter:

Code: Select all

...\Library\$Group($RemovePrefix($First($if(<Album Artist>,<Album Artist>,<Artist>))),3)\$RemovePrefix($First($if(<Album Artist>,<Album Artist>,<Artist>)))\$if(<Album>,<Album>,Singles)\$First(<Artist>) $if(<Album>,(,)$Left($if(<Album>,<Album>,),25)$if($Len(<Album>)>25,...,)$if(<Album>,$) - <Track#:2>,-) <Title>
and worked very well for the last years with MM4.

However when I create a MMS collection Music for the directory M:\Library and rescan the collection, I only get 5 files and actually none of them a mp3 or flac file. Looking more closely at the logs, I saw the message

Code: Select all

Scan movie directory
although the collection is created as a MUSIC collection:
Collection screenshort

Any thoughts?

Debug log
allwi
Posts: 58
Joined: Sun Jan 22, 2012 7:34 pm
Location: Sydney NSW

Re: MMS not scanning mapped directory path

Post by allwi »

Hey Jiri or anyone else for the dev team :)

Any thoughts? Either I did something completely stupid or there is a severe bug in v0.4.1
I configured a music collection but MMS tries to scan for movies. Do I have to wait for the next version or can I solve this in a different way?
jiri
Posts: 5411
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: MMS not scanning mapped directory path

Post by jiri »

I understand that the current alpha version doesn't support network paths like \\NAS\Music\Library, right?
Right, not implemented yet.
I only get 5 files and actually none of them a mp3 or flac file
That's strange, after mapping to a drive letter, it should work fine. We'll look into it, maybe meanwhile you could try to also mail me your MMS database.

Thanks,
Jiri
Ludek
Posts: 4489
Joined: Fri Mar 09, 2007 9:00 am

Re: MMS not scanning mapped directory path

Post by Ludek »

Hi, in the log I see that there are only 9 files to process in the M:/Library/ and all seems video files (MKV, ASX) like:
M:/Library/DEF/FM Einheit/FM 4.5.1 Compilation/FM Einheit (FM 4.5.1 Compilation) - 07 Hammermörder.asx
M:/Library/PQR/Pan Optikum/Il Corso/Il Corso.mov
M:/Library/ABC/Coil/Moon's Milk (In Four Phases)/Coil (Moon's Milk (In Four Phas...) - 102 Moon's Milk or Under an Unquiet Skull (part two).asx


Are you sure that there are really presented audio files?
And if yes and you add only the subfolder where the audio files resides, does it scan them then?
Ludek
Posts: 4489
Joined: Fri Mar 09, 2007 9:00 am

Re: MMS not scanning mapped directory path

Post by Ludek »

BTW: In your log I see:

Scan movie directory: file:M:/Library, 9 files to process
Scan movie directory: file:C:/Users/monsta/Videos, 9 files to process
Scan music directory: file:C:/Users/monsta/Music, 0 files to process

So it seems that you have two video and single music collections?
Either way ot does not correspond to your single collection settings shown on your screenshot.
If you click the three dots menu of the collections and select "Rescan" then does it change anything?

By evidence the issue is that M:/Library is scanned as movie directory (and not music) thus it takes just the video files.
If you create allternate collection M:/Library with type Music then I guess it scans all the audio files?
Could you share your database ( C:\Users\monsta\MediaMonkeyServer\mms.db ) ?
allwi
Posts: 58
Joined: Sun Jan 22, 2012 7:34 pm
Location: Sydney NSW

Re: MMS not scanning mapped directory path

Post by allwi »

Thanks Ludek and Jiri

I did some more testing and the behaviour is very weird but reproducible.
So, after the "installation" of MMS, I deleted the two default collections and create a new Music collection.
The scanning however searched for movies and found the few video files in the music library directory path.

Then I create a new collection which pointed to an album directory. I.e. no subdirectories and only mp3 files.
Same result scanned for movies.

Then I created a new collection for an artist and suddenly all music files for this artist are shown in all collections.

The paths are:
Music collection: M:\Library
Album collection: M:\Library\ABC\Air\Premier Symptoms
Artist collection: M:\Library\ABC\Air

The MMS.DB is here
Ludek
Posts: 4489
Joined: Fri Mar 09, 2007 9:00 am

Re: MMS not scanning mapped directory path

Post by Ludek »

Dmn, it fails to open your mms.db in SQLite studio to analyze, while tryint with mine mms.db it works:
https://www.dropbox.com/s/esbstyeqdw8ut ... 8.png?dl=0

Can you please check whether there are some additional files in the MediaMonkeyServer directory, specifically:
mms.db-wal
mms.db-shm
?

i.e. try zipping whole the folder with the database.

Thanks!
Ludek
Posts: 4489
Joined: Fri Mar 09, 2007 9:00 am

Re: MMS not scanning mapped directory path

Post by Ludek »

Hi, ok, no need for the DB anymore.

I think I replicated it exaclty the same ateps as you described.

Tracking as: https://github.com/mediamonkeyserver/mms/issues/55

Thanks!
allwi
Posts: 58
Joined: Sun Jan 22, 2012 7:34 pm
Location: Sydney NSW

Re: MMS not scanning mapped directory path

Post by allwi »

Cool thanks :)

Just for your reference (and because I had the post already written):
The zipped MediaMonkeyServer directory is here.

I haven't started MMS since the test I described above.
The MediaMonkeyServer directory path is C:\Users\monsta\MediaMonkeyServer.
The MMS software itself is "installed" in C:\Users\monsta\MMS-win64-0.4.1

The machine is running Windows 10 Home, version 10..0.19042
Post Reply