album covers missing when syncing to android

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

railfan-eric
Posts: 47
Joined: Sun Dec 19, 2021 1:31 am

album covers missing when syncing to android

Post by railfan-eric »

I posted about this with no solution. So i posted about it at Poweramp forums. i redid the album covers for an album many times but it won't show the covers and they're missing when the album is synced to the phone and loaded into Poweramp. Media Monkey is doing something how the covers I read. i shared a song to a guy in the forum and he said it wouldn't show the cover in VLC and some other programs on the computer. but he use MP3Tag and resaved the cover there and it fixed the problem so i did the same with my album on my computer. resynced with Media Monkey to my phone and instantly it was fixed in Poweramp. this problem started when i switched from Musicbee to Media Monkey so I'm sure it's a bug in MM.
so that being said i have tons of random songs that need fixed now. I'm not too happy as i have a large library of over 60GB's of music. god knows how far the corruption has gone.
MiPi
Posts: 832
Joined: Tue Aug 18, 2009 2:56 pm
Location: Czech Republic
Contact:

Re: album covers missing when syncing to android

Post by MiPi »

Your description is too general. What file type you use? How do you tag image to it? Could you upload us 2 files - one which has image tagged in MediaMonkey, which does not work on Android, and second the same track, but the one which works on both places? You can PM me link and I will analyze it, thanks.
railfan-eric
Posts: 47
Joined: Sun Dec 19, 2021 1:31 am

Re: album covers missing when syncing to android

Post by railfan-eric »

MiPi wrote: Wed Aug 03, 2022 6:57 am Your description is too general. What file type you use? How do you tag image to it? Could you upload us 2 files - one which has image tagged in MediaMonkey, which does not work on Android, and second the same track, but the one which works on both places? You can PM me link and I will analyze it, thanks.
sorry i thought i explained it good enough. I'm using Mp3's. I have the album art covers embedded and in the folder. but when i look at it in Poweramp it shows no embedded artwork when i look at the ones in question. I sync with Media Monkey Pro over the wifi. I'll upload some tracks when i get a chance.
Andre_H
Posts: 326
Joined: Thu Jan 21, 2021 2:04 pm
Location: Germany

Re: album covers missing when syncing to android

Post by Andre_H »

what format (file format, dimensions?) do the embedded images have? Some apps/player wont show other formats then JPG, and resolutions above 600x600.

Is the embedded image type set to "Front Cover"?

Does PowerAmp expect a specific filename for the cover image in the folder? Is it set up correctly?

Have you tried MMA, does the cover appear there?
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 2016 # only essential addons # my 24/7 media server
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 10 # playing, testing skins & addons # my desktop app
- various MMW 5.xx (portable, local DB & a few media files) on Windows 10 & 11 # ripping CDs, testing new builds in alpha state, trying some scripting things
- MMA Pro (latest build) on Android 10 Phone and Android 11 Tab # WiFi Sync # playing

- MP3Tag, MP3Diags, MP3DirectCut, IrfanView
Barry4679
Posts: 2039
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: album covers missing when syncing to android

Post by Barry4679 »

railfan-eric wrote: Wed Aug 03, 2022 4:19 pm I have the album art covers embedded and in the folder. but when i look at it in Poweramp it shows no embedded artwork when i look at the ones in question. I sync with Media Monkey Pro over the wifi. I'll upload some tracks when i get a chance.
In MM5, check Devices&Services>your_phone ... look at SyncProfile>Tagging ... have you got "Sync All ArtWork To File Folders" checked? In my case I have it syncing to file name of albumart.jpg

I don't think that MM5 does any unusual with the album art files ... I just synced an album to my phone, and I see the requested albumart.jpg file where I expected, ie in my Phone's >Music folder in the correct Artist>Album Folder.

Poweramp, on my phone, see the album OK, including the album art.

nb. I don't have album art embedded into my tracks. And the album I tested was mp3..
Want a dark skin for MM5? This is the one that works best for me .. elegant, compact & clear.
railfan-eric
Posts: 47
Joined: Sun Dec 19, 2021 1:31 am

Re: album covers missing when syncing to android

Post by railfan-eric »

Andre_H wrote: Thu Aug 04, 2022 2:49 am what format (file format, dimensions?) do the embedded images have? Some apps/player wont show other formats then JPG, and resolutions above 600x600.

Is the embedded image type set to "Front Cover"?

Does PowerAmp expect a specific filename for the cover image in the folder? Is it set up correctly?

Have you tried MMA, does the cover appear there?
Poweramp works with hi resolution artwork. do you use Poweramp?
I have everything in my library set to front cover unless something is overlooked.
I don't use MMA because the equalizer sucks and Poweramp is way way better and has skins. But the artwork shows up on MMA when i have looked. But not looked recently. I only use it for syncing.
I don't think Poweramp is picky about ablum cover names. But I don't sync the covers to folders because last time I did that I had thousands of photo albums with one cover in each album in my Gallery apps. that was a mess to delete out.
railfan-eric
Posts: 47
Joined: Sun Dec 19, 2021 1:31 am

Re: album covers missing when syncing to android

Post by railfan-eric »

Barry4679 wrote: Thu Aug 04, 2022 3:59 am
railfan-eric wrote: Wed Aug 03, 2022 4:19 pm I have the album art covers embedded and in the folder. but when i look at it in Poweramp it shows no embedded artwork when i look at the ones in question. I sync with Media Monkey Pro over the wifi. I'll upload some tracks when i get a chance.
In MM5, check Devices&Services>your_phone ... look at SyncProfile>Tagging ... have you got "Sync All ArtWork To File Folders" checked? In my case I have it syncing to file name of albumart.jpg

I don't think that MM5 does any unusual with the album art files ... I just synced an album to my phone, and I see the requested albumart.jpg file where I expected, ie in my Phone's >Music folder in the correct Artist>Album Folder.

Poweramp, on my phone, see the album OK, including the album art.

nb. I don't have album art embedded into my tracks. And the album I tested was mp3..
I don't have anything checked. i don't sync artwork because last time i did that had hundreds or thousands of photo albums with one album cover in each. it took forever to delete them all. i couldnt' see my pictures because there was so many album covers scattered in the gallery.
Andre_H
Posts: 326
Joined: Thu Jan 21, 2021 2:04 pm
Location: Germany

Re: album covers missing when syncing to android

Post by Andre_H »

You can set a .nomedia file to prevent the covers to be shown in your gallery.
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 2016 # only essential addons # my 24/7 media server
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 10 # playing, testing skins & addons # my desktop app
- various MMW 5.xx (portable, local DB & a few media files) on Windows 10 & 11 # ripping CDs, testing new builds in alpha state, trying some scripting things
- MMA Pro (latest build) on Android 10 Phone and Android 11 Tab # WiFi Sync # playing

- MP3Tag, MP3Diags, MP3DirectCut, IrfanView
Andre_H
Posts: 326
Joined: Thu Jan 21, 2021 2:04 pm
Location: Germany

Re: album covers missing when syncing to android

Post by Andre_H »

railfan-eric wrote: Sat Aug 06, 2022 12:10 am But the artwork shows up on MMA when i have looked.
Then it seems to be a poweramp problem? Guess you have to look what conditions for covers poweramp has.
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 2016 # only essential addons # my 24/7 media server
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 10 # playing, testing skins & addons # my desktop app
- various MMW 5.xx (portable, local DB & a few media files) on Windows 10 & 11 # ripping CDs, testing new builds in alpha state, trying some scripting things
- MMA Pro (latest build) on Android 10 Phone and Android 11 Tab # WiFi Sync # playing

- MP3Tag, MP3Diags, MP3DirectCut, IrfanView
Barry4679
Posts: 2039
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: album covers missing when syncing to android

Post by Barry4679 »

railfan-eric wrote: Sat Aug 06, 2022 12:12 am I don't have anything checked. i don't sync artwork because last time i did that had hundreds or thousands of photo albums with one album cover in each. it took forever to delete them all. i couldnt' see my pictures because there was so many album covers scattered in the gallery.
OK, but FWIIW
  • I have it checked
  • I see album art in the dBpoweramp on my phone, for albums that I have sync'd to the phone using MM5
  • and the album images don't pollute the stock Android Google Photos app on my phone
Want a dark skin for MM5? This is the one that works best for me .. elegant, compact & clear.
Andre_H
Posts: 326
Joined: Thu Jan 21, 2021 2:04 pm
Location: Germany

Re: album covers missing when syncing to android

Post by Andre_H »

Same here, installed PowerAmp on Android. I see my music, all with correct cover art.
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 2016 # only essential addons # my 24/7 media server
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 10 # playing, testing skins & addons # my desktop app
- various MMW 5.xx (portable, local DB & a few media files) on Windows 10 & 11 # ripping CDs, testing new builds in alpha state, trying some scripting things
- MMA Pro (latest build) on Android 10 Phone and Android 11 Tab # WiFi Sync # playing

- MP3Tag, MP3Diags, MP3DirectCut, IrfanView
Barry4679
Posts: 2039
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: album covers missing when syncing to android

Post by Barry4679 »

Andre_H wrote: Sat Aug 06, 2022 3:18 pm Same here, installed PowerAmp on Android. I see my music, all with correct cover art.
Hi Andre,

like the OP I once did have an issue where MM5 synch'd tracks polluted the phone's image app.
I looked to see if I had worked around the problem with a nomedia file, like you mentioned in an earlier post in this thread, but It looks like I didn't have to do that.

I an guessing that the earlier problem may have been due to an earlier version of MM5 synching art to the MediaMonkey folder (ie. not into the Music folder, as it does now). ... I do see a .nomedia file in the MediaMonkey folder, which I think that Ludek added during the beta.

My other guess is that Android auto-magically excludes images in the Music folder from the stock images app, because I cannot find any user setting to achieve that.
Want a dark skin for MM5? This is the one that works best for me .. elegant, compact & clear.
Andre_H
Posts: 326
Joined: Thu Jan 21, 2021 2:04 pm
Location: Germany

Re: album covers missing when syncing to android

Post by Andre_H »

Barry4679 wrote: Sat Aug 06, 2022 8:37 pm like the OP I once did have an issue where MM5 synch'd tracks polluted the phone's image app ...
I do see a .nomedia file in the MediaMonkey folder, which I think that Ludek added during the beta.
That's quite possible. I remember that when I started using MMA, I also got all the cover images displayed in the photo galleries, I think I was working around with the .nodmedia file at the time, but that was a good 2 years ago now.

Possibly MMA sets this by default in the meantime. Then the OP's problem should be solved by updating/reinstalling MMA?
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 2016 # only essential addons # my 24/7 media server
- MMW 5.0.3.2627 (non-portable, shared DB & files) on Windows 10 # playing, testing skins & addons # my desktop app
- various MMW 5.xx (portable, local DB & a few media files) on Windows 10 & 11 # ripping CDs, testing new builds in alpha state, trying some scripting things
- MMA Pro (latest build) on Android 10 Phone and Android 11 Tab # WiFi Sync # playing

- MP3Tag, MP3Diags, MP3DirectCut, IrfanView
Rob_S
Posts: 305
Joined: Wed Mar 10, 2021 1:53 pm

Re: album covers missing when syncing to android

Post by Rob_S »

OK, so the OP does not want album art to display in whatever is being used to view images, and does not want to embed album art in tracks, which is what I do.

It appears to me most file image viewers will not display jpgs in a .nomedia folder or in the music folder, but some such as file manager plus will ignore that and display them, so this creates mexican standoff. :)

I can think of the following options:

Solution 1 - embed the art on the phone, using the sync option to copy artwork to tags, thus no loose jpgs (I am assuming this will work, not tested)

Solution 2 - make sure to use music folder or subfolders for all tracks and or the .nomedia, this "should" eliminate the synced jpgs from displaying by most but not all image viewers

Solution 3 - use nomedia files in whatever folders music is synced to https://www.lifewire.com/nomedia-file-4172882 - same result as above

Solution 4 - live without artwork on the phone (android device)

Anything else??
Using build 5.0.4.2659 on Windows 10, HP laptop
railfan-eric
Posts: 47
Joined: Sun Dec 19, 2021 1:31 am

Re: album covers missing when syncing to android

Post by railfan-eric »

Andre_H wrote: Sat Aug 06, 2022 3:54 am You can set a .nomedia file to prevent the covers to be shown in your gallery.
Problem is each cover is in each folder for each music album in the music folder, last i looked. so i would have to put the nomedia file in thousands of folders for that to work.
Post Reply