album covers missing when syncing to android

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

Andre_H
Posts: 337
Joined: Thu Jan 21, 2021 2:04 pm
Location: Germany

Re: album covers missing when syncing to android

Post by Andre_H »

railfan-eric wrote: Tue Aug 09, 2022 11:56 pm
Andre_H wrote: Sat Aug 06, 2022 3:54 am You can set a .nomedia file to prevent the covers to be shown in your gallery.
Problem is each cover is in each folder for each music album in the music folder, last i looked. so i would have to put the nomedia file in thousands of folders for that to work.
Pretty sure that one in the root folder of your music should do the Job.
- MMW 5.0.4.2660 (non-portable, shared DB & files) on Windows 2016 # only essential addons # my 24/7 media server
- MMW 5.0.4.2660 (non-portable, shared DB & files) on Windows 10 # playing, testing skins & addons # my desktop app
- various MMW 5.xx (portable, local DB & a few media files) on Windows 10 & 11 # ripping CDs, testing new builds in alpha state, trying some scripting things
- MMA Pro (latest build) on Android 10 Phone and Android 11 Tab # WiFi Sync # playing

- MP3Tag, MP3Diags, MP3DirectCut, IrfanView
AlanH
Posts: 187
Joined: Sun Sep 08, 2013 3:54 pm

Re: album covers missing when syncing to android

Post by AlanH »

railfan-eric wrote: Tue Aug 09, 2022 11:56 pm
Andre_H wrote: Sat Aug 06, 2022 3:54 am You can set a .nomedia file to prevent the covers to be shown in your gallery.
Problem is each cover is in each folder for each music album in the music folder, last i looked. so i would have to put the nomedia file in thousands of folders for that to work.
I thought if you put the nomedia in the root music folder it applies to all sub folders.
Ludek
Posts: 4667
Joined: Fri Mar 09, 2007 9:00 am

Re: album covers missing when syncing to android

Post by Ludek »

It does not need to include the .nomedia file once you use the default filename format for artworks that is ignored by the photo galleries then. I believe it is 'albumart.jpg'.

It relates to https://www.ventismedia.com/mantis/view.php?id=15923 where for some reason in early MM5 versions the filename was just albumart (without extension), this was fixed in build 2195 + added also auto-correction ('albumart' -> 'albumart.jpg') for the already existing profiles.

i.e. as Barry suggested go to Devices&Services>your_phone ... look at SyncProfile>Tagging
and ansure that the filename format is albumart.jpg
Post Reply