MM5 for Windows playing music too fast

Get answers about the current version of MediaMonkey 5

Moderator: Gurus

rkhanso
Posts: 20
Joined: Sat Mar 16, 2013 3:51 pm

MM5 for Windows playing music too fast

Post by rkhanso »

I recently installed MMW5 and it was working OK for a while. Using it today, all my music is playing too fast and at a higher pitch than it should be. I don't see a Playback Speed option in the software. Searching the web and forum, it looks like there is no native option for changing playback speed. Maybe an addon, but I don't have any addon that would do that.

How can I fix this?
Lowlander
Posts: 56865
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: MM5 for Windows playing music too fast

Post by Lowlander »

Which Build (Help > About) and does switching output plugin help?

Related: https://www.mediamonkey.com/support/kno ... corrupted/
JSNBLK
Posts: 9
Joined: Tue May 05, 2020 9:56 am

Re: MM5 for Windows playing music too fast

Post by JSNBLK »

Occasionally if I switch from KODI to MediaMonkey too quickly, MM will play as you have noticed. I suspect that it has to do with both using the same Output Plugins. Usually simply stopping and pressing play again on MM (making sure the other app is closed) will play again as normal.
rkhanso
Posts: 20
Joined: Sat Mar 16, 2013 3:51 pm

Re: MM5 for Windows playing music too fast

Post by rkhanso »

Lowlander wrote: Mon Apr 22, 2024 7:37 pm Which Build (Help > About) and does switching output plugin help?

Related: https://www.mediamonkey.com/support/kno ... corrupted/
I'm using MMW5 Build 5.0.2.2532

@Lowlander - you're suggestion is definitely on the right track.

Maybe my setup is not as common as others....
I'm using VoiceMeeter and all my computer audio goes through it. I also have a Behringer UM2 audio device that I use for inputs and headphone output, and a Blackmagic Intensity 4K card which I'm outputting my computer audio from to an external amp and speakers.

I have MMW5 Audio output set as ASIO output (dll version) v0.67 SSE2 file: out_asio.dll
When clicking the "Configure" button there and then checking the Resampling box and setting to 48K, the audio is played at normal speed. I have VoiceMeeter set to 48K also. My guess is that MM by default uses a 44.1K sampling rate, because when manually set that in MM, the playback speed is the same as when the resampling is OFF. It's only when I manually set the sampling rate to 48K that it plays at the correct speed.

I'm wondering what combination of config settings would be best. Or might it not really matter and just find whatever combination works? Maybe I should change VoiceMeeter to 44.1K?

Other options for Audio outputs in MMW5 are: MediaMonkey DirectSound output, MediaMonkey WASAPI output, and waveOut output v2.0.2a.
Peke
Posts: 17567
Joined: Tue Jun 10, 2003 7:21 pm
Location: Earth
Contact:

Re: MM5 for Windows playing music too fast

Post by Peke »

Hi,
I wonder why you use ASIO at all? It makes issues all over the Windows except if used in DAW apps exclusively and natively.

WASAPI in non exclusive mode (also disable exclusive access to all playback devices) is much better than ASIO in Windows.

Do you use ASIO4All driver for Behringer UM2? If yes then you have double virtualization which is call to issues. ASIO4ALL is not driver for hardware support but software emulation of ASIO. I have Realtek AC1220 on motherboard and Focusrite Solo 4th gen for headphones and DAW usage, both have native ASIO Drivers not thru ASIO4ALL emulation.

I am curious how you setup your virtualization routing? eg. something like shown at https://shop.vb-audio.com/en/win-apps/9 ... eeter.html
Best regards,
Peke
MediaMonkey Team lead QA/Tech Support guru
Admin of Free MediaMonkey addon Site HappyMonkeying
Image
Image
Image
How to attach PICTURE/SCREENSHOTS to forum posts
rkhanso
Posts: 20
Joined: Sat Mar 16, 2013 3:51 pm

Re: MM5 for Windows playing music too fast

Post by rkhanso »

VoiceMeeter website and forums suggest to use ASIO for the main output device, I think for best timing source, lowest latency, or something like that. I'm not totally sure, and am not an audio engineer. Maybe I mistakenly associated that with ASIO being the best to use whenever possible, thus choosing it for MMW5. I also do use Reaper occasionally to edit podcasts or mess around recording music.

But I had the fast playback no matter which audio output device I used in MMW5. But now after changing it to WSAPI (your suggestion), that doesn't have the option to change the sampling rate and it is playing at the correct speed. Weird. Either I was totally spacing out, or something changed from earlier today.

Yes, I'm using ASIO4All for the Behringer USB audio. It's a real low-end audio interface. That's only where my headphone output is going (through the Behringer), as well as mic and guitar inputs.

As shown in the screenshot, VoiceMeeter is set up with the A1 output as the Blackmagic ASIO Driver to run my speakers. Output A2 is the Behringer for headphones, using WDM Audio. Voicemeeter is working well.

Thanks for the help, Peke.

Image
Post Reply