Messed up titles

To get bugs in the current release fixed, please report them here.

Moderator: Gurus

abecedarian
Posts: 47
Joined: Sun Feb 08, 2004 2:59 am

Messed up titles

Post by abecedarian »

I'm not sure this is a beta problem, and I have not yet checked on
MM2.2. I'm currently using MM2.3B2. Also, this is not my computer (MM2.3B2 works great so far on MY computer). I think it is a strange setting, or font problem.

Anyway, I get garbled text when I do operations such as ripping a CD, or auto-organizing. I have attached a sample image (hope the link works!).

Image

The tags are saved currectly, I think, but auto-organize doesn't work.

Any help would be appreciated.

Thanks,
Al
Last edited by abecedarian on Wed Dec 29, 2004 11:55 pm, edited 1 time in total.
abecedarian
Posts: 47
Joined: Sun Feb 08, 2004 2:59 am

Post by abecedarian »

Ok. I just checked and it doesn't work in good old MM2.2. Perhaps this thread should be moved to bug reports. Anyway, any help would still be much appreciated.
jiri
Posts: 5401
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Post by jiri »

This seems to have something to do with the locale settings for that computer. Isn't it set to some kind of foreign language or some foreign font?

Jiri
abecedarian
Posts: 47
Joined: Sun Feb 08, 2004 2:59 am

Post by abecedarian »

Well, I haven't been able to figure this out. It seems like a font problem or language problem. All the language settings as far as I can tell are set to English. It's not clear to me how to set or change fonts. Tried to set some of the fonts in Display Properties dialog box in Windows XP.

It's not clear by the picture, but the directory portion is displayed just fine. I changed it to "D:\" just to make it easier to see the messed up text, but usually it is "C:\Documents and Settings\......\My Documents\Music files" and that path portion is not messed up. It seems that the tags that are affected are most of the text tags except <path>. It's weird that <path> works, but <filename> doesn't.
abecedarian
Posts: 47
Joined: Sun Feb 08, 2004 2:59 am

Found It!!

Post by abecedarian »

There was a section in the mm.ini file named [FilenameMappings] that seemed wrong to me. It contained:

[FilenameMappings]
3A=2D
2A=2D
3F=
3E=2D
3C=2D
22=27
21=
2F=2D
67=00
68=20
69=02
70=02
71=00
72=00
73=00
74=00
75=00
76=02
77=02
78=20
79=20
20=00
81=00
19=A0

Deleting that section fixed the problem.

How does one actually change these letter mappings in the MM interface?

Anyway, it works!!! :D
Post Reply