iTunes 9.0 Compatibility

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

rusty
Posts: 7233
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

iTunes 9.0 Compatibility

Post by rusty » Thu Sep 10, 2009 9:25 am

Just a quick note that MediaMonkey 3.1.1 is _not_ compatible with the newly-released iTunes 9.0 (actually with the latest version of Quicktime, which is automatically updated when iTunes 9 is installed/upgraded to) or the iPhone/iPod 3.1 firmware that comes with it. Installing the new version of iTunes can cause MediaMonkey to be unable to start or crash when tracks are played.

We recommend not installing iTunes 9 or the new firmware while we investigate the issue. If you've already installed it, see the information below!

-Rusty

Edit:
Check out the beta forum for MM 3.1.2 builds. iTunes 9.0 compatibility is now fixed. See: http://www.mediamonkey.com/forum/viewto ... 45#p221799

Edit 2:
As of build 3.1.2.1267, synching to the iPhone 3.1 firmware is supported.

Edit 3:
If you prefer not to use a beta version of MM, and iPhone/touch sync is not important for you, you can avoid this problem by deleting the iPhone plugin (d_iPhone.dll) at C:\Program Files\MediaMonkey\Plugins


Edit 4:
MediaMonkey 3.2 has been released--this thread is no longer relevant.

rnathoo
Posts: 3
Joined: Wed Aug 26, 2009 1:22 pm

Re: iTunes 9.0 Compatibility

Post by rnathoo » Thu Sep 10, 2009 10:23 am

Hi,
Tooooooooooooooo late. I have upgraded itunes and get a number of error exception messages, re the iphone configurability. I have no iphone and did not install the utility.

Will wait until this is sorted.

Thanks

R Nathoo

DonTay89
Posts: 20
Joined: Tue Jul 01, 2008 7:18 pm
Contact:

Re: iTunes 9.0 Compatibility

Post by DonTay89 » Thu Sep 10, 2009 1:01 pm

rnathoo wrote:Hi,
Tooooooooooooooo late. I have upgraded itunes and get a number of error exception messages, re the iphone configurability. I have no iphone and did not install the utility.

Will wait until this is sorted.

Thanks

R Nathoo
Yeah, it's too late for me too, but I'm glad the MM staff is aware and I will be eagerly awaiting a patch that will allow over half of my library to be able to be played again. :)
I am using the latest MediaMonkey 4 beta on a Windows 7 Home Premium 64-bit machine.

dmac

Re: iTunes 9.0 Compatibility

Post by dmac » Thu Sep 10, 2009 1:03 pm

Me too! Any ETA on when a patch will be released.

iTunes always manages to mess up something on my computer.

tazzman
Posts: 1
Joined: Thu Sep 10, 2009 1:08 pm

Re: iTunes 9.0 Compatibility

Post by tazzman » Thu Sep 10, 2009 1:11 pm

Ditto

salov
Posts: 2
Joined: Wed Feb 28, 2007 11:14 am

Re: iTunes 9.0 Compatibility

Post by salov » Thu Sep 10, 2009 1:14 pm

as mentioned in an other thread delete the file

C:\Program Files (x86)\MediaMonkey\Plugins\d_iPhone.dll

as a workaround

P.S. also the new quicktime version causes this issue

DonTay89
Posts: 20
Joined: Tue Jul 01, 2008 7:18 pm
Contact:

Re: iTunes 9.0 Compatibility

Post by DonTay89 » Thu Sep 10, 2009 3:05 pm

salov wrote:as mentioned in an other thread delete the file

C:\Program Files (x86)\MediaMonkey\Plugins\d_iPhone.dll

as a workaround

P.S. also the new quicktime version causes this issue
That may solve the crashing problem, but it doesn't fix the problem of the AAC/M4A files no longer working.
I am using the latest MediaMonkey 4 beta on a Windows 7 Home Premium 64-bit machine.

crzkat01

Re: iTunes 9.0 Compatibility

Post by crzkat01 » Thu Sep 10, 2009 7:36 pm

Oh how I hate Apple, let me count the ways................. I actually thought that Steve Jobs picture was in the are you human check, you know the 4 legged guy braying about how he is going to force everyone to do it his way. I hope this gets fixed soon. I realize it is my fault for not checking here before I dl/ed the latest Icrap version.

gruntman
Posts: 1
Joined: Thu Sep 10, 2009 8:03 pm

Re: iTunes 9.0 Compatibility

Post by gruntman » Thu Sep 10, 2009 8:12 pm

Rather than deleting d_iPhone.dll, rename it to d_iPhone.OLDdll. That way, if/when you ever need it back, just rename it again.

Zan5hin

Re: iTunes 9.0 Compatibility

Post by Zan5hin » Thu Sep 10, 2009 8:44 pm

I had the problem with the iphone dll as above, and I also had a problem where I tried to start a m4b file and MM told me I don't have the latest quicktime, which is required to play this file. Then MM crashed with a bunch of glorious error codes, and it won't play any m4b files (I assume until I reboot).

I do have the latest quicktime.

Ternaugh
Posts: 13
Joined: Fri Aug 10, 2007 4:05 am

Re: iTunes 9.0 Compatibility

Post by Ternaugh » Thu Sep 10, 2009 9:50 pm

Zan5hin wrote:I had the problem with the iphone dll as above, and I also had a problem where I tried to start a m4b file and MM told me I don't have the latest quicktime, which is required to play this file. Then MM crashed with a bunch of glorious error codes, and it won't play any m4b files (I assume until I reboot).

I do have the latest quicktime.
It's the latest QuickTime version that's failing on my system for playback of .m4a files, and I get the MM dialog box warning me about QT, and asking if I want to upgrade it (but without the crash and error codes, thankfully). If I uninstall, and go back to an earlier version of QT (7.6.2, in this case), MM3 works perfectly. That kills iTunes 9, however, as it requires a newer version of QT than what I had on my system. I don't have an older version of the iTunes installer, or I would have reverted it on my main machine.

JoeG

DaveFrischknecht
Posts: 23
Joined: Wed Mar 25, 2009 12:33 am

Re: iTunes 9.0 Compatibility

Post by DaveFrischknecht » Fri Sep 11, 2009 12:44 am

When will Apple realize that they'll gain even more customers if they make their hardware interoperable with software from other vendors? I like MediaMonkey because it actually adds all the music in my music folder to its library. iTunes always leaves out some files no matter what I do. I guess I'll have to go back to syncing my music to my iPod touch with iTunes again. :x
Dave F

Owyn
Posts: 2018
Joined: Fri Mar 21, 2008 10:55 am
Location: Canada

Re: iTunes 9.0 Compatibility

Post by Owyn » Fri Sep 11, 2009 1:06 am

Ditto to above problems.
I installed just the QT7.6.4 update, i.e. without iTunes.

Resolved problem by installing old QT7.5.5 installer that I had in my archives. QT7.6.2 should be ok as well but I did not have it available.

Note QT7.6.4 has to be removed before older version of installer can be used.

------
Uodated version note. QT7.6.3 is OSX Snow Leopard release. QT7.6.2 is latest prior release for Windows.
Looked around for copy of QT7.6.2 for Windows. No luck. Only links I could find were already updated to QT7.6.4.
Cogito cogito ergo cogito sum. (Ambrose Bierce)
I drink therefore I am. (Monty Python)
Vista 32bit Home Premium SP2 / MM3.2.1.1297 Gold / Last.Fm 1.0.2.22 / IE8
Dell Inspiron 530 (1.8 Core2 / 2GB)
Skin: Vitreous Blue
Scripts: Add/Remove Playstat|Advanced Duplicate Find & Fix|Album Art Tagger|Backup|Batch Art Finder|Calculate Cover Size|Case&Leading Zero Fixer|DB_Audit|DB_Clean|DB_Schema|Event Logger|Genre Finder|Lyricator|Magic Nodes|MM2VLC|Monkey Rok|MusicIP Tagger|PUID Generator|RegExp Find & Replace|Right Click for Scripts|Scriptreloader|SQL Viewer|Stats(Filtered)|Tagging Inconsistencies

CRYBYE

Re: iTunes 9.0 Compatibility

Post by CRYBYE » Fri Sep 11, 2009 2:35 am

:P Cool, I'm not the only one!
I pray for help because I can't live without my MM! :roll:
WTF APPLE :oops:

mattinsa
Posts: 3
Joined: Thu Oct 30, 2008 2:23 am

Re: iTunes 9.0 Compatibility

Post by mattinsa » Fri Sep 11, 2009 3:14 am

ok - also have this issue, have removed quicktime until MM patch/upgrade is released.

thanks guys.

Post Reply