1248 Incremental auto-sync corrupts ZEN [#5833]

Beta Testing for Windows Products and plugins

Moderator: Gurus

1248 Incremental auto-sync corrupts ZEN [#5833]

Postby chrisjj » Thu May 28, 2009 2:01 pm

I did the following:

1 Format a Creative ZEN
2 Auto-sync 1998 WMAs and MP3a via Music and Playlists tabs (Filters not enabled in the autosync dialog, Tracks not selected using the 'advanced' selector, Auto-playlists not used)
3 Change Album tags of 522 WMAs
4 Auto-sync again
5 Run WMlog.exe

Expected (well, desired): all files present and true on device
Observed: variously, some filepaths corrupted e.g.

Viewed in Explorer, 123.wma corrupted to <title>.wma:
Image

and 33.wma corrupted to <title>.wma:
Image

Viewed in WMlog, these files' names corrupted to null:
Image

Then I did:

5 Auto-sync again

Expected: no worse, and perhaps better
Observed: three more filepaths corrupted, according to 'Delete from Device' which [EDIT:] finds present on device three files that were /not/ present at #5:
Image

and Explorer confirms these are now present:
Image
but no files with such title/artist pairings appear anywhere in the library.

6 Auto-sync again

Expected: not much :(
Observed: two more filepaths corrupted, and this times the files are zero length:
Image
Image

The above fits with my experience since first using MM to sync with a Creative ZEN: It explains spurious Delete from Device occurrences, missing tracks, and jumbled tags also reported recently by Nyn.

EDIT: Another symptom is entries appearing out of place on alphabetical list on the device, pranging navigation of those lists. Reported also at viewtopic.php?f=12&t=42763 though there cause unknown.

EDIT: Note: now assumed to be the cause of
1187 Duplicate file under identical name on portable device
viewtopic.php?f=7&t=33688

EDIT: Device Configuration says Sync tracks to: \Music\DJ09\<Path>

Workaround: Format device before each sync.

Note:
Code: Select all
Device
Creative ZEN
Version: 1.21.03e
Total Space: 7620MB
Free Space: 1292Mb
Track Count: 1998
Album Count: 125
Playlist Count: 150

Driver:
Creative ZEN
Driver Provider:       Microsoft
Driver Date:            2006-02-22
Driver Version:        5.2.5326.4762
Digital Signer:          Microsoft Windows Component Publisher

OS:
Win XP SP2 plus WMF11

The only programs known to access the ZEN that are installed are the ZEN driver, Explorer and MediaMonkey. No software from the Creative Labs ZEN CD has even in the past been installed on this setup.


EDIT: Tracked at http://www.ventismedia.com/mantis/view.php?id=5833
Chris
chrisjj
 
Posts: 4926
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby nynaevelan » Thu May 28, 2009 2:23 pm

Chris:

I know you do not want to read this but THANK YOU, for a while there I thought I was drowning alone. Now back to being useful, I plan on doing some more tests this weekend in a clean enviroment, I will try to run the tests using your steps.

Devs: The workaround that Chris suggests is NOT something I want to do, at this point I am debating if I want to live with the corruption or reformat every weekend. But I have videos and photos that I do not want to reload each time I re-format, not to mention having to keep putting my settings back. BTW Chris which Zen are your running these tests on, the original Zen?

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby chrisjj » Thu May 28, 2009 5:27 pm

> BTW Chris which Zen are your running these tests on, the original Zen?

Dunno about original but it is the one named just "ZEN".
Chris
chrisjj
 
Posts: 4926
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby nynaevelan » Thu May 28, 2009 5:38 pm

That's what I thought, but I wasn't sure if you had one of the X-Fi ones, I have one of each but they behave differently during syncs, although the Zen doesn't give me as much trouble as the X-Fi.
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby chrisjj » Thu May 28, 2009 5:41 pm

> plan on doing some more tests this weekend in a clean enviroment, I will try to run the tests using your steps.

Actually I think the time is right for the Devs to do some testing with the ZEN. Especially as I get the impression they haven't done any such previously.
Chris
chrisjj
 
Posts: 4926
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby nynaevelan » Fri May 29, 2009 5:35 pm

Ok:

I have had time to complete 4 tests today and after each one I ended up with corrupted files on my Zen. These are all incremental syncs completed in a clean environment. This environment only has Vista Home Premium (with all the latest updates) and Mediamonkey. I have not installed any other software on this partition. You can download the four wmlogs from here. Here is some examples of the corrupted files.

Image

Image

Image

I am going to make an assumption and say the files with 0kb's in size are corrupted album files and the ones with sizes are corrupted music files.

This is just examples of 3 of my 13 genre's but all 13 of them have corrupted files after each sync. And before you ask, after I completed the tests and checked them I used the Zen's Recovery scan to clean them all off, so these are put on after each sync. I followed pretty much the same steps as Chris except I used mp3's on all my tests. And each test consisted of either playlist changes or tag changes. Once I finish some other things I am going to conduct some more tests but without the delete feature turned on.

As a side note, this problem has been going on for some time discussed here and here, what more can we do in order to get a ticket created?? And after all the research and dedication I have given for this problem, if not for the fact that I already own a lifetime copy of MM, I would want a free copy for services rendered. :wink:

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby nynaevelan » Fri May 29, 2009 5:57 pm

Chris:

Do you have the auto-unmount option selected on your Zen's??

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby chrisjj » Fri May 29, 2009 6:08 pm

Nice work Nyn.

FTR, lets have the ZEN firmware version too.

> I am going to make an assumption and say the files with 0kb's in size are
> corrupted album files and the ones with sizes are corrupted music files.

All my 0Kb corrupted files appeared to be tracks. Explorer shows .ALB files as 0Kb anyway.

> Do you have the auto-unmount option selected on your Zen's??

I don't see any such option, having looked on the device, device Explorer properties, and device driver Settings.
Chris
chrisjj
 
Posts: 4926
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby nynaevelan » Fri May 29, 2009 6:22 pm

chrisjj wrote:Nice work Nyn.

FTR, lets have the ZEN firmware version too.


My FW version is 1.04.08_1.3.3, this is on my X-Fi device.

chrisjj wrote:> I am going to make an assumption and say the files with 0kb's in size are
> corrupted album files and the ones with sizes are corrupted music files.

All my 0Kb corrupted files appeared to be tracks. Explorer shows .ALB files as 0Kb anyway.


Mine too that is why I made the assumption they were alb files, silly me.

chrisjj wrote:> Do you have the auto-unmount option selected on your Zen's??

I don't see any such option, having looked on the device, device Explorer properties, and device driver Settings.


I meant the auto-unmount option within MM, it is on the Auto-Sync Options Page. And FTR it doesn't make a difference, I just tried a sync with the delete turned off and the un-mount turned on and I still ended up with the same results.

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby nynaevelan » Fri May 29, 2009 7:14 pm

This just keeps getting better and better, this is what the playlist looks like for one of the corrupted tracks:

Image

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby chrisjj » Fri May 29, 2009 8:33 pm

> I meant the auto-unmount option within MM, it is on the Auto-Sync Options Page.

Ah, right. "[ ] Automatically unmount device after Auto-Sync" is untiked. (That's the default, and with no documentation as to why it might be needed, I didn't change it.)

> And FTR it doesn't make a difference

OK, thanks.
Chris
chrisjj
 
Posts: 4926
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby nynaevelan » Sun Jun 14, 2009 6:08 pm

Here is another topic discussing the same problems. The problem is affecting more users than just Chris and I.

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby Zeke129 » Wed Jun 17, 2009 1:04 am

I have a Zen and have never been able to reproduce this. The player shows the exact same number of tracks as the auto-sync window, and none are corrupted. I don't have WMA files, but I tried following the steps outlined in the OP and changed some of the track properties and resynced. Worked fine. I've had some glitches in the past with ratings and play counts not syncing properly, but that is minor. I could autosync over and over and never get any corruption issues.

I need to ask: what firmware version are you guys running?
Zeke129
 
Posts: 35
Joined: Mon Jan 26, 2009 2:58 pm

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby chrisjj » Wed Jun 17, 2009 3:54 am

> I need to ask: what firmware version are you guys running?

As the OP says: Version: 1.21.03e .
Chris
chrisjj
 
Posts: 4926
Joined: Wed Feb 14, 2007 5:14 pm
Location: UK

Re: 1248 Incremental auto-sync corrupts ZEN -----------

Postby nynaevelan » Wed Jun 17, 2009 4:31 am

My X-fi uses 1.04.08, my Zen uses 1.21.03e. You should consider yourself very fortunate to not be plagued with these problems. I am curios, what is your sync setup? How many tracks? How many playlists? Any overlap of tracks in the playlists? Do you have alot of tracks which frequently change in MM, which requires re-syncing on the Zen?

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Next

Return to MediaMonkey for Windows 4 Beta Testing

Who is online

Users browsing this forum: Bing [Bot] and 11 guests