1343: OUT_WASAPI 24 bit...only noise [#7146]

Beta Testing for Windows Products and plugins

Moderator: Gurus

luckyaua

1343: OUT_WASAPI 24 bit...only noise [#7146]

Post by luckyaua » Tue Jan 04, 2011 7:18 pm

All sample rate with 16bit is ok...
..with 24bit all sample rate i heard only noise...

my conf is:
pc-->nvidia gtx 460-->hdmi-->a/v receiver 100% 24bit/192Khz compatible.

Is possible to add "as input" on output sample/bit format?

Thanx!!

jiri
Posts: 5395
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: OUT_WASAPI 24 bit...only noise!!

Post by jiri » Wed Jan 05, 2011 6:52 am

Please add more details - is it in Exclusive mode? Do you mean 24-bit output configuration, or are you using 24-bit tracks as input? How exactly is configured the output plug-in?

Thanks,
Jiri

Guest

Re: OUT_WASAPI 24 bit...only noise!!

Post by Guest » Wed Jan 05, 2011 7:04 am

Thanx for reply
...so i use exclusive mode and the tracks is flac stereo
..the resolution and bit-depth i've indicated is for file in input.

my goal is that the output configuration/sample rate/bit-depth is the same of the input file
..so for flac stereo 96Khz/24bit in input the output should be the same and then the a/v receiver should show PCM 2.0 / 96khz / 24bit
while for flac stereo 48Khz/16bit in input the output should be the same and then the a/v receiver should show PCM 2.0 / 48khz / 16bit
..etc

Guest

Re: OUT_WASAPI 24 bit...only noise!!

Post by Guest » Wed Jan 05, 2011 7:06 am

...naturally my goal is bypass windows 7 64-bit mixer and control panel configuration..
now the config seven is 5.1 speaker and share mode 44Khz/16bit.

jiri
Posts: 5395
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: OUT_WASAPI 24 bit...only noise!!

Post by jiri » Wed Jan 05, 2011 10:16 am

As for your request - ok, will try to implement.

As for the bug - I can't reproduce, I play 192/24 flawlessly. What output format do you have set in the Exclusive mode?

Jiri

Guest

Re: OUT_WASAPI 24 bit...only noise!!

Post by Guest » Wed Jan 05, 2011 10:37 am

...ok implement is essential for me.

...i try to use the same output format as the input then when i've try flac 24/48 i set the output of exclusive to the same.

The same flac works fine with mmonkey 3 setting the same format of the flac in output shared mode windows control panel.

luckyaua

Re: OUT_WASAPI 24 bit...only noise!!

Post by luckyaua » Wed Jan 05, 2011 1:14 pm

the problem is "only" with 24 bit parameters
...all output with 24 bit i heard noise...all 16bit format are ok.

luckyaua

Re: OUT_WASAPI 24 bit...only noise!!

Post by luckyaua » Tue Jan 18, 2011 5:36 pm

With 1344...thanks for option Auto Choose output bit depth/sample rate...the selction work very fine for me
....but with flac 24bit i still having only noise....
...my hardware is nvidia gtx460--->HDMI--->Cambridge Audio Azur AVR650R..(the Avr is fully compatible with depth 16/24 and sample rate from 44 to 192Khz).

Lowlander
Posts: 46625
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: OUT_WASAPI 24 bit...only noise!!

Post by Lowlander » Tue Jan 18, 2011 5:39 pm

It isn't clear what is fixed in 1344, but the 24bit noise should be fixed in 1345.

See: http://www.ventismedia.com/mantis/view.php?id=7146
Lowlander (MediaMonkey user since 2003)

jiri
Posts: 5395
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: 1343: OUT_WASAPI 24 bit...only noise [#7146]

Post by jiri » Tue Jan 18, 2011 6:08 pm

luckyaua, please include as many details as possible, it would be useful to know whether you use Volume Leveling (MM Play menu), all the configuration details of the WASAPI plug-in (and whether they have any influence), sampling rate of the 24-bit files you test, etc. The 24-bit files I tested work very well, so maybe even upload a sample file somewhere, so that I can test it.

Thanks,
Jiri

luckyaua

Re: 1343: OUT_WASAPI 24 bit...only noise [#7146]

Post by luckyaua » Wed Jan 19, 2011 12:55 am

Fhe file that i've tested is downloadable from here:
http://www.2l.no/hires/index.html

The wasapi setting are:

Exclusive mode : YES ( Automatic choose of format)

all other options OFF

Volume levelling OFF or ON is the same

My HTPC-->AVR link is trought HDMI nof SPDIF

luckyaua

Re: 1343: OUT_WASAPI 24 bit...only noise [#7146]

Post by luckyaua » Wed Jan 19, 2011 3:43 am

The same file with shared mode or with other player (XBMC Wasapi, VLC) sounds perfect.

jiri
Posts: 5395
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: 1343: OUT_WASAPI 24 bit...only noise [#7146]

Post by jiri » Wed Jan 19, 2011 3:54 am

Ok, one more detail please, how exactly does look the combination of input and output audio streams? I.e., if you switch from Auto mode to some specific format in which you hear the noise, how exactly does it look like? For example, I have:

192kHz, 24bit, 2 channels input file -> 96kHz, 24bit, 2 channels output file

and it plays fine. I have tested many other combinations as well.

Btw, I have been testing the very same tracks as you... ;-)

Jiri

luckyaua

Re: 1343: OUT_WASAPI 24 bit...only noise [#7146]

Post by luckyaua » Wed Jan 19, 2011 4:06 am

The problem is only with 24bit output selection...all format with 16bit is ok.

for example if i have

192kHz, 24bit, 2 channels input file -> 192/96/48kHz, 16bit, 2 channels output file all is ok
if i select:
192kHz, 24bit, 2 channels input file -> 192/96/48kHz, 24bit, 2 channels output file i heard noise (the sound of music is very very low under noise)

jiri
Posts: 5395
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: 1343: OUT_WASAPI 24 bit...only noise [#7146]

Post by jiri » Wed Jan 19, 2011 6:28 am

No matter how I test, it works fine here. Do you have a clean installation of MM? Can't it be that you have some DSP plug-in that doesn't handle 24-bits enabled? If nothing helps, try to create a debug log and e-mail it to me (jh @ our domain).

Thanks,
Jiri

Post Reply