[1486] ios5 sync still fails, iphone 4s disappears [#9318]

Beta Testing for Windows Products and plugins

Moderator: Gurus

tinana
Posts: 210
Joined: Sat Apr 15, 2006 1:52 pm
Location: new orleans los angeles

[1486] ios5 sync still fails, iphone 4s disappears [#9318]

Post by tinana » Wed May 02, 2012 10:15 pm

It seems attempting to sync any number of tracks in 1486 to iphone 4s still results in failure. In addition, iphone eventually disappears media tree after initially showing up as connected. Debug log submitted.

Win7 Home Premium x64 6g ram
iphone 4s 64g ios 5.0.1
Image
MM Gold/Lifetime member

Ludek
Posts: 2741
Joined: Fri Mar 09, 2007 9:00 am

Re: [1486] ios5 sync still fails, iphone 4s disappears

Post by Ludek » Thu May 03, 2012 8:09 am

Where is the debug log?

Does it disappear from MM interface only or from the iTunes too?
Do you use a USB hub? If yes, try to connect it directly.

tinana
Posts: 210
Joined: Sat Apr 15, 2006 1:52 pm
Location: new orleans los angeles

Re: [1486] ios5 sync still fails, iphone 4s disappears

Post by tinana » Thu May 03, 2012 11:30 am

VTA-280624

It only disappears from MM.

I don't use a USB hub, I connect directly.
Image
MM Gold/Lifetime member

yarman
Posts: 19
Joined: Fri Apr 27, 2012 11:32 am

Re: [1486] ios5 sync still fails, iphone 4s disappears [#931

Post by yarman » Fri May 04, 2012 7:17 am

Well, I have had almost but not quite complete success with [1486] with an IOS 5.1 iPod touch. I was able to sync all the tracks I wanted - but not necessarily on the first try. Most times all the tracks on an album were properly transferred, but on occasion it took two tries for some of the tracks and once or twice three tries. The missed tracks were usually just random (1, 2 & 5 would sync on the first try, 3 & 4 would not) but it mostly affected later tracks on the album. The remaining issues I have are:

1) MM syncs the artwork just fine, but then doesn't recognize it. That is, if I go to Properties for a track that is on my iPod the Artwork tab is empty. Yet the artwork is there and displays properly on the iPod itself.

2) MM does not recognize playlists on the iPod.

3) (Trivial) The tracks I synced were all Classical Music type. The type did not sync as all the tracks were type Music after transfer. The iPod does accept Classical Music type as I made a wholesale change on the tracks I had transferred and MM recognized this.

[1486] seems to be getting very close.

Lowlander
Posts: 45442
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [1486] ios5 sync still fails, iphone 4s disappears [#931

Post by Lowlander » Fri May 04, 2012 10:16 am

Did you remove all files within MediaMonkey from device and then sync a single track using iTunes. This may be required to get proper syncing (to get rid of problems caused by earlier beta's).
Lowlander (MediaMonkey user since 2003)

yarman
Posts: 19
Joined: Fri Apr 27, 2012 11:32 am

Re: [1486] ios5 sync still fails, iphone 4s disappears [#931

Post by yarman » Fri May 04, 2012 10:36 am

Lowlander wrote:Did you remove all files within MediaMonkey from device and then sync a single track using iTunes. This may be required to get proper syncing (to get rid of problems caused by earlier beta's).
Yes, I did. In fact I deleted everything and then synced a number of tracks from iTunes. But iTunes wouldn't sync the artwork, so I deleted everything again before trying [1486].

I can report some more on syncing with [1486]. I still occasionally get a track that doesn't sync first time - even though other tracks from the same album sync fine at the same time. In fact, it seems the more tracks I am syncing, the less likely I am to have a track that fails.

And for what reason I don't know, the problem with type (Classical Music) not properly syncing seems to have disappeared.

And, when I detached the iPod and re-connected it, MM found the playlists on the iPod. It seems it won't find any that are created while it is attached, but when it is forced to scan it again, it finds them. Though it actually lists one of the playlists twice??

And even after re-scanning it doesn't find the artwork on the iPod, though it transfers it just fine.

All in all, I'd say for me [1486] is getting pretty close. It's annoying to have to sync some tracks several times, but for now I am able to get what I want on an iPod that has IOS 5.1 on it.

ADDED: I forget to mention that the tracks that I was syncing were a mix of just copying (from MP3 files) and converting (from FLAC files). The type of source file did not seem to have any effect on whether there was a problem with any of the tracks.

Lowlander
Posts: 45442
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: [1486] ios5 sync still fails, iphone 4s disappears [#931

Post by Lowlander » Fri May 04, 2012 11:04 am

Debug logs (step 4b) are most helpful in these situations, just send them to support: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
Lowlander (MediaMonkey user since 2003)

GD3771730
Posts: 31
Joined: Mon Dec 21, 2009 5:33 pm
Location: Paris

Re: [1486] ios5 sync still fails, iphone 4s disappears [#931

Post by GD3771730 » Fri May 04, 2012 2:42 pm

Hi Lowlander, have you checked the fact that multiprocessing (Tools->Options->General->Performance->Auto-conversion) could result in concurrent syncs that could mess up the iphone database ?
Just a suggestion.

rusty
Posts: 7162
Joined: Tue Apr 29, 2003 3:39 am
Location: Montreal, Canada

Re: [1486] ios5 sync still fails, iphone 4s disappears [#931

Post by rusty » Mon May 07, 2012 5:01 pm

Hi Yarman,

Thanks for the feedback. Re. your comments:
1) MediaMonkey has never been able to browse the artwork on iOS devices
2) There was a bug fixed in 1488 ( http://www.ventismedia.com/mantis/view.php?id=9316 ) that might be related--give the new build a try.

Let us know how the new build works for you.

Thanks.

-Rusty

Post Reply