[Solved] MM not starting caught in a loop

Get answers about using the current release of MediaMonkey for Windows.

Moderator: Gurus

Ashran
Posts: 34
Joined: Wed Nov 19, 2008 4:10 pm

[Solved] MM not starting caught in a loop

Post by Ashran » Fri Oct 31, 2014 8:38 am

Hi.

I recently bought a new computer and installed the latest version of mediamonkey on it. I proceded to move my collection to the new database, leaving all the music on the other computer (I access is through the network). All was working fine, but after a day, I can not open mediamonkey anymore. I tried removing the usual dll for iphone and ipad (quicktime corruption work around) but still it was not working.

I installed the debug version of mediamonkey, but could not produce a log since it's not starting so I took the debugviewer and looked at what was happenning. Here it is:

Code: Select all

[7764] TEventedAutoObject Created, Class: TSDBTreeNode
[7764] TEventedAutoObject Destroying, Class: TSDBTreeNode
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 3031.
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 851756.
[7764] TEventedAutoObject Created, Class: TSDBTreeNode
[7764] TEventedAutoObject Destroying, Class: TSDBTreeNode
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 2807.
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 856208.
[7764] TEventedAutoObject Created, Class: TSDBTreeNode
[7764] TEventedAutoObject Destroying, Class: TSDBTreeNode
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 2842.
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 852911.
[7764] TEventedAutoObject Created, Class: TSDBTreeNode
[7764] TEventedAutoObject Destroying, Class: TSDBTreeNode
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 3093.
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 871636.
[7764] TEventedAutoObject Created, Class: TSDBTreeNode
[7764] TEventedAutoObject Destroying, Class: TSDBTreeNode
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 2858.
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 879906.
[7764] TEventedAutoObject Created, Class: TSDBTreeNode
[7764] TEventedAutoObject Destroying, Class: TSDBTreeNode
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 2988.
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 857785.
[7764] TEventedAutoObject Created, Class: TSDBTreeNode
[7764] TEventedAutoObject Destroying, Class: TSDBTreeNode
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=0 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 2803.
[7764] 17876 DB open SQL: SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] OpenQuery - Preparing query SELECT * FROM Playlists WHERE Playlists.ParentPlaylist=26215 ORDER BY Playlists.PlaylistName 
[7764] 17876 DB lock finished, took 872277.
[7764] TEventedAutoObject Created, Class: TSDBTreeNode
As you can see, it seems trapped in a loop. What can I do to solve this ?

edit: If i remove the database, mediamonkey starts fine, but I don't want to do that because I have a huge database (800.000+ songs) and it takes forever to put it back inside mm, and it's the second time I'm doing it.
Last edited by Ashran on Fri Oct 31, 2014 12:07 pm, edited 1 time in total.

Lowlander
Posts: 46273
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: MM not starting caught in a loop

Post by Lowlander » Fri Oct 31, 2014 11:11 am

Send the full log to support (or offer the DB): http://www.mediamonkey.com/support/inde ... ets/Submit
Lowlander (MediaMonkey user since 2003)

Ashran
Posts: 34
Joined: Wed Nov 19, 2008 4:10 pm

Re: MM not starting caught in a loop

Post by Ashran » Fri Oct 31, 2014 11:23 am

I have news. The loop seems not a loop because "after some time" (I left it in my taskmanager) MM opened. "After Some time" = at least two hours, but I don't have a precise timing. To think of it, it might be the imported playlists (the one imported when scanning the hard drive to add music, the .m3u files and so on often found with mp3's) that might cause the trouble. At least it's what I understand from seeing the same request over and over and after a very long time, MM finally opens. Is there a way to not scan thoses files ? I don't use thoses playlists...

I can give you a full debug file when it finally opens (I closed it by mistake). As for the database, it's more than 3 gigs big, I don't know how to send it your way.

Lowlander
Posts: 46273
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: MM not starting caught in a loop

Post by Lowlander » Fri Oct 31, 2014 11:25 am

Do you have File Monitoring enabled? Disable it or deselect the Playlist File Types under File > Add/Rescan Files.
Lowlander (MediaMonkey user since 2003)

Ashran
Posts: 34
Joined: Wed Nov 19, 2008 4:10 pm

Re: MM not starting caught in a loop

Post by Ashran » Fri Oct 31, 2014 11:28 am

I have no way of checking if it's enabled or not right now, as it's trying to start. I think it's not enabled, but I can not garantee it. I did not activate that function, but maybe it's activated by default.

I'll try your solution as soon as it opens and get back to you.

Lowlander
Posts: 46273
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: MM not starting caught in a loop

Post by Lowlander » Fri Oct 31, 2014 11:37 am

It's not activated by default, and you need Gold to be able to activate it.
Lowlander (MediaMonkey user since 2003)

Ashran
Posts: 34
Joined: Wed Nov 19, 2008 4:10 pm

Re: MM not starting caught in a loop

Post by Ashran » Fri Oct 31, 2014 11:40 am

I have gold so it's not impossible. I could have activated it when I scanned for my files. I just don't remember if it's the case or not. I would not have done it on purpose though as I have never used that feature on my other computer.

Ashran
Posts: 34
Joined: Wed Nov 19, 2008 4:10 pm

Re: MM not starting caught in a loop

Post by Ashran » Fri Oct 31, 2014 12:04 pm

The function was not activated. I removed the playlist import option when I add tracks, so I think they will not come back . I have ereased all the imported playlists. Shutted down, and restarted, and ho and behold, it opened almost instantaneously (hard word, that, for a non english native, sorry if it's wrong) I think we can call it a closed case. Thank you for your time and the answers :)

Post Reply