Last.FM Scrobbler Plugin Info

From MediaMonkey Wiki
Jump to: navigation, search

About Last.FM Scrobbler Support

Mediamonkey supports the Last.FM 'scrobbler' plugins to submit played tracks within MediaMonkey itself (portable player sync'd played tracks are not supported).

Currently there are 3 main plugins available, only ONE of which should reside in the "<MediaMonkey program folder>\Plugins" folder.

NOTE: Option 3 Is recommended for use

Option 1: gen_audioscrobbler.dll (v 1.1.10)

This is the last 'old style' plugin for winamp 2 compatible clients. This plugin uses a config panel normally accessed via Tool > Options > Player > General Plugins > Plugin Config.

You can download this from the links @ http://www.last.fm/forum/34905/_/135053

Occasionally the config panel will get hidden behind the MM app window, if the MM window is made smaller you can usually then click on the config panel to bring it to the front where you can change and save your settings. Alternative way is to use ALT+TAB to bring back focus to config panel.

This plugin does not support last.fm profile "Now Playing" updates, and some unicode characters can cause a track to not be submitted.

INSTALLATION:

  • Download this: http://static.last.fm/plugins/audioscrobbler.wa.1.1.10.exe
  • Install to \Program Files\Mediamonkey\Plugins\
  • Choose 'General' option rather than 'Media library' option when installing.
  • Restart MM or start it, and go into Tools -> Options -> General Plug-ins to enter your login information
  • Scrobble!

Option 2: gen_wa2_scrobbler.dll (v 2.x.x)

This is the offical current style of last.fm plugins. This plugin utilizes a 'tray application' which gives some additional metadata info and includes the last.fm radio player for streaming radio.

The last compatible version for v2 plugins is 2.0.45, newer plugins are currently incompatible with MediaMonkey.

To configure the version 2 style, you must open the tray application and configure through it's options. The plugin does not have any self configure, nor will it function without the tray application installed and running (normally the plugin will start the tray app automatically).

The latest official plugins are always available at Last.FM http://www.last.fm/download/ keeping in mind that while the latest tray app should work, plugins newer than 2.0.45 will not.

INSTALLATION:

Option 3: gen_LastFMScrobbler.dll Native Last.FM Scrobbler Plugin

Native MM last.fm plugin - Requires at least MediaMonkey version 3.1 Only one that Scrobbles Unicode Tracks Correctly; Does NOT need Last.fm Util/player to be installed (And if it is installed suggested action is to disable Scrobbling of tracks played in last.fm player).

See complete forum thread for more details

INSTALLATION: