UI jerky and slow for tracks with no art [#16214]

Report bugs & feature requests for MediaMonkey 5 and learn about the newest builds.

Moderator: Gurus

Barry4679
Posts: 1365
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

UI jerky and slow for tracks with no art [#16214]

Post by Barry4679 »

I downloaded an album from my GPM library using MM5 ... an album which was not previously on my PC, and not in MM db.
  • the Tagging tab at D&S>GPM has Sync ALL Artwork To Folders is set off
  • Copy Art to tags is set on
  • the Library|MetadataLookup tab, at Tools|Options, has Looking Missing Artwork set on
  • When I view this album the MM5 UI is jerky and slow
  • I expected that when I viewed the album, after you had obtained the art from GPM, you would insert the overlay icon that offers to save the album art to my local cache ... this did not happen
I sent a link, to Ludek, of a .mp4 recording of the UI ... you can see
  • I selected the album, and then a track from the album
  • the rhs panel was showing the Selected panel ... 20 seconds later it was still showing the art from a previous album that I had selected ... I could understand that it may take you a while to retrieve the new art, but you should clear the previous art as soon as I change the selection
  • for over a minute the breadcrumb on the toolbar is jerking around, which is distracting
  • I waited for a long time ... you were displaying me the art ... the track is in my MM.db without art (as you can see in the video) ... but you didn't put the overlay icon into the art offering to save it for me.
Barry4679
Posts: 1365
Joined: Fri Sep 11, 2009 8:07 am
Location: Australia
Contact:

Re: 2219 - UI jerky and slow for tracks with no art

Post by Barry4679 »

Barry4679 wrote: Tue Dec 17, 2019 6:56 am
  • I waited for a long time ... you were displaying me the art ... the track is in my MM.db without art (as you can see in the video) ... but you didn't put the overlay icon into the art offering to save it for me.
Follow up question.

I downloaded these two albums from GPM. The woman with the red hat was downloaded with 2219.

The other one I did with an earlier version ... maybe I had "Copy artwork to tags" set differently?

In both cases:
  • the album has been downloaded to my PC, and inserted into MM
  • if I review track Properties there is no local art, ie. neither in the tag, nor in the folder
It is confusing that:
  • I don't have the art locally
  • and that you are showing me the art
  • but in one case you offer me the chance to persist the art, but in the other case you don't?

Is this Working As Designed?
Ludek
Posts: 3666
Joined: Fri Mar 09, 2007 9:00 am

Re: 2219 - UI jerky and slow for tracks with no art

Post by Ludek »

Post Reply