Access violation error on startup, and the MegaDJ script doesn't load. [#14820]]

Beta Testing for Windows Products and plugins

Moderator: Gurus

AnthonyM1229
Posts: 46
Joined: Fri Oct 14, 2011 2:59 pm

Access violation error on startup, and the MegaDJ script doesn't load. [#14820]]

Post by AnthonyM1229 » Sat May 26, 2018 9:22 am

I figured I'd give 1867 a try after I read about Issue 0014820 that tries to correct long load times. MM has always taken around a minute or longer to load for me, but I always thought it's because I have such a huge music library (now over 300k tracks). However, my environment is significantly different: Windows 7 x64, using MM in Portable mode, and no anti-virus (Windows Defender is disabled).

I wasn't expecting much, but didn't think it'd hurt to try anyway, to see if I'd have any decrease in loading times. Well, as it turns out, 1867 causes issues for me. I was greeted with several memory access violation errors on startup, and had to forcefully terminate MM from my task manager. So, I installed the Debug version of 1867 and fired up DebugView. I sent at least one error report with my forum user name @gmail.com as a contact address.

I suspected issues with the MegaDJ extension (http://mediamonkey.com/forum/viewtopic. ... lit=megadj), an extension crucial to my MM experience. Like Magic Nodes, it creates its own node that populates child nodes I created (which function as custom playlists with weighted random shuffling and other criteria). I also made changes to my local copy of the script that make MM switch my playlists on a schedule, and either my changes or the original script, or both, require the script to be loaded on startup. (As a side note, I've been meaning to write a post of some features I'd love to see in MM5, and that would definitely include something replicating MegaDJ's functionality. I still hope to get around to making that post eventually.)

So, I temporarily disabled MegaDJ, and restarted MM. But I still received an access violation error on startup. So, maybe something else is going on? Upon request, I have a ZIP file containing my final debug log and an ELF log that I can send. Should I also file a support ticket? In the meantime, I've reverted to 1864, because I need my music functioning properly, but I'll be happy to test a new update if necessary.

Ludek
Posts: 3087
Joined: Fri Mar 09, 2007 9:00 am

Re: 1867: I get an access violation error on startup, and the MegaDJ script doesn't load.

Post by Ludek » Thu May 31, 2018 5:58 am

Hi, thanks for reporting, re-opened https://www.ventismedia.com/mantis/view ... 820#c50309 and looking into it...

Ludek
Posts: 3087
Joined: Fri Mar 09, 2007 9:00 am

Re: 1867: I get an access violation error on startup, and the MegaDJ script doesn't load.

Post by Ludek » Fri Jun 01, 2018 1:59 am

Could you please try with build 1868 and report whether the issue is resolved for you?
https://www.mediamonkey.com/forum/viewt ... 0b#p445758

AnthonyM1229
Posts: 46
Joined: Fri Oct 14, 2011 2:59 pm

Re: 1867: I get an access violation error on startup, and the MegaDJ script doesn't load.

Post by AnthonyM1229 » Fri Jun 01, 2018 4:42 pm

1868 is working well. I didn't get any access violation errors, and all my extensions loaded properly. Thank you!

Post Reply