iPhone/iPod Touch 2.0 Firmware

Get answers about syncing the current release of MediaMonkey with iPods and other devices.

Moderator: Gurus

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by nynaevelan » Mon Aug 18, 2008 5:36 pm

What if you don't use itunes, will you still get the notification regarding the firmware updates? Can you update the apps without updating the firmware? Can you turn off firmware update notifications?

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

jiri
Posts: 5394
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by jiri » Tue Aug 19, 2008 3:17 am

I see that there is some unnecessary argument in this thread. Let me answer some questions:
It's frustrating to have so little developer feedback at this point because I (we?) have absolutely no way to know if iPhone 2.0 support is slow in coming because:
1) It's very hard or
2) it's not very high priority.
1) Yes, it _is_ very hard. Why? Well, you answered it yourself in your other post later, Apple added a new hashing scheme and did everything to make it as hard as possible to crack for non-Apple developers.
2) It's very hard priority, as iPod/iPhone support has always been for us.
There are groups working on the new hash. I wish the best of luck. http://bluwiki.com/go/Ipodhash is pretty clear on the goal.
Yes, this page summarizes the current progress for those who can understand technical details. Btw, this is a page I created in order to better coordinate the efforts to crack the new hash. So far, Israr is the main (and almost the only one) person working on this.
Good software would check before it would mess up the device that it was not compatible.
I can't fully agree here. MediaMonkey has supported iPods for several years and such problem happened just once, when Apple introduced the first hashing protection with iPod Classic. Now it's the second time out of tens of FW upgrades of many iPod models. So should we let users to use MediaMonkey only on tested FW versions? Well, some time ago my answer would definitely be no, but now that it seems the Apple is even more protective than ever before, we can consider this step.

I hope it explains the current situation, at this moment we really can't tell you more than 'we are trying to find some solution'. If you really need to blame anybody for this, I think that you should start with Apple.

Jiri

DazB
Posts: 409
Joined: Mon Jun 11, 2007 4:09 am
Location: Yorkshire, UK

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by DazB » Tue Aug 19, 2008 5:54 am

Hi,
Jiri wrote:...If you really need to blame anybody for this, I think that you should start with Apple
Apple is merely protecting it's own (financial) interests, just as you should be doing by releasing an update to MM to stop you both losing customers and gaining a bad reputation.

Daz

Carlton Bale
Posts: 11
Joined: Sat Oct 29, 2005 3:01 am

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by Carlton Bale » Tue Aug 19, 2008 8:21 am

I think MediaMonkey should start by releasing an update that prevents corrupting iPhones with 2.0 firmware. If/when the new hash is broken, then release a second update that allows sync with the 2.0 firmware.

You need to look at this from a customer perspective. Our first priority is that we don't want software to corrupt our iPhones. Our second priority is that we want software that allows us to sync without using iTunes. Do what you can to look after your customers. If you can't sync now, fine, but don't let people continue to corrupt their iPhones. I am very displeased that I lost some data on my iPhone due to this problem and I'm very surprised a new version hasn't been released to prevent others from having the same problem.

I'm fine with the fact that I can't use MM to sync. It's not your fault and I know you're working on it. But please don't continue to allow the current version wreck havoc on updated iPhones.

jiri
Posts: 5394
Joined: Tue Aug 14, 2001 7:00 pm
Location: Czech Republic
Contact:

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by jiri » Tue Aug 19, 2008 12:11 pm

Originally we hoped that it will take just a couple of days to crack the new hash, so an update of MM didn't look like a good idea. Now, that it seems that it will take a little longer, we probably will make one.

Jiri

Carlton Bale
Posts: 11
Joined: Sat Oct 29, 2005 3:01 am

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by Carlton Bale » Tue Aug 19, 2008 12:31 pm

This is great news! Thank you very much for the response.

reza666
Posts: 7
Joined: Fri Aug 08, 2008 5:11 pm

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by reza666 » Thu Aug 21, 2008 1:47 pm

@fros1y: Great explanation m8! At least now i understand what the problem is. This is what i expected from the developers to be honest. O well.

@Carlton Bale: I fully Agree! I think MM should at least disable the Sync or give you a BIG warning when you try to sync so that the customers do not trash their Database.
It happened to me and i got pretty pissed, mostly because there were no indication about this from MM. Of course you don't go to forums and read about problems before using your application!!!

And last i want to say that i really love MM so i hope a solution is near.

BTW. I found a nasty bug in MM that i should report but will mention it here. If your mp4 files are associated with MM and you double click it the program will go bananas. I got like 100:s of error windws poping up. Kinda funny really, thought it was a virus or something but it was harmless.

cheers
/Reza

fredguy

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by fredguy » Fri Aug 22, 2008 2:01 pm

Ok, well now i'm kinda pissed of.
I've used MM for some time now, and previously had several MP3 playres and sync went pretty ok. for some reason i couldn't get the sync with mm 3.0.2, and therefore went on the site and there i can see "Sync iPhones, iPods, & MP3 players, converting & leveling tracks on-the-fly."
Wow that rocks !

If only i knew...

It's not much of a matter of i can do or can't... that's ok with me. We got the smartest brains arround the world trying to crack the V2 :) and they can't get it done...yet.

But what pissses me really off is that this issue is know for more than a month, and honnestly, YOU HAVE TO RUN INTO TROUBLE TO FIND THE ISSUE ON THE SITE ! That's not fair.

My phone is screwed now, have to reinstall all the crap and conf etc... Thanks. Comon guys, you lose more money in deceiving guys instead of explaining the issue with mm/V2, and still MM is the best media management soft there is.
Anyway, as of today, i'll remeber that you knew there is some major issue, and didn't do anthing about it. Glad we're not talking avionics here...

Still, keep on with the good work, drop the bad communication and everything will be great !

fred

AltairJr
Posts: 16
Joined: Fri Jan 06, 2006 12:59 am
Location: Boise

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by AltairJr » Sat Aug 23, 2008 12:03 am

fredguy wrote:It's not much of a matter of i can do or can't... that's ok with me. We got the smartest brains arround the world trying to crack the V2 :) and they can't get it done...yet.

But what pissses me really off is that this issue is know for more than a month, and honnestly, YOU HAVE TO RUN INTO TROUBLE TO FIND THE ISSUE ON THE SITE ! That's not fair.
Umm, that's how things usually work. People don't usually check for problems until you have one. If this was a long standing problem (no, 2 1/2 weeks or so is not long standing) than yes, it probably should be on one of the main pages; but seeing as how it is recent (and rather selective - only affects those with the iPhone software upgrade, which isn't free if you remember), you shouldn't expect it to show up anywhere BUT the forums.
fredguy wrote:My phone is screwed now, have to reinstall all the crap and conf etc... Thanks. Comon guys, you lose more money in deceiving guys instead of explaining the issue with mm/V2, and still MM is the best media management soft there is.
Anyway, as of today, i'll remeber that you knew there is some major issue, and didn't do anthing about it. Glad we're not talking avionics here...

Still, keep on with the good work, drop the bad communication and everything will be great !

fred
I don't know how it was so difficult for you to find out about this problem. Sure, if this was back when it first came out (and I mean like hours, not days) I could understand the hardship, but come on - the thing is the very first sticky under Needing Help with Device Synchronization. That, and if that is too much work, a basic google search with terms itouch/iphone, mediamonkey/mm, and update brings up this thread as the first result.

I do understand the frustration - I was a bit upset myself with situation, but that's no reason to be unreasonable with the mm team for a perceived slight regarding providing you with information

scs102

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by scs102 » Sat Aug 23, 2008 5:43 am

I've had the same problem and blame Apple not MM for causing it.

I still think MM should provide a popup warning if attempting to sync.

Is it possible for MM developers to make it sync to the iPhone 2.0 via iTunes instead? e.g. by injecting mouse/keyboard events into the iTunes window based on the user's selections from MM? This way the hash will always work.

Guest

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by Guest » Sat Aug 23, 2008 7:45 am

Yes, I think that is a good idea too. If not, you'll have to do changes everytime iPhone/iTunes is updated with new hashes etc.
Could we get a status report from the crew?

Carlton Bale
Posts: 11
Joined: Sat Oct 29, 2005 3:01 am

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by Carlton Bale » Sat Aug 23, 2008 8:52 am

AltairJr wrote:only affects those with the iPhone software upgrade, which isn't free if you remember
Actually, for the iPhone, the 2.0 software upgrade is free. You only have to pay for it on the Touch. So that's around 14 million iPhone 2Gs that have or will get the software update and around 4 million iPhone 3Gs (and counting) that ship with the 2.0 software. That's a lot of potentially upset customers.

AltairJr
Posts: 16
Joined: Fri Jan 06, 2006 12:59 am
Location: Boise

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by AltairJr » Sat Aug 23, 2008 9:17 am

Carlton Bale wrote:
AltairJr wrote:only affects those with the iPhone software upgrade, which isn't free if you remember
Actually, for the iPhone, the 2.0 software upgrade is free. You only have to pay for it on the Touch. So that's around 14 million iPhone 2Gs that have or will get the software update and around 4 million iPhone 3Gs (and counting) that ship with the 2.0 software. That's a lot of potentially upset customers.
I stand corrected :roll:

JoeyJoJo
Posts: 7
Joined: Mon Jan 28, 2008 8:58 pm

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by JoeyJoJo » Sat Aug 23, 2008 3:57 pm

You guys need to relax about this. The 2.0 firmware has broken ALL third-party tools that sync the iPhone or iPod Touch, including WinAmp and Linux tools such as Amarok or gtkpod. All of these tools will continue to be broken (w.r.t. synching iphone) until the 2.0 firmware DB hash is broken, and no one can predict when that will occur, because it is an extraordinarily difficult process.

Guest

Re: iPhone/iPod Touch 2.0 Firmware isn't compatible with MM

Post by Guest » Sat Aug 23, 2008 4:45 pm

Yes, and therefore I think they should start to think an other way. A way to sync without braking the the hash every time, because Apple will always make new hashes and do what they can so you have to use iTunes.

Locked