last.fm doesn't work

Beta Testing for Windows Products and plugins

Moderator: Gurus

Pman
Posts: 169
Joined: Fri Jan 02, 2009 11:57 am

Re: last.fm doesn't work

Post by Pman » Tue May 31, 2011 6:55 am

- If you skip until the end of the track, it does NOT scrobble.
- If you play +30 seconds of a track and then skip until the end it WILL scrobble.

BUT..............
There's a little annoying thing with it though, if say you had a track <30 secs long (like a typical hip-hop skit, interlude, intro track etc), this will NOT get scrobbled. Not that much of a hassle, but if, like me, you have about 60 odd songs of length <30 secs, these just don't get scrobbled....Shame really
  • W7Ultimate x32 - MM4 - SHABBA!
Image

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: last.fm doesn't work

Post by nynaevelan » Tue May 31, 2011 7:59 am

Yikes, I just realized that my scrobbling stopped working after I upgraded to the latest beta version, I lost 4 days of scrobbling, I will keep my eye out to see if this happens for each upgrade.

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

TedMosby
Posts: 3
Joined: Sat Apr 02, 2011 10:28 am

Re: last.fm doesn't work

Post by TedMosby » Tue May 31, 2011 10:18 pm

nohitter151 wrote:
TedMosby wrote:BUT...

isn't suposed to scrobble a track after 50% or more was played? here, if i skip a track 5 before it ends, won't get scrobled... this isn't suposed to happen, right?
No, the MM scrobbler has never worked that way. When the playcount is increased in MM, then the scrobbler count is submitted too. The MM playcounter only increases when the whole track is played or if you skip to the end of the track.

i was mistaken then, but... it would be nice to add that option. i would very much appreciate it =)... and i won't be the only one who would like this option.....

besides this, thumbs up!! all works perfectly =)...

alystair
Posts: 128
Joined: Sun Jun 07, 2009 7:16 pm

Re: last.fm doesn't work

Post by alystair » Wed Jun 01, 2011 10:31 pm

Uninstalled MediaMonkey totally, removed all extension information... only kept database. Reinstalled MM and new Last.FM plugin, did not work at all as local install... made global install and now only 'now playing' works when only 'Only submit tracks if Album Metadata exists'.... I'm really at a loss here as I'm a pretty avid scrobbler :(

Ok seems to scrobble after a while if I uncheck the 'part of library' bit... don't want to filter out podcasts as that seems to interrupt it as well, but at least it's scrobbling in now.

KJIACC
Posts: 191
Joined: Sun Oct 11, 2009 5:40 am
Location: Магнитогорск. Россия
Contact:

"Exclude tracks that match the following filters"

Post by KJIACC » Thu Jun 02, 2011 8:31 am

"Exclude tracks that match the following filters".
Scrobbling stop if I marked a collection that I created myself.
Is there anyone who has the filter "Exclude ..." works as expected?

1382 1.0.2.26
Win7 x64 Intel Core i3 CPU 540 @ 3.07GHz 3.07 GHz 8 GB RAM NVIDIA GeForce GTS 450
4HD: (C:/D:/ - 1TB) (F:/ - 2TB) (G:/ - 2TB) (H:/ - 3TB)
Screen Resolution 1920x1080
MM runs as administrator.
I'm Tired to post messages using google-translator. I look forward to a forum for Russian-speaking users.

HeinzDo

Re: last.fm doesn't work

Post by HeinzDo » Thu Jun 02, 2011 9:00 am

As user it won't work.
As administrator i gut 100% CPU load. :(

Scam

Re: last.fm doesn't work

Post by Scam » Fri Jun 03, 2011 3:08 pm

Well I can reinstall it to make it work. However, as soon as I stop listening to music and come back to use it later, it will no longer scrobble and I have to reinstall it again. No error codes, just doesn't do anything. The log displays this over and over:
6/3/2011 14:59:42.946: Last.FM: Player got Command wParam (2)
About 20 of those in a row, but never identifies the song. Using most recent versions of MM and last.fm.

Lowlander
Posts: 45921
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: last.fm doesn't work

Post by Lowlander » Fri Jun 03, 2011 3:10 pm

Are you stopping or pausing music playback?

Try to send a debug log and full last.fm log to support for this issue: http://www.mediamonkey.com/forum/viewto ... ?f=6&t=341
Lowlander (MediaMonkey user since 2003)

Scam

Re: last.fm doesn't work

Post by Scam » Sat Jun 04, 2011 3:43 am

OK, it stops scrobbling after about 8 hours whether music is playing or not, nothing to do with stopping or pausing. I no longer have to reinstall, just exit out of MM and reopen it. Here's what the log looks like once it stops scrobbling. Sorry, I don't know how to embed the log.

Code: Select all

6/4/2011 00:52:50.894: Last.FM: NowPlaying Song Death Cab For Cutie - Portable Television
6/4/2011 00:52:56.674: Last.FM: Player got Command wParam (2)
6/4/2011 00:52:56.807: Last.FM: Player got Command wParam (1)
6/4/2011 00:52:56.817: Last.FM: Player got Command wParam (1)
6/4/2011 00:52:56.831: Last.FM: Player got Command wParam (0)
6/4/2011 00:52:56.844: Last.FM: Player got Command wParam (2)
6/4/2011 00:56:55.611: Last.FM: Player got Command wParam (1001)
6/4/2011 00:56:55.634: Last.FM: Submit Started at 1307167015
6/4/2011 00:56:55.701: Last.FM: Player got Command wParam (2)
6/4/2011 00:56:55.904: Last.FM: Player got Command wParam (1)
6/4/2011 00:56:55.913: Last.FM: Player got Command wParam (1)
6/4/2011 00:56:55.922: Last.FM: Player got Command wParam (1)
6/4/2011 00:56:56.024: Last.FM: Player got Command wParam (1)
6/4/2011 00:56:56.039: Last.FM: Player got Command wParam (0)
6/4/2011 00:56:56.050: Last.FM: Player got Command wParam (2)
6/4/2011 01:00:11.987: Last.FM: Player got Command wParam (2)
6/4/2011 01:00:12.002: Last.FM: Player got Command wParam (1001)
6/4/2011 01:00:12.225: Last.FM: Player got Command wParam (1)
6/4/2011 01:00:12.234: Last.FM: Player got Command wParam (1)
6/4/2011 01:00:12.242: Last.FM: Player got Command wParam (1)
6/4/2011 01:00:12.253: Last.FM: Player got Command wParam (2)
6/4/2011 01:00:12.453: Last.FM: Player got Command wParam (1)
6/4/2011 01:00:12.481: Last.FM: Player got Command wParam (0)
6/4/2011 01:00:12.493: Last.FM: Player got Command wParam (2)
6/4/2011 01:00:40.526: Last.FM: Player got Command wParam (2)
6/4/2011 01:00:40.812: Last.FM: Player got Command wParam (1)
6/4/2011 01:00:40.824: Last.FM: Player got Command wParam (1)
6/4/2011 01:00:40.852: Last.FM: Player got Command wParam (0)
6/4/2011 01:00:40.863: Last.FM: Player got Command wParam (2)
6/4/2011 01:04:39.666: Last.FM: Player got Command wParam (1001)
and just keeps going on like that as you continue to play music.

treponem
Posts: 52
Joined: Sat Jan 12, 2008 9:54 am

Re: last.fm doesn't work

Post by treponem » Tue Jun 14, 2011 1:09 pm

Same here, it doesn't scrobble anything. Upgraded to latest MM & plugin. I'll post the log, but Lastfm shows nothing.

Code: Select all

14.06.2011 20:06:56.592: MediaMonkey v4.0.0
14.06.2011 20:06:56.594: Loading Last.fm Scrobbler
14.06.2011 20:06:56.597: ----------------------------------------
14.06.2011 20:06:56.600: Last.fm Scrobbler v1.0.2.26
14.06.2011 20:06:56.602: ----------------------------------------
14.06.2011 20:06:56.618: Last.FM: Player got Command wParam (1)
14.06.2011 20:06:56.621: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:05.344: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:05.347: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:05.350: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:05.920: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:05.924: Last.FM: Player got Command wParam (0)
14.06.2011 20:07:05.931: Last.FM: Player got Command wParam (2)
14.06.2011 20:07:05.953: Last.FM: Nowplaying Play Detected at 1308074825
14.06.2011 20:07:05.960: Last.FM: Handshake Session Started
14.06.2011 20:07:06.914: Last.FM: Handshake OK
14.06.2011 20:07:07.024: Last.FM: Handshake Session ID is fb8d0de5c40c4dfd9ad101d580e1f4f9
14.06.2011 20:07:07.038: Last.FM: Handshake NowPlaying URL is http://post.audioscrobbler.com:80/np_1.2
14.06.2011 20:07:07.085: Last.FM: Handshake Submission URL is http://post2.audioscrobbler.com:80/protocol_1.2
14.06.2011 20:07:07.140: Last.FM: NowPlaying Song Leonard Cohen - Joan of Arc
14.06.2011 20:07:07.275: select Songs.ID from Songs where Songs.id=127896 AND ( mediaaccessible( Songs.IdMedia) OR Songs.CacheStatus=1) 
14.06.2011 20:07:07.536: Last.FM: Player got Command wParam (2)
14.06.2011 20:07:07.638: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:07.642: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:07.645: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:08.797: Last.FM: Player got Command wParam (1)
14.06.2011 20:07:08.840: Last.FM: Player got Command wParam (0)
14.06.2011 20:07:08.843: Last.FM: Player got Command wParam (2)

nohitter151
Posts: 23640
Joined: Wed Aug 09, 2006 10:20 am
Location: NJ, USA
Contact:

Re: last.fm doesn't work

Post by nohitter151 » Tue Jun 14, 2011 1:13 pm

I had the same issue with scrobbling not working at all, but I followed these instructions exactly and it worked after that:
http://www.mediamonkey.com/forum/viewto ... 90#p298355
MediaMonkey user since 2006
Need help? Got a suggestion? Can't find something?

Please no PMs in reply to a post. Just reply in the thread.

alystair
Posts: 128
Joined: Sun Jun 07, 2009 7:16 pm

Re: last.fm doesn't work

Post by alystair » Tue Jun 14, 2011 1:23 pm

Submission rules should really be fixed - this workaround is very silly

nynaevelan
Posts: 5559
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA
Contact:

Re: last.fm doesn't work

Post by nynaevelan » Tue Jun 14, 2011 1:33 pm

alystair wrote:Submission rules should really be fixed - this workaround is very silly

I agree, I hope it it is fixed before the final release but I am optomistic that it will be.
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files

stan9980
Posts: 101
Joined: Tue Nov 06, 2007 6:28 am

Re: last.fm doesn't work

Post by stan9980 » Wed Jun 15, 2011 3:38 am

Just FYI, I switched to the 1.0.2.22 version that was working for me in MM3. Everything seems to work perfectly. Things that should be scrobbled are, things that shouldn't aren't and I don't run into the high cpu issue http://www.mediamonkey.com/forum/viewto ... =6&t=58418. I've now switched to MM4 full time, hurrah!

stan9980

alystair
Posts: 128
Joined: Sun Jun 07, 2009 7:16 pm

Re: last.fm doesn't work

Post by alystair » Tue Jun 21, 2011 8:09 pm

Seems latest version of scrobbler has all functions working correctly. Although I've only tested in 'for everyone' install, not local only. Thanks guys :D

Post Reply