Tagging Inconsistencies 4.0.1 (2014-02-27)

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby monday-friday » Mon Nov 14, 2011 4:03 pm

Hi!
Seems like I have a problem installing Tagging Inconsistencies since I have moved to Win7 (x64).
I have a "Product installation error" window after double-clicking the mmip file, and consequently no node is added to my library. Not being used to this new system yet, I hope I haven't missed something really obvious as I usually do these days (If I have, please accept my apologies in advance).
It has been one of my top 3 add-ons for almost four years now, I would be really sad if I couldn't use it any more...

Thank you for you help!
monday-friday
 
Posts: 14
Joined: Sun May 25, 2008 9:21 am
Location: Helsinki

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby Lowlander » Mon Nov 14, 2011 4:04 pm

monday-friday wrote:I have a "Product installation error" window
See: http://www.mediamonkey.com/support/inde ... ticleid=59
Lowlander
 
Posts: 36645
Joined: Sat Sep 06, 2003 5:53 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby monday-friday » Wed Nov 16, 2011 5:46 am

Thank you a lot for your help. I am not used to this Win7 administrator "protection".
Everything works fine now, I am sorry for not finding the answer myself (but all other addons which I use installed correctly without running MM as administrator...so that is why I was confused!)
monday-friday
 
Posts: 14
Joined: Sun May 25, 2008 9:21 am
Location: Helsinki

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby Evil Overlord » Sun Jan 15, 2012 8:40 am

Similar installation problem.
Win 7 Pro 32
MM 4.02.1462


I run MM as administrator, then double click mmip to install. It says it has installed. However, there is no TI node under "Files to edit". I've done this several times (with restarts, etc), so I'm wondering whether I have several invisible installs somewhere. More to the point, I'm unable to use this great addon.
Evil Overlord
 
Posts: 48
Joined: Mon Jul 13, 2009 2:56 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby Vyper » Sun Jan 15, 2012 9:41 am

Are you looking under the 'Entire Library' node? Look at this:

Image

If I look under 'Files to Edit' under the 'Music Only' node, TI isn't there but if I look under 'Files to Edit' under the 'Entire Library' node, it is. Don't know if that's the way it's supposed to work or not but that's the way mine is working.
Stop Button Freak
Vyper
 
Posts: 845
Joined: Tue May 23, 2006 5:53 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby Evil Overlord » Sun Jan 15, 2012 12:32 pm

@Vyper

Many thanks! You were absolutely right. Problem solved.
Evil Overlord
 
Posts: 48
Joined: Mon Jul 13, 2009 2:56 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby Vyper » Mon Jan 16, 2012 7:17 am

Cool beans. :)
Stop Button Freak
Vyper
 
Posts: 845
Joined: Tue May 23, 2006 5:53 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby zephyr » Thu Feb 09, 2012 2:21 pm

Hi Bex, and all...

I have Tagging Inconsistencies installed. I read it could be used to identify (amongst almost everything else!) inconsistencies with (album|)artist prefixes,

The first thing I noticed upon installation and usage, is the DB inconsistencies. It seems to flag the same issues as the db audit report... I don't know what the issues are, why they are occuring, or how to fix them.

I've tried to maintain the library, and I've ran the cleanup script... but the issues still remain.

They are almost all concerning the beachboys, screen attached.
Image

Any ideas?

THANKS!!

(db audit report info also included)
----Checking Fast Lookup (Join) Tables---
ArtistSongs(Artist) Check Counts OK
ArtistsSongs(Artist) Check Values **ERROR**
---------------------Details-----------------------------
SELECT *
FROM (SELECT Artists.ID AS IDArtist, Artists.Artist AS Artist, Songs.ID AS IDSong, Songs.Artist AS SongsArtist, Songs.SongTitle, Songs.Album
FROM Artists, ArtistsSongs, Songs
WHERE ArtistsSongs.PersonType=1
AND Artists.ID=ArtistsSongs.IDArtist
AND ArtistsSongs.IDSong=Songs.ID)
WHERE SongsArtist NOT LIKE '%'||REPLACE(REPLACE(Artist,'@','@@'),';',';;')||'%'
[IDARTIST] [ARTIST] [IDSONG] [SONGSARTIST] [SONGTITLE] [ALBUM]
[145178] [The Beach Boys] [1469850] [Audio Bullys] [Snake] [Ego War]
[145178] [The Beach Boys] [1469851] [Audio Bullys] [100 Million] [Ego War]
[145178] [The Beach Boys] [1469852] [Audio Bullys] [Way Too Long] [Ego War]
[145178] [The Beach Boys] [1469853] [Audio Bullys] [Turned Away] [Ego War]
[145178] [The Beach Boys] [1469854] [Audio Bullys] [Real Life] [Ego War]
[145178] [The Beach Boys] [1469855] [Audio Bullys] [We Don't Care] [Ego War]
[145178] [The Beach Boys] [1469856] [Audio Bullys] [Face In A Cloud] [Ego War]
[145178] [The Beach Boys] [1469857] [Audio Bullys] [The Tyson Shuffle] [Ego War]
[145178] [The Beach Boys] [1469858] [Audio Bullys] [The Things] [Ego War]
[145178] [The Beach Boys] [1469859] [Audio Bullys] [Veteran] [Ego War]
[145178] [The Beach Boys] [1469860] [Audio Bullys] [The Snow] [Ego War]
[145178] [The Beach Boys] [1469861] [Audio Bullys] [I Go To Your House] [Ego War]
[145178] [The Beach Boys] [1469862] [Audio Bullys] [Hit The Ceiling] [Ego War]
[145178] [The Beach Boys] [1469863] [Audio Bullys] [Ego War] [Ego War]
[152378] [Isolée] [1542179] [Isole´e] [Pictureloved] [We Are Monster]
[152378] [Isolée] [1542180] [Isole´e] [Schrapnell] [We Are Monster]
[152378] [Isolée] [1542181] [Isole´e] [Enrico] [We Are Monster]
[152378] [Isolée] [1542182] [Isole´e] [Madchen Mit Hase] [We Are Monster]
[152378] [Isolée] [1542183] [Isole´e] [My Hi-Matic] [We Are Monster]
[152378] [Isolée] [1542184] [Isole´e] [Do Re Mi] [We Are Monster]
---------------- 20 OF 24 Errors Listed------------

SELECT *
FROM (SELECT Artists.ID AS IDArtist, Artists.Artist AS Artist, Songs.ID AS IDSong, Songs.Author AS Composer, Songs.AlbumArtist, Songs.SongTitle, Songs.Album
FROM Artists, ArtistsSongs, Songs
WHERE ArtistsSongs.PersonType=3
AND Artists.ID=ArtistsSongs.IDArtist
AND ArtistsSongs.IDSong=Songs.ID)
WHERE Composer NOT LIKE '%'||REPLACE(REPLACE(Artist,'@','@@'),';',';;')||'%'
[IDARTIST] [ARTIST] [IDSONG] [COMPOSER] [ALBUMARTIST] [SONGTITLE] [ALBUM]
[184768] [Asa de A´guia] [1889120] [Asa de Águia] [Axe] [Abalou] [Axé Bahia 2004]
---------------- 1 OF 1 Errors Listed------------

ArtistsAlbums(Album) Check LIKE Values **ERROR**
---------------------Details-----------------------------
SELECT *
FROM (SELECT Artists.ID AS IDArtist, Artists.Artist AS Name, Albums.ID As IDAlbum, Albums.Artist AS AlbumArtist
FROM Artists, ArtistsAlbums, Albums
WHERE ArtistsAlbums.IDArtist=Artists.ID
AND ArtistsAlbums.IDAlbum=Albums.ID)
WHERE AlbumArtist NOT LIKE '%'||REPLACE(REPLACE(Name,'@','@@'),';',';;')||'%'
[IDARTIST] [NAME] [IDALBUM] [ALBUMARTIST]
[145178] [The Beach Boys] [149353] [Audio Bullys]
[145178] [The Beach Boys] [149445] [Audio Bullys]
[152378] [Isolée] [158372] [Isole´e]
---------------- 3 OF 3 Errors Listed------------

Songs->Albums: Check Values **ERROR**
---------------------Details-----------------------------
SELECT Songs.ID AS IDSong, Songs.Album AS SongAlbum, Songs.IDAlbum AS IDAlbum, Albums.Album AS Album
FROM Songs, Albums
WHERE Songs.IDAlbum = Albums.ID
AND TRIM(Songs.Album)<>Albums.Album
[IDSONG] [SONGALBUM] [IDALBUM] [ALBUM]
[1871678] [Beyond the Wall] [186947] [Beyond the Wall]
[1871683] [Beyond the Wall] [186947] [Beyond the Wall]
[1871684] [Beyond the Wall] [186947] [Beyond the Wall]
[1871685] [Beyond the Wall] [186947] [Beyond the Wall]
[1871686] [Beyond the Wall] [186947] [Beyond the Wall]
---------------- 5 OF 5 Errors Listed------------
Grateful noob
zephyr
 
Posts: 93
Joined: Fri Oct 07, 2011 2:56 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby zephyr » Mon Feb 13, 2012 12:08 pm

Update:

After some analysis, I think I understand some of the audit errors flagged.

I tried using the following select statement from the audit report with Bex's SQL Viewer, but get errors when running.

SELECT *
FROM (SELECT Artists.ID AS IDArtist, Artists.Artist AS Artist, Songs.ID AS IDSong, Songs.Artist AS SongsArtist, Songs.SongTitle, Songs.Album
FROM Artists, ArtistsSongs, Songs
WHERE ArtistsSongs.PersonType=1
AND Artists.ID=ArtistsSongs.IDArtist
AND ArtistsSongs.IDSong=Songs.ID)
WHERE SongsArtist NOT LIKE '%'||REPLACE(REPLACE(Artist,'@','@@'),';',';;')||'%'
[IDARTIST] [ARTIST] [IDSONG] [SONGSARTIST] [SONGTITLE] [ALBUM]


The errors found are

[145178] [The Beach Boys] [1469850] [Audio Bullys] [Snake] [Ego War]
[145178] [The Beach Boys] [1469851] [Audio Bullys] [100 Million] [Ego War]
[145178] [The Beach Boys] [1469852] [Audio Bullys] [Way Too Long] [Ego War]
[145178] [The Beach Boys] [1469853] [Audio Bullys] [Turned Away] [Ego War]
[145178] [The Beach Boys] [1469854] [Audio Bullys] [Real Life] [Ego War]
[145178] [The Beach Boys] [1469855] [Audio Bullys] [We Don't Care] [Ego War]
[145178] [The Beach Boys] [1469856] [Audio Bullys] [Face In A Cloud] [Ego War]
[145178] [The Beach Boys] [1469857] [Audio Bullys] [The Tyson Shuffle] [Ego War]
[145178] [The Beach Boys] [1469858] [Audio Bullys] [The Things] [Ego War]
[145178] [The Beach Boys] [1469859] [Audio Bullys] [Veteran] [Ego War]
[145178] [The Beach Boys] [1469860] [Audio Bullys] [The Snow] [Ego War]
[145178] [The Beach Boys] [1469861] [Audio Bullys] [I Go To Your House] [Ego War]
[145178] [The Beach Boys] [1469862] [Audio Bullys] [Hit The Ceiling] [Ego War]
[145178] [The Beach Boys] [1469863] [Audio Bullys] [Ego War] [Ego War]

When viewing these tracks, the Artist and Album Artist appear correct. Changing the Album artist does not fix. Removing and re-adding the files does not resolve.
Playing the songs in MM, the tracks are skipped, but the (recently changed and re-added) tracks all play fine in (for example) Winamp.

So, the listed artist for these songs in the ARTIST table is (incorrectly) The Beach Boys?
Why?! And how to fix?!

Any insights most welcome!
Grateful noob
zephyr
 
Posts: 93
Joined: Fri Oct 07, 2011 2:56 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby willyvds » Tue Feb 21, 2012 3:35 pm

Since the conversion from MM3 to MM4, app 5000 tracks (out of our 30000 tracks library) show up in the LastPlayedDate<>LastPlayHistoryDate.
But the LastPlayedDate is exactly equal to the LastPlayHistoryDate.

Any ideas how to resolve this?

regards, Willy
willyvds
 
Posts: 271
Joined: Tue Feb 24, 2009 3:30 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby nynaevelan » Tue Feb 21, 2012 9:39 pm

If memory serves there is a change in the way MM4 is calculating dates, I do not think a solution was ever given, I just added a fake play to the tracks affected in my library.

Nyn
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5558
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby willyvds » Wed Feb 22, 2012 3:19 am

It's not a one-time-problem, sorry for that impression.
They keep popping up if I add playdates using AddRemovePlaystat for the songs I play on the mp3 player.
Maybe TaggingInconsistencies uses another date format than AddRemovePlaystat? Eg with/without the milliseconds?
Regards, Willy
willyvds
 
Posts: 271
Joined: Tue Feb 24, 2009 3:30 pm

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby Mizery_Made » Wed Feb 22, 2012 4:53 am

Actually, it probably has to do with the fact that in MM4, the way the times/dates are stored for plays was changed. They're now saved as UTC times (or whatever) and then in a second column, the offset for your current time zone is saved. However, I don't think the dates/times in the Songs table (LastPlayed, DateModified, etc.) are saved like this. Thus, TI probably needs updating to account for this, instead of a simple column to column compare.
Mizery_Made
 
Posts: 2256
Joined: Tue Aug 29, 2006 1:09 pm
Location: Kansas City, Missouri, United States

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby nynaevelan » Wed Feb 22, 2012 8:58 am

Mizery_Made wrote:Actually, it probably has to do with the fact that in MM4, the way the times/dates are stored for plays was changed. They're now saved as UTC times (or whatever) and then in a second column, the offset for your current time zone is saved. However, I don't think the dates/times in the Songs table (LastPlayed, DateModified, etc.) are saved like this. Thus, TI probably needs updating to account for this, instead of a simple column to column compare.


Bex had mentioned back in the beta phase that an update was needed but he didn't know when he would have the time to complete an update. I think there was an SQL offered that would address this issue, I would suggest you do a search in the beta forum. I am not sure if this would help, but I have this SQL saved in my SQL Viewer script but I do not remember if this is the SQL that would fix it.

Code: Select all
UPDATE Played SET UTCOffset=-'0.166666667' WHERE UTCOffset=''
3.2x - Win7 Ultimate (Zen Touch 2 16 GB/Zen 8GB)
Link to Favorite Scripts/Skins

Join Dropbox, the online site to share your files
nynaevelan
 
Posts: 5558
Joined: Wed Feb 07, 2007 11:07 pm
Location: New Jersey, USA

Re: Tagging Inconsistencies 3.9.4 (2009-01-10)

Postby willyvds » Wed Feb 22, 2012 10:29 am

I don't think I feel confident enough to do this.... a TI update to solve this would be greatly appreciated!
Regards, Willy
willyvds
 
Posts: 271
Joined: Tue Feb 24, 2009 3:30 pm

PreviousNext

Return to Need Help with Addons?

Who is online

Users browsing this forum: Bing [Bot] and 7 guests