Very slow response of year node in navigation view [#18023]

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

Slingers
Posts: 40
Joined: Mon Mar 24, 2008 8:06 pm
Location: Yorkshire, UK

Navigation view - location access is very slow

Post by Slingers »

In the Navigation View the navigating down the tree in the Video/Location View takes an excessive amount of time for each step of the process when the screens are in default view. The same occurs under the music node.

Also - the information does not seem to be being cached so each time it's accessed it takes an age to get to a folder location - many seconds if not minutes.

This is not being reported via the debug log file.

MM 5.0.0.2338 - Windows 10 Pro 64Bit 20H2
Slingers - MM user and promoter for over 15 years
Slingers
Posts: 40
Joined: Mon Mar 24, 2008 8:06 pm
Location: Yorkshire, UK

Very slow response of year node in navigation view [#18023]

Post by Slingers »

When trying to view information in the 'Year' node in the navigation view of any media types, when in default view, each 'branch' of the tree takes many seconds to load with the information not being cached so each access results in a new very slow reload of information. This was instantaneous in MM4

This does not show up in the debug logger

MM 5.0.0.2338 - Windows 10 Pro 64Bit 20H2
Slingers - MM user and promoter for over 15 years
Lowlander
Posts: 50715
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Very slow response of year node in navigation view

Post by Lowlander »

I can reproduce the Decade node on 2415, added as: https://www.ventismedia.com/mantis/view.php?id=18023

However Location isn't slow on 2415, have you tried a optimize database: https://www.mediamonkey.com/wiki/WebHel ... aintenance
Post Reply