[Solved] Waveform area becomes unresponsive [#18035]

Help improve MediaMonkey 5 by testing the latest pre-release builds, and reporting bugs and feature requests.

Moderator: Gurus

tbm72
Posts: 158
Joined: Tue Dec 09, 2008 3:04 pm

[Solved] Waveform area becomes unresponsive [#18035]

Post by tbm72 »

I've had this bug happen numerous times where the waveform preview bar becomes unresponsive to any clicks. I've been trying to find a way to replicate and although this isn't usually the way it happens to me you should be able to repeat it by doing the following:

1) Play any random track from your library
2) Now the track is playing click the album title in the Artwork/preview panel so you're taken to all the tracks on the album
3) Highlight all tracks from the album, right click and go to properties
4) In the Artwork tab tick 'Apply to all selected' and OK

Now the waveform preview area is no longer responsive and can't be clicked on anywhere.
Last edited by tbm72 on Mon Jun 28, 2021 4:37 am, edited 3 times in total.
Lowlander
Posts: 50823
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Waveform area becomes unresponsive

Post by Lowlander »

Which build (Help > About) are you seeing this on? I wasn't able to reproduce on build 2415.
tbm72
Posts: 158
Joined: Tue Dec 09, 2008 3:04 pm

Re: Waveform area becomes unresponsive

Post by tbm72 »

I'm also on build 2415. That's strange, it happens every time on any album for me. Not sure what else is unique to my install - I'm on a portable build, default skin, using the waveform bar instead of seek bar, that's about it I think.
Lowlander
Posts: 50823
Joined: Sat Sep 06, 2003 5:53 pm
Location: MediaMonkey 5

Re: Waveform area becomes unresponsive

Post by Lowlander »

Please capture this in a debug log (step 4b) and attach the log to a Support Ticket: https://www.mediamonkey.com/forum/viewt ... 30&t=86643 A developer will then be able to analyze the log as to why this happens in your setup.
MiPi
Posts: 748
Joined: Tue Aug 18, 2009 2:56 pm
Location: Czech Republic
Contact:

Re: Waveform area becomes unresponsive

Post by MiPi »

There were some stability fixes related to waveforms recently, please test new build 2416, if this issue still persists for you, thanks.
tbm72
Posts: 158
Joined: Tue Dec 09, 2008 3:04 pm

Re: Waveform area becomes unresponsive

Post by tbm72 »

No, I still get this issue after the update. When I get time I'll try and send a debug log.
MiPi
Posts: 748
Joined: Tue Aug 18, 2009 2:56 pm
Location: Czech Republic
Contact:

Re: Waveform area becomes unresponsive

Post by MiPi »

Thanks, already not needed, I was able to reproduce it. Tracked as: https://www.ventismedia.com/mantis/view.php?id=18035
tbm72
Posts: 158
Joined: Tue Dec 09, 2008 3:04 pm

Re: [Solved] Waveform area becomes unresponsive [#18035]

Post by tbm72 »

Confirmed fixed in today's update - thank you!
tbm72
Posts: 158
Joined: Tue Dec 09, 2008 3:04 pm

Re: [Solved] Waveform area becomes unresponsive [#18035]

Post by tbm72 »

This bug seems to have reverted and come back again in the most recent MM update (2337).
MiPi
Posts: 748
Joined: Tue Aug 18, 2009 2:56 pm
Location: Czech Republic
Contact:

Re: Waveform area becomes unresponsive [#18035]

Post by MiPi »

2337 is older 5.0 build, the issue was fixed in build 2417 and was included in all subsequent beta builds, stable 5.0.1 will be released soon hopefully, this fix included.
tbm72
Posts: 158
Joined: Tue Dec 09, 2008 3:04 pm

Re: Waveform area becomes unresponsive [#18035]

Post by tbm72 »

You're right, I'm sorry! I think it's because version 2337 is at the top of the last page in the downloads thread and I wasn't paying attention when I downloaded - will check more carefully next time!
Post Reply