PrettyPictures (Album Art Browser) [MM 3]

Download and get help for different MediaMonkey Addons.

Moderators: Peke, Gurus

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

PrettyPictures (Album Art Browser) [MM 3]

Post by DaledeSilva » Sun Nov 26, 2006 2:32 pm

Hello everyone, Pretty Pictures is currently at BETA version 0.9

It is an organic method of browsing your albums by flicking through their album Art.

here's the link to the page where you can download it and read some information which may not be present in this forum:
http://www.oiltinman.com/downloads/

If at any time you are confused on how to do something with Pretty Pictures, please refer to mediamonkey / help / PrettyPictures Instructions
or
PrettyPictures Help on http://www.oiltinman.com/downloads

ACTIVE X WARNINGS..

if you recieve a warning that the active X control on the page may be unsafe, you need to click "yes" to allow it or most of the functions won't work. If you haven't adjusted your active x settings as explained below.. you may also need to do that:
' ACTIVE X WARNINGS
ActiveX warnings: In Internet Options, Local Intranet zone, enable "Initialise and script ActiveX controls not marked as safe".
If you are still getting the warning messages - try this:
1) Run regedit.exe
2) Goto HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0
3) Modify key 1201 = 0
This enables the above option in your My Computer zone
please enjoy.. and post your comments in this thread.
(there are still a few annoying bugs and unfinished elements - most are listed in my next post - if not listed.. please let me know)

Dale.
Last edited by DaledeSilva on Fri Feb 15, 2008 11:16 am, edited 15 times in total.
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Sun Nov 26, 2006 2:34 pm

Known Issues…

- if you click in the tracklist, tree, or now playing list, Pretty Pictures loses focus. When you click back in Pretty Pictures, you first click will give it focus and do nothing else. This issue is discussed here:
http://www.mediamonkey.com/forum/viewto ... highlight=
(hopefully someone finds a workaround or the Devs are able to alter this in the future).
- single clicking two different albums quickly can be seen as a double click and can also activate a gesture… the second click should only be relevant on the same album and double clicking shouldn’t be able to activate gestures at all.
- If you try to undock the panel or manually resize it AFTER the program has already resized it automatically itself, you will recieve and access violation. It does not cripple the further running of the program though. The easiest way to reposition the panel is to do it when it first starts.

- Currently the installer is set to work with MM v2.5.2.951 and above… this is just left over from Steegy’s script that I used as a template… I would expect that the minimum version would be the first version in which dockable panels were available.. but I’m not aware what version that was at the moment.

TO DO – short term

1- fix memory issues
2- adjust resize window saving (hopefully will fix access violation)
3- fix refreshing issue when same artist
4- more sorting options (eg, by avg rating, by year)
5- merge cache buttons into one that responds to selection
6- prompt user to cache on first run
7- add ability to lock PP from refreshing
8- create settings sheet in preferences to control things like image caching size & expand/contract size.
9- ignore prefixes when sorting by artist (allow defineable prefixes in settings).
10- move prefixes of "_" to beginning of list (based on sort order field as will be defined in edit above)... maybe do this / maybe not?
11- popup album information on rollover of album
12- more sorting options (eg, by tracklist order)
13- create original button icons for the menu and caching buttons
14- upon refresh, if currently playing album is in list, start centred on that. (option in settings? to start at playing / start / middle / end
15- move “show albums without Art”, “show alphabet” and “show alphabet marker” settings into individual minimize and maximize settings so they can be set differently for each view.
16- create a better homepage ;)
17- Make a vertical orientated version

Bugs I need to address:
- Changing from Expand to Contract or vice versa adds shadows to Letter Dividers.
- non art album text centering (non second text adjust should only occur IF the text is wrong - other than that, it should already be moved)
- if stage size difference is too large - don't save new value.
- if detect a small resize... begin monitoring.. if ceasing moving for 0.5 seconds, then save (this may fix the access violation listed below)
- look into acces violation on panel resize / dock / undock... send debug log if necessary.
- problems with apostrophes in album / artist names.

TO DO – long term (definitely not before MM 3.0 is released)

- When clicking on a single file in the track list, it’s album is automatically scrolled to and centred.
- Tint settings (to be able to set the background colour, and tint the albums various colours - & no art text and square)
- abillity to lock the view so it doesn't change when changing nodes. (bring back autorefresh / manual refresh button).
- make a more user friendly design for the visual settings window.
- Make gestures defineable in settings sheet
- make a artist group view in which albums by the same artist are stacked on top of each other and spread out vertically when clicked on.

ORIGINALLY PLANNED ON DOING BUT NOT POSSIBLE IN MM YET

- single clicking on an album that is already centred would hide all the files in the current track view that AREN’T in the album clicked (without going to a new node… (this isn’t possible until a Clear() method is made available (or onFillTracks is able to be activated at times ‘other’ than when clicking on a node) - alternatively, something like removeSelected() but with the ability to give it the index of a track in the list (this would be my preference because it would be quicker (not having to do another SQL query - and could lead to the development of a new way of searching (that I'd make if no one else did)
Last edited by DaledeSilva on Sun Mar 18, 2007 6:53 am, edited 26 times in total.
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

Mizery_Made
Posts: 2283
Joined: Tue Aug 29, 2006 1:09 pm
Location: Kansas City, Missouri, United States

Post by Mizery_Made » Sun Nov 26, 2006 3:06 pm

First of all, I'll tell you now, I didn't read your entire post and thus am not sure what this is spose to do... but I thought I'd check it and see how it works. I hit a brick wall right after installing. Went to start it up and got a problem.

Screen Cap 1

Ignore the black boxes, that's just me being paranoid and blocking all my stuff out. Anyway, that's what I get. I can't make out what it says behind the top box because when I try moving the box I end up with a screen like...

Screen Cap 2

Problem much? Haha. Anyway, another "Error" box pops up like every second so it's impossible to see exactly what the bottom message says entirely. Anyway, don't know if this is an error with your script, error with my computer, or maybe it's because of something I'm missing. Anyway, you might be able to figure out what's up.

PS -- You misspelled "Pictures" in your Topic Title, not sure if you can change it though. Hmm...
Last edited by Mizery_Made on Sun Nov 26, 2006 3:34 pm, edited 1 time in total.

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Post by Bex » Sun Nov 26, 2006 3:13 pm

That's a lot of error boxes you got there in your second picture. :D

Anyway, I'm testing this script now but it's still caching so I'll get back...
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

paulmt
Posts: 1170
Joined: Tue Jul 18, 2006 6:06 pm

Post by paulmt » Sun Nov 26, 2006 3:24 pm

Well done DaledeSilva

Excellent idea and approach, I look forward to seeing your script develop and grow. :)

I also have exactly the same problem after install as described and shown in the screenshots by Mizery_Made

Bex
Posts: 6316
Joined: Fri May 21, 2004 5:44 am
Location: Sweden

Post by Bex » Sun Nov 26, 2006 3:47 pm

Yes, well done. I can see that you have put much work into this...

I don't get the errors the others get but instead I get this:

Code: Select all

Row: 88
ActiveX can't create object: 'SongsDB.SDBApplication'
And then I only see the settings in the PrettyPicture window.
I never see any album arts or anything else...

PS Thanks for the comment within the script :D

Edit, now I also get the errors mention by others
Advanced Duplicate Find & Fix Find More From Same - Custom Search. | Transfer PlayStat & Copy-Paste Tags/AlbumArt between any tracks.
Tagging Inconsistencies Do you think you have your tags in order? Think again...
Play History & Stats Node Like having your Last-FM account stored locally, but more advanced.
Case & Leading Zero Fixer Works on filenames too!

All My Scripts

Teknojnky
Posts: 5524
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Post by Teknojnky » Sun Nov 26, 2006 5:14 pm

I get the same errors as mizery_made.

I used the installer, havent' tried the manual install version.

psyXonova
Posts: 785
Joined: Fri May 20, 2005 3:57 am
Location: Nicosia, Cyprus
Contact:

Post by psyXonova » Sun Nov 26, 2006 5:25 pm

The idea looks really promising besides the fact that from what I can recall this is the first effort to integrate Flash inside MM. I am really going to read your script line by line since I too have some ideas on a flash project...

Anyway, caching completed ok but i get the same error as Bex does...

EDIT: just figured that all the good flash staff is inside the swf and thus not readable. It would be nice if you can post the fla file or just the action script code in a txt

alanl
Posts: 20
Joined: Mon Oct 16, 2006 4:09 pm
Location: Northants, England

Post by alanl » Sun Nov 26, 2006 5:34 pm

The pretty pictures show up OK for me, after caching.

The first time I tried it there appeared to be no relationship between the images and the library, and I got an error message. After re-booting, whenever I move the mouse into the images pane I get the same error message as previously:

ActiveX component can't create object: 'SongsDB.SDBApplication'

and I can't go any further.

I have several other scripts installed, so this may be a conflict. I may get around to disabling them later and trying again.

Whatever, I like the concept a lot. Thanks for all your effort so far, Dale.

Edit: My Music folder and the MediaMonkey settings folder are on a different partition to the program files. Could this cause a problem?

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Sun Nov 26, 2006 9:29 pm

wow... false start!

Mizery_Made... nice artwork.. lol

I've gotten this problem once before but haven't been able to reproduce it... I occured while changing nodes in the tree... have you got any node changes going on on startup? I imagine most people would.

I'm looking into all these problems.. will get back to y'all soon.
(I can actually see the line number from that screenshot so it might help somewhat).

Dale.
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

DiddeLeeDoo
Posts: 1017
Joined: Wed Mar 01, 2006 1:09 am
Location: In a jungle down under
Contact:

Post by DiddeLeeDoo » Sun Nov 26, 2006 9:50 pm

Impressive project. A bit of 'tidy-up' of code and it should be there I think.
Currently have it running and it looks fantastic!

Image

I hope to get some time to provide a bit of 'debug' info.
Image

Teknojnky
Posts: 5524
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Post by Teknojnky » Sun Nov 26, 2006 9:59 pm

DaledeSilva wrote:I've gotten this problem once before but haven't been able to reproduce it... I occured while changing nodes in the tree... have you got any node changes going on on startup? I imagine most people would.

FYI, I am using tweakmonkey to auto-play and to make startup node = now playing.

I will try disabling it and see what happens.


edit:

I disabled tweakmonkey and re-enabled pretty pictures and it didn't give me errors on startup, however as soon as I selected the 'now playing' node, I got the same errors as before.

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Sun Nov 26, 2006 10:51 pm

Hi Guys,

I'm unable to reproduce this error but suspect I may hve fixed it...

can someone please edit PrettyPictures.vbs in the scripts/auto directory

the first block of code.. where it says "Option Explicit"

replace with this:

Code: Select all

Option Explicit
Dim FilePath
Dim CachePath
Dim Mnu, Pnl, AlbumPanel, SlideTmr, qCache, prevListCount, HtmlPnl
Dim lastNode : Set lastNode = SDB.MainTree.Node_Library
Dim WBComplete : WBComplete = False
Dim ImageSize : ImageSize = 250
Dim sImageSize : sImageSize = 100
and let me know if you still get that error

thanks,
Dale.
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

DaledeSilva
Posts: 893
Joined: Sun May 28, 2006 4:22 am
Location: Australia
Contact:

Post by DaledeSilva » Sun Nov 26, 2006 10:59 pm

PS -- You misspelled "Pictures" in your Topic Title, not sure if you can change it though. Hmm...
Mizery_Made, I'm going nuts trying to find this... I can't see it... I had very little sleep last night lol
My Plugins: PrettyPictures [v0.9.2], Forget Crossfade [v1.0], Behind Titlebars [v0.9], Filter Nodes [v1.0.1], View Mode [1.0], BPM.tapper [v1.0]
My Site: http://www.ublik-om.net

Teknojnky
Posts: 5524
Joined: Tue Sep 06, 2005 11:01 pm
Contact:

Post by Teknojnky » Sun Nov 26, 2006 11:01 pm

Ok I modifed the script to include your above modifications, it seems to work now.

However I've come across another error:

Internet explorer script error (not a MM vb script error)

line 89
char 2
error: activex component cant create object songsdb.sdbapplication
code 0
url: file j:\program files\mediamonkey\scripts\auto\prettypictures\flashpage.html

Post Reply